1

Topic: Security update perl-Archive-Tar breaks Spamassasin

The security update perl-Archive-Tar-1.39.1-1.el5_5.1.noarch.rpm will breaks /usr/bin/sa-update from spamassassin-3.2.5-1.el5.x86_64.rpm. For those who is using iRedOS or Centos, pls take note.

https://bugzilla.redhat.com/show_bug.cgi?id=612879

There is a solution for this but I am not sure how to do it...does anyone mind to teach me?

Here's the patch (which I've also attached):

--- Tar.pm.force-numeric-version 2008-08-22 12:32:01.000000000 -0400
+++ Tar.pm 2010-07-13 12:40:49.000000000 -0400
@@ -17,6 +17,7 @@
$WARN                   = 1;
$FOLLOW_SYMLINK         = 0;
$VERSION                = "1.39_01";
+$VERSION                = eval $VERSION;
$CHOWN                  = 1;
$CHMOD                  = 1;
$DO_NOT_USE_PREFIX      = 0;

2

Re: Security update perl-Archive-Tar breaks Spamassasin

Hi,

Just edit the /usr/lib/perl5/vendor_perl/5.8.8/Archive/Tar.pm in like the following (just add the 2nd line):

$VERSION                ="1.39_01";
$VERSION                = eval $VERSION;

3

Re: Security update perl-Archive-Tar breaks Spamassasin

ze wrote:

Hi,

Just edit the /usr/lib/perl5/vendor_perl/5.8.8/Archive/Tar.pm in like the following (just add the 2nd line):

$VERSION                ="1.39_01";
$VERSION                = eval $VERSION;

Thanks...it work smile