1 (edited by bethebeast 2010-06-13 17:53:41)

Topic: Problem after installation

Hi,

I installed iRedMail 0.6.0 in a minimal CentOS 5.5 x86_64 server.

During the install, i have no error, but after rebooting the server, i was unable to login in Roundcube, phpLdapAdmin and Awstats.

In /var/log/maillog i have :

Jun 13 11:49:35 mail postfix/proxymap[4172]: warning: dict_ldap_connect: Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=domain,dc=biz: 49 (Invalid credentials)
Jun 13 11:49:35 mail last message repeated 2 times
Jun 13 11:49:35 mail postfix/trivial-rewrite[6251]: fatal: proxy:ldap:/etc/postfix/ldap_virtual_alias_maps.cf(0,lock|fold_fix): table lookup problem
Jun 13 11:49:35 mail postfix/proxymap[4172]: warning: dict_ldap_connect: Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=domain,dc=biz: 49 (Invalid credentials)
Jun 13 11:49:35 mail last message repeated 2 times
Jun 13 11:49:35 mail postfix/trivial-rewrite[6252]: fatal: proxy:ldap:/etc/postfix/ldap_virtual_alias_maps.cf(0,lock|fold_fix): table lookup problem
Jun 13 11:49:36 mail postfix/smtpd[4607]: warning: problem talking to service rewrite: Success
Jun 13 11:49:36 mail postfix/smtpd[4171]: warning: problem talking to service rewrite: Connection reset by peer
Jun 13 11:49:36 mail postfix/master[3909]: warning: process /usr/libexec/postfix/trivial-rewrite pid 6251 exit status 1
Jun 13 11:49:36 mail postfix/master[3909]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling
Jun 13 11:49:36 mail postfix/smtpd[5656]: warning: problem talking to service rewrite: Success
Jun 13 11:49:36 mail postfix/cleanup[3932]: warning: problem talking to service rewrite: Connection reset by peer
Jun 13 11:49:36 mail postfix/master[3909]: warning: process /usr/libexec/postfix/trivial-rewrite pid 6252 exit status 1

What can i do to resolve this problem ?

Thank you for your help.

Regards.

2

Re: Problem after installation

openldap is not running.

3

Re: Problem after installation

thank you for your answer ZhangHuangbin

ZhangHuangbin wrote:

openldap is not running.

[root@server ~]# ps aux |grep ldap
ldap     10006  0.0  0.2 520480  4476 ?        Ssl  12:56   0:00 /usr/sbin/slapd -h ldap:/// ldaps:/// -u ldap


And i have this error when trying to log in to Roundcube :

Jun 13 13:01:30 mail roundcube: [13-Jun-2010 13:01:30 +0200]: IMAP Error: Authentication for www@domain.biz failed (LOGIN): "a001 NO Temporary authentication failure." (POST /mail/?_task=&_action=login)

4

Re: Problem after installation

Sorry, it should be incorrect bind dn and password in postfix lookup file:

Jun 13 11:49:35 mail postfix/proxymap[4172]: warning: dict_ldap_connect: Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=domain,dc=biz: 49 (Invalid credentials)

5

Re: Problem after installation

ZhangHuangbin wrote:

postfix lookup file

where is this file, in /etc/postfix ?

6

Re: Problem after installation

i haven't found the solution, so i re-install iRedMail, and now it's ok.

thank you... wink