1 (edited by hata_ph 2010-06-04 08:36:01)

Topic: clamav 0.96.1 new update? [SOLVED]

I notice my clamav for my iRedOS-5 is not up-to-date....i try to run yum install  but cannot find it...

Last ClamAV update process started at Mon May 31 23:13:43 2010

Last Status:
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.96 Recommended version: 0.96.1
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cvd is up to date (version: 52, sigs: 704727, f-level: 44, builder: sven)
    Trying host db.my.clamav.net (211.239.150.206)...
    Downloading daily-11106.cdiff [100%]
    Downloading daily-11107.cdiff [100%]
    daily.cld updated (version: 11107, sigs: 84208, f-level: 51, builder: arnaud)
    bytecode.cld is up to date (version: 21, sigs: 3, f-level: 51, builder: nervous)
    Database updated (788938 signatures) from db.my.clamav.net (IP: 211.239.150.206)
    Clamd successfully notified about the update.

2

Re: clamav 0.96.1 new update? [SOLVED]

Did you try 'yum upgrade'?

3

Re: clamav 0.96.1 new update? [SOLVED]

Try yum upgrade but still no show version 0.96.1...

4

Re: clamav 0.96.1 new update? [SOLVED]

0.96.3 is in yum repository: http://iredmail.org/yum/rpms/5/

Try to clear yum cache first, and then run 'yum upgrade':

# yum clean all
# yum upgrade

5 (edited by hata_ph 2010-06-01 13:57:44)

Re: clamav 0.96.1 new update? [SOLVED]

I did try yum clean all and yum upgrade but still cannot...

I can manually download the file from the iRedMail repo but when I run yum update or yum upgrade it does not detect the new version....

[root@mail ~]# wget http://www.iredmail.org/yum/rpms/5/clam … f.i386.rpm
--2010-06-01 13:54:51--  http://www.iredmail.org/yum/rpms/5/clam … f.i386.rpm
Resolving www.iredmail.org... 74.220.219.116
Connecting to www.iredmail.org|74.220.219.116|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2166194 (2.1M) [text/plain]
Saving to: `clamav-0.96-3.el5.rf.i386.rpm'

100%[=======================================================================================================================================>] 2,166,194    109K/s   in 28s

2010-06-01 13:55:26 (74.8 KB/s) - `clamav-0.96-3.el5.rf.i386.rpm' saved [2166194/2166194]

6 (edited by hansolo 2010-06-02 02:46:40)

Re: clamav 0.96.1 new update? [SOLVED]

I'm sorry to use your post, but I'm having the same issue.

I check ' /var/log/messages ' and I get:

freshclam[20646]: Your ClamAV installation is OUTDATED!
freshclam[20646]: Local version: 0.96 Recommended version: 0.96.1
freshclam[20646]: DON'T PANIC! Read http://www.clamav.net/support/faq

and checking 'ClamAV':

rpm -qi clamav
Name        : clamav                       Relocations: (not relocatable)
Version     : 0.96                              Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
Release     : 3.el5.rf                      Build Date: Mon 03 May 2010 12:20:55 AM CEST
Install Date: Thu 20 May 2010 01:05:27 PM CEST      Build Host: lisse.hasselt.wieers.com
Group       : Applications/System           Source RPM: clamav-0.96-3.el5.rf.src.rpm

rpm -qa | grep clam
clamav-0.96-3.el5.rf
clamav-db-0.96-3.el5.rf
clamav-0.96-3.el5.rf
clamd-0.96-3.el5.rf

gives me ver. 0.96-3.el5

But at a closer look it seems that

freshclam[20646]: Local version: 0.96 Recommended version: 0.96.1

FRESHCLAM is outdated not ClamAV

Giving 'yum update '

yum update clamav
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* addons: ftp.xxxxx
* base: ftp.xxxxx
* extras: ftp.xxxxx
* updates: ftp.xxxxx
10 packages excluded due to repository priority protections
Setting up Update Process
No Packages marked for Update

doesn't find anything to update
and I can't find the solution neither. Googling around gives no straight solution ...

So, if anybody has the answer, please help

Thank you
Regards,
Thomas

7 (edited by hansolo 2010-06-02 04:11:56)

Re: clamav 0.96.1 new update? [SOLVED]

sorry for bloating your post but I was eager to get it update I ran into another error:

My steps were:
1. finding clamav-0.96.1  rpm in Repo's (found RPMForge / DAG and ATrpms

2. enabling Repo to update Clamav - meaning to add repo's to YUM:

vim /etc/yum.repos.d/ATrpms.repo
[atrpms]
name=Fedora Core $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/el$releasever-$basearch/atrpms/stable
http://ftp.tu-chemnitz.de/pub/linux/ATr … ms/stable/
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms
gpgcheck=1
priority=1
enabled=0

vim /etc/yum.repos.d/DAG.repo
[dag]
name=RPMforge $releasever - $basearch - DAG
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag/
http://ftp.tu-chemnitz.de/pub/linux/dag … /RPMS.dag/
gpgkey=http://ftp.tu-chemnitz.de/pub/linux/dag/RPM-GPG-KEY.dag.txt
gpgcheck=1
priority=1
enabled=0

Now when I added Repo's I check with YUM:

#yum --enablerepo=dag update clamav
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* addons: mirror.lihnidos.org
* base: mirror.lihnidos.org
* extras: mirror.lihnidos.org
* updates: mirror.lihnidos.org
210 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.96.1-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================
Package                      Arch                         Version                                  Repository                 Size
====================================================================================================================================
Updating:
clamav                       x86_64                       0.96.1-1.el5.rf                          dag                       2.2 M

Transaction Summary
====================================================================================================================================
Install       0 Package(s)
Upgrade       1 Package(s)

Total download size: 2.2 M
Is this ok [y/N]: y
Downloading Packages:
clamav-0.96.1-1.el5.rf.x86_64.rpm                                                                            | 2.2 MB     00:04     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
dag/gpgkey                                                                                                   | 1.6 kB     00:00     
Importing GPG key 0x6B8D79E6 "Dag Wieers (Dag Apt Repository v1.0) <dag@wieers.com>" from http://ftp.tu-chemnitz.de/pub/linux/dag … EY.dag.txt
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test

Transaction Check Error:
  file /etc/freshclam.conf from install of clamav-0.96.1-1.el5.rf.x86_64 conflicts with file from package clamav-0.96-3.el5.rf.i386
  file /usr/share/man/man1/clamscan.1.gz from install of clamav-0.96.1-1.el5.rf.x86_64 conflicts with file from package clamav-0.96-3.el5.rf.i386
  file /usr/share/man/man1/freshclam.1.gz from install of clamav-0.96.1-1.el5.rf.x86_64 conflicts with file from package clamav-0.96-3.el5.rf.i386
  file /usr/share/man/man1/sigtool.1.gz from install of clamav-0.96.1-1.el5.rf.x86_64 conflicts with file from package clamav-0.96-3.el5.rf.i386
  file /usr/share/man/man5/freshclam.conf.5.gz from install of clamav-0.96.1-1.el5.rf.x86_64 conflicts with file from package clamav-0.96-3.el5.rf.i386

Error Summary
-------------

And now I get this errors....

How to solve it ( except installing /downloading RPM manually and then having trouble with dependencies) ?

Thanks
Regards,
Thomas

8

Re: clamav 0.96.1 new update? [SOLVED]

I just check my iRedOS and it is install with clamav-0.96.3 but freshclam.log is reporting my clamav is out of date.......

9

Re: clamav 0.96.1 new update? [SOLVED]

hata_ph wrote:

I just check my iRedOS and it is install with clamav-0.96.3 but freshclam.log is reporting my clamav is out of date.......

Check 'rpm -qa | grep clam' to be sure.
I thought it was 0.96.3 version too, but 'rpm -qa' gave me version 0.96-3 , which was still not 0.96.1 

The diferrence is in .3 and -3

10

Re: clamav 0.96.1 new update? [SOLVED]

You are correct...my clamav version is showing clamav-0.96-3 too...
could that be the problem that freshclam is saying out clamav is out-of-date??

11

Re: clamav 0.96.1 new update? [SOLVED]

clamav-0.96.1-1 is avalable in yum repository now. Thanks for your remind. (And i was wrong in above post, sorry)

12

Re: clamav 0.96.1 new update? [SOLVED]

ZhangHuangbin wrote:

clamav-0.96.1-1 is avalable in yum repository now. Thanks for your remind. (And i was wrong in above post, sorry)

Great,
just do:
yum clean all
yum list all
... and finally
yum update clamav

13

Re: clamav 0.96.1 new update? [SOLVED]

ZhangHuangbin wrote:

clamav-0.96.1-1 is avalable in yum repository now. Thanks for your remind. (And i was wrong in above post, sorry)

Yes. freshclam no more saying my clamav is out-of-date..thanks

14 (edited by hoho 2010-06-09 15:36:37)

Re: clamav 0.96.1 new update? [SOLVED]

I saw that there are total three packages related to clamav when using yum update list

clamav                              i386       0.96.1-1.el5.rf                iRedMail     2.1 M
clamav-db                           i386       0.96.1-1.el5.rf                iRedMail      23 M
clamd                               i386       0.96.1-1.el5.rf                iRedMail     229 k

When typing yum update clamav, only two packages showing to be updated.==================================================================================================
Package             Arch              Version                        Repository             Size
==================================================================================================
Updating:
clamav              i386              0.96.1-1.el5.rf                iRedMail              2.1 M
Updating for dependencies:
clamd               i386              0.96.1-1.el5.rf                iRedMail              229 k

Transaction Summary
==================================================================================================
Install      0 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

Total download size: 2.3 M
Is this ok [y/N]:

So, I think the updating command should be " yum update clam* " - Thanks ZhangHuangbin

After upgrading process, restart the clamd and freshclam service

If got the below error:

service clamd restart
Stopping Clam AntiVirus Daemon:                            [  OK  ]
Starting Clam AntiVirus Daemon: LibClamAV Warning: Detected duplicate databases /var/clamav/main.cvd and /var/clamav/main.cld, please manually remove one of them         [  OK  ]

simply delete the older one (date) and run again.
Here is the reference: http://www.gossamer-threads.com/lists/c … sers/39516