1 (edited by White 2010-04-12 06:07:14)

Topic: clamd does not start for me in 0.6.0-RC1

Hi,

clamd did not start with error

Starting Clam AntiVirus Daemon: ERROR: Please define server type (local and/or TCP).

Had a look into /etc/clamd.conf and truely, LocalSocket was still commented out.
Diff to a still running 0.5.1 setup showed that it's normally not not commented out.

So I diff'ed the two clamd packages installed on the systems
0.5.1 => clamd-0.95.2-4.el5.rf
0.6.0-rc1 => clamd-0.96-1.el5.rf

And looking into the packages it looks like the default for the LocalSocket configuration does indeed differ.

So in essence what I did:
- removed the # infront of the LocalSocket line and see, it works

What would fix the root cause
Option 1: Fix the package in the repo to have the correct default value
Option 2: Fix the clamav.sh install script and change the line

perl -pi -e 's#^(LocalSocket).*#${1} $ENV{'CLAMD_LOCAL_SOCKET'}#' ${CLAMD_CONF}

to something like the following (completly untested, just out of my mind)

perl -pi -e 's-^#?(LocalSocket).*-${1} $ENV{'CLAMD_LOCAL_SOCKET'}-' ${CLAMD_CONF}

hope the helps, however I wonder why no-one else did ever come across that problem - hm

2

Re: clamd does not start for me in 0.6.0-RC1

Fixed in iRedMail -current. Thanks for your report and solution smile

3

Re: clamd does not start for me in 0.6.0-RC1

Just to add that this is only relevant to iRedOS/Redhat/CentOS

I'm running 0.6.0-rc1 on Debian, and had no problems with Clamd.

4

Re: clamd does not start for me in 0.6.0-RC1

derchris wrote:

Just to add that this is only relevant to iRedOS/Redhat/CentOS

I'm running 0.6.0-rc1 on Debian, and had no problems with Clamd.

Yes, RHEL/CENTOS only.