1

Topic: How do I add a transport

Hi:

I want to add a transport (to gmail) entry as follows:

<mydomain.com>     smtp:[smtp.gmail.com]:587

Do I edit the /etc/postfix/transport file and reference it as: hash:/ in main.cf or do I do it through the ldap formatted files? If ldap, how do I do that?

Cheers,
Dave

2

Re: How do I add a transport

Add it in LDAP: Add new attribute 'mtaTransport', use 'smtp:[smtp.gmail.com]:587' as its value.
Format of value is same as hash file.

3

Re: How do I add a transport

Hi:

Thanks for the reply.  I'm new to OpenLDAP - where do I put that entry in the directory tree?  I've attached an image of my directory tree.

Cheers,
Dave

Post's attachments

ldap_img.jpg
ldap_img.jpg 43.5 kb, 2 downloads since 2010-03-24 

You don't have the permssions to download the attachments of this post.

4

Re: How do I add a transport

hmm, my answer is not clear, sorry.

Click 'domainName=xxx', and then click 'add new attribute' in the right panel, choose 'mtaTransport' in the drop-down box.

If you have iRedAdmin-Pro installed, you can manage it in domain profile page:
http://iredmail.googlecode.com/hg/screenshots/iredadmin/domain_profile_relay.png

5

Re: How do I add a transport

Hi:

I don't see mtaTransport in the dropdown list.  Can I just type it in the text box and hit "Add"? BTW: I'll also be picking up the professional version for my client once I ge this working. It looks good.

Cheers,
Dave

6

Re: How do I add a transport

i'm on my phone and can't post screenshot now, i will post it later.

You can try iRedAdmin-Pro in our demo site:
http://www.iredmail.org/admin_demo.html

7

Re: How do I add a transport

Well, it may be my another mistake, domainName=xxx should already have attribute 'mtaTransport' with default value 'dovecot'.
Just change 'dovecot' to 'smtp:[xxx]:25' and save your change.

8

Re: How do I add a transport

Ah perfect, thanks I'll try that.

9

Re: How do I add a transport

Hi Zhang:

I changed the LDAP mtaTransport settings and  I get the following message in my logs when I send a message from an outside account:

Recipient address rejected: User unknown in virtual mailbox table (state 14).

It doesn't seem to be relaying mail to gmail. Probably a policy thing - do you know which policy I should change?

So the sending process is: <any outside account> -> <iRedmail relay to Gmail> -> <Gmail account>

Cheers,
Dave

10

Re: How do I add a transport

Hi Zhang: 

I'm getting a little further.  I get this in a bounce at Gmail and in my logs:

Must issue a STARTTLS command first. 4sm583751fgg.7 (in reply to MAIL FROM
   command)......

I know Gmail requires TLS, how do I turn that on in iRedmail? It seems to be set to Opportunistic in main.cf so that seems good but Gmail doesn't seem to recognize it somehow.

Cheers,
Dave

11

Re: How do I add a transport

Try either:

:smtp.gmail.com:587
:[smtp.gmail.com]:587

12

Re: How do I add a transport

Yep, that got me a little further.  I now get the following message in my maillog:

<dcook@gogridworkz.com>: Recipient address rejected: User unknown in virtual mailbox table;

So that makes sense because I don't have a local account in iRedmail.  How do I pass the message on to my Gmail account without getting this message?  I know it's probably a policy setting but which one do I change?

Cheers,
Dave

13

Re: How do I add a transport

Hi Zhang:

Do I need to use SASL Authentication?  If so, do I set that up in LDAP?  (or how do I set that up).

Cheers,
Dave

14

Re: How do I add a transport

Hi Zhang: 

Here's my latest log message (the dreaded Gmail StartTLS message):
...
Mar 25 16:46:50 mail2 postfix/smtp[14349]: 1E7B4201E0: to=<dcook@gogridworkz.com>, relay=smtp.gmail.com[72.14.221.111]:587, delay=0.62, delays=0.02/0.01/0.46/0.13, dsn=5.7.0, status=bounced (host smtp.gmail.com[72.14.221.111] said: 530 5.7.0 Must issue a STARTTLS command first. d4sm414560fga.25 (in reply to MAIL FROM command))
...

I've tried every combination of relay commands.  Gmail definitely seems to like smtp:[smtp.gmail.com]:587 (with or without MX lookups).  I don't know if the current iRedmail vanilla configuration likes port 587.  I can telnet to the iRedMail mail server and STARTTLS is there when I EHLO mail2.gogridworkz.com.  I even type: STARTTLS and I get the TLS ready prompt no problem.

I can connect from an email client like Thunderbird and use TLS on port 587 - again, no problem.  Somehow we need to send down my SMTP-AUTH credentials to the Gmail servers from within iRedmail.

BTW: smtp.gmail.com is really a CNAME record that goes to: ASPMX.L.GOOGLE.COM if that is any help. Could it be a Certificate issue?

Anyway, I'm heading out now and I'll catch up with you guys tomorrow.

Cheers,
Dave