1

Topic: Helo command rejected: need fully-qualified hostname

==== Required information ====
- iRedMail version: 0.8.7 (Pro 1.8.2)
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Debian Wheezy
- Related log if you're reporting an issue:
====

When sending mail to my server some users get rejected with this error:
Mail delivery failed: returning message to sender

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

  firstname.lastname@myserver.no
    SMTP error from remote mail server after RCPT TO:<firstname.lastname@myserver.no>:
    host XX.XXX.62.110 [XX.XXX.62.110]: 504 5.5.2 <XX.XXX.62.73>:
    Helo command rejected: need fully-qualified hostname

Any clue to fix this? What is it on my server who rejects this? (any way to bypass it?)

2

Re: Helo command rejected: need fully-qualified hostname

*) Does your user has SMTP authentication enabled in mail client application (Outlook, Thunderbird, ...)?
*) Show us output of command "postconf smtpd_recipient_restrictions" please.

3

Re: Helo command rejected: need fully-qualified hostname

I am not able to change/chech anything on the senders side, it is some kind of local govenment (prety static)

I get this output:
root@post:~# postconf smtpd_recipient_restrictions
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:127.0.0.1:7777, check_policy_service inet:127.0.0.1:10031, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
root@post:~#

4

Re: Helo command rejected: need fully-qualified hostname

Please show me output of "postconf smtpd_helo_restrictions".

5

Re: Helo command rejected: need fully-qualified hostname

root@post:~# postconf smtpd_helo_restrictions
smtpd_helo_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_helo_access pcre:/etc/postfix/helo_access.pcre
root@post:~#

6

Re: Helo command rejected: need fully-qualified hostname

The issue seems to have been solved now, maby the admin of the other server have fetched the error message and fixed it.
Anyway, again, thanks for the fast reply ZhangHuangbin