1 (edited by bijuedathodi 2014-06-16 18:02:07)

Topic: upgrade from 0.8.5 - 0.8.6 ,Iread admin pro 2.0-2.1

Usinng CentOs CentOs 6.3 x86_64+ iRedmail 0.8.5+ Iredadmin Pro Ldap 2.0

I need to update IRedadmin Pro Ldap 2.0 - 2.1 Pls help server is already Live ,so i need to make this upgrade error free

I have Some doubts over phpmyadmin upgrading.Since my mysql version is 5.3 .What should i do with below steps found on Phpmyadmin upgrade.Do i need to run script in below lines

Please see below lines

You should not copy libraries/config.default.php over config.inc.php because the default configuration file is version- specific.
If you have upgraded your MySQL server from a version previous to 4.1.2 to version 5.x or newer and if you use the phpMyAdmin configuration storage, you should run the SQL script found in examples/upgrade_tables_mysql_4_1_2+.sql.

Presently my package not includes cluebringer so i am skipping that part.

My entire upgrade procedure given below.Please correct me if anything found wrong

Steps Upgrading from 0.8.5 – 0.8.6
1. Update /etc/iredmail-release with iRedMail version number
File: /etc/iredmail-release
0.8.6

2. Upgrade Roundcube webmail to the latest 0.9.5
Satisfied with older version , so not updating

3. Upgrade/iRedAPD/1.4.1-1.4.2
•    This tutorial describes how to upgrade iRedAPD-1.4.1 or later versions to the latest stable release, iRedAPD-1.4.3. It's applicable on all Linux/BSD distributions supported by iRedMail.
•    If you're looking for upgrade tutorial for iRedAPD-1.3.8 or earlier versions, please use this tutorial: How to upgrade iRedAPD-1.3.8 (or earlier versions) to iRedAPD-1.4.1 or later versions

Steps:
•    Download the latest stable release here: http://iredmail.org/yum/misc/ For example, iRedAPD-1.4.3.tar.bz2.
•    Upload it to your iRedMail server. Assume it's /root/iRedAPD-1.4.3.tar.bz2 on the server.
•    Extract downloaded package and move to /opt/.
Terminal:
# tar xjf /root/iRedAPD-1.4.3.tar.bz2 -C /opt/
You get a new directory: /opt/iRedAPD-1.4.3/.
•    Set correct owner and permission:
Terminal:
# chown -R iredapd:iredapd /opt/iRedAPD-1.4.3
# chmod -R 0700 /opt/iRedAPD-1.4.3
•    Copy config file from iRedAPD-1.4.1 release. WARNING: You cannot use config file from iRedAPD-1.3.8 or earlier versions directly, they have different syntax.
Terminal:
# cd /opt/iRedAPD-1.4.3/
# cp -p /opt/iRedAPD-1.4.1/settings.py /opt/iRedAPD-1.4.3/
# chown -R iredapd:iredapd settings.py
# chmod -R 0600 settings.py
WARNING: Config file /opt/iredapd/settings.py contains sensitive infomation (username, password), please don't make it world-readable. Permission 0600 is the best.
•    Remove symbol link of old release:
Terminal:
# rm -i /opt/iredapd               # <- Don't not end with '/'.
•    Create symbol link to the latest release:
Terminal:
# cd /opt/
# ln -s iRedAPD-1.4.3 iredapd
•    Copy new RC script for your server. We have scripts for different Linux/BSD distributions. Please copy the proper one for your server. For example:
/opt/iredapd/rc_scripts/iredapd.rhel: For Red Hat, CentOS, Scientific Linux.
# cp /opt/iredapd/rc_scripts/iredapd.rhel /etc/init.d/iredapd
# chmod +x /etc/init.d/iredapd
•    Restart iRedAPD service:
Terminal:
#
# ---- On Linux ----
#
# /etc/init.d/iredapd restart

4.Upgrade iRedAdmin Pro 2.0 – 2.1 (Using 2.1.1 package for this upgrade)

Below are steps used to upgrade iRedAdmin-Pro-LDAP from 2.0 to v2.1:
•    Download iRedAdmin-Pro-LDAP-2.1 source tarball. All customers can get download link with below steps if you have iRedAdmin-Pro-LDAP-1.7.0 or later version installed:
o    Login to iRedAdmin-Pro as global admin
o    Click "License" on the top-right corner, it will show you basic license info and a "Download" button if new version is available for upgrading.
•    Copy or upload iRedAdmin-Pro-LDAP-2.1 to your server which has iRedAdmin-Pro-LDAP-2.0 running. We assume you copy it to /root/iRedAdmin-Pro-LDAP-2.1.tar.bz2.
•    Extract v2.1 source tarball, copy config file (settings.ini) from old version v2.0 directly, then convert it to new config file format (Python source file)
•    Set correct file owner and permission, restart Apache web server.
For Red Hat Enterprise Linux, CentOS, Scientific Linux
Terminal:
# tar xjf /root/iRedAdmin-Pro-LDAP-2.1.tar.bz2 -C /var/www/
# cd /var/www/
# cp iRedAdmin-Pro-LDAP-2.0/settings.ini iRedAdmin-Pro-LDAP-2.1/
# cd iRedAdmin-Pro-LDAP-2.1/
# bash tools/convert_ini_to_py.sh settings.ini
# rm -f settings.ini
# cd ../
# rm -i iredadmin                              # <- This is a symbol link.
# ln -s iRedAdmin-Pro-LDAP-2.1 iredadmin            # <- Create new symbol link.
# chown -R iredadmin:iredadmin iRedAdmin-Pro-LDAP-2.1/
# chmod -R 0555 iRedAdmin-Pro-LDAP-2.1/
# chmod 0400 iRedAdmin-Pro-LDAP-2.1/settings.py
# /etc/init.d/httpd restart

5. Upgrade phpMyAdmin to the latest stable release

Simply copy config.inc.php from your previous installation into the newly unpacked one. Configuration files from old versions may require some tweaking as some options have been changed or removed. For compatibility with PHP 6, remove a set_magic_quotes_runtime(0); statement that you might find near the end of your configuration file.
You should not copy libraries/config.default.php over config.inc.php because the default configuration file is version- specific.
If you have upgraded your MySQL server from a version previous to 4.1.2 to version 5.x or newer and if you use the phpMyAdmin configuration storage, you should run the SQL script found in examples/upgrade_tables_mysql_4_1_2+.sql.



6.Enable Opportunistic TLS support in Postfix when sending mail to remote SMTP server

This feature is used to secure your mail transaction when sending email from your iRedMail server (Postfix) to remote SMTP server. Refer to Postfix document for more technical details: http://www.postfix.org/postconf.5.html# … rity_level
•    Add required parameters in Postfix:
Terminal:
# postconf -e smtp_tls_security_level='may'
# postconf -e smtp_tls_CAfile='$smtpd_tls_CAfile'
•    Then restart Postfix service:
Terminal:
# ---- On Linux ----
# /etc/init.d/postfix res


FINISH

2

Re: upgrade from 0.8.5 - 0.8.6 ,Iread admin pro 2.0-2.1

bijuedathodi wrote:

I have Some doubts over phpmyadmin upgrading.Since my mysql version is 5.3 .What should i do with below steps found on Phpmyadmin upgrade.Do i need to run script in below lines
Please see below lines
You should not copy libraries/config.default.php over config.inc.php because the default configuration file is version- specific.
If you have upgraded your MySQL server from a version previous to 4.1.2 to version 5.x or newer and if you use the phpMyAdmin configuration storage, you should run the SQL script found in examples/upgrade_tables_mysql_4_1_2+.sql.

Please copy only 'config.inc.php' under old phpMyAdmin. We don't use the phpMyAdmin configuration storage, so no need to execute the SQL scripts.

if you're not sure what to do with the upgrade tutorials, maybe it's better to purchase our remote upgrade service.