1

Topic: Internal Server Error - After upgrade to iRedMail-Pro-1.8.2

==== Required information ====
- iRedMail version: 0.8.4
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Ubuntu precise (12.04.1 LTS)
- Related log if you're reporting an issue:

Hi, I have upgraded following http://www.iredmail.org/wiki/index.php? … 8.1-1.8.2.
I am getting an internal server error when going to the properties of an account.
I have a feeling this is because of iRedMail version is only 0.8.4? Sorry.
I will purchase remote upgrade tomorrow if you can do the upgrade (around Tuesday, 20 May 2014 at 6:00:00 a.m. in Beijing).

====

[Mon May 19 23:53:54 2014] [error] [client ] Traceback (most recent call last):
[Mon May 19 23:53:54 2014] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 242, in process
[Mon May 19 23:53:54 2014] [error] [client ]     return self.handle()
[Mon May 19 23:53:54 2014] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 233, in handle
[Mon May 19 23:53:54 2014] [error] [client ]     return self._delegate(fn, self.fvars, args)
[Mon May 19 23:53:54 2014] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 415, in _delegate
[Mon May 19 23:53:54 2014] [error] [client ]     return handle_class(cls)
[Mon May 19 23:53:54 2014] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 390, in handle_class
[Mon May 19 23:53:54 2014] [error] [client ]     return tocall(*args)
[Mon May 19 23:53:54 2014] [error] [client ]   File "/usr/share/apache2/iredadmin/controllers/decorators.py", line 11, in proxyfunc
[Mon May 19 23:53:54 2014] [error] [client ]     return func(self, *args, **kw)
[Mon May 19 23:53:54 2014] [error] [client ]   File "/usr/share/apache2/iredadmin/controllers/mysql/user.py", line 329, in GET
[Mon May 19 23:53:54 2014] [error] [client ]     domain_settings = iredutils.convert_sql_account_settings_to_dict(domain_profile['settings'])
[Mon May 19 23:53:54 2014] [error] [client ] KeyError: 'settings'

2

Re: Internal Server Error - After upgrade to iRedMail-Pro-1.8.2

I have a feeling I may need you to upgrade these packages also..
I don't mind having to pay for more support tickets..

Roundcube webmail current version 0.8.6 (Latest 1.0.1)
phpMyAdmin current version 3.4.10.1deb1 (Latest 4.2.0)
iRedAdmin current version ? (Latest 0.3.1?)
iRedAPD current version 1.4.0 (Latest 1.4.3)

Thanks for your response, this is urgent for me.

3

Re: Internal Server Error - After upgrade to iRedMail-Pro-1.8.2

As mentioned in iRedAdmin-Pro download page, the latest iRedAdmin-Pro requires iRedMail-0.8.7, so please upgrade your iRedMail to 0.8.7 first. Also, please upgrade iRedAPD to the latest iRedAPD-1.4.3.

Remote iRedMail upgrade service will cost $99 for upgrading to the release immediately follow your current release. For example:

- Upgrade from 0.8.4 to 0.8.5, $99.
- Upgrade from 0.8.5 to 0.8.6, $99.
- Upgrade from 0.8.6 to 0.8.7, $99.

Personally, i suggest you try to upgrade it yourself, our upgrade tutorials are available here:
http://www.iredmail.org/doc.html#upgrade_tutorial

4

Re: Internal Server Error - After upgrade to iRedMail-Pro-1.8.2

Thanks Zhang for your first class support.
With the help of your easy remote support my system is back in action.

Highly recommend this solution to anyone, I wont go anywhere else.

5

Re: Internal Server Error - After upgrade to iRedMail-Pro-1.8.2

Thanks for purchasing our remote support service. I hope you enjoy iRedMail + iRedAdmin-Pro. smile