1

Topic: I can't receive mail with smtp server setting IPv6, somebody help me?

==== Required information ====
- iRedMail version: 0.8.6
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):  ldap
- Linux/BSD distribution name and version: Ubuntu 13.04
- Related log if you're reporting an issue:
====

I reference the "enabling ipv6 for your iredmail (Postfix/Dovecot)" on the website
http://www.iredmail.org/forum/topic1968 … vecot.html

My mail server is setting static ip [fc00::10]

1.This is my postfix config for main.cf
inet_protocols = ipv4, ipv6

2.This is my dovecot config for dovecot.conf
listen = *, [::]

3.Then restart the dovecot and postfix

4.Send a test mail for IPv6, this is my config
SMTP Port=25, SMTP Server=fc00::10

5.It still can't receive any mails on roundcube with IPv6 but setting smtp with IPv4 is working

6.Should I config "Roundcube" to enable IPv6 ? or which config file I missing to enable IPv6?

Somebody can help me? Thanks a lot!!

2

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

*) Excuse me, what do you mean "can't receive any mails on roundcube with IPv6"? Check emails with Roundcube via IPv6 http address?
*) Any related error log in Postfix log file (/var/log/mail.log)?

3

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Hi,
I want to send a email from client via smtp server IP address is setting on IPv6 [fc00::10]
[fc00::10] is my mail server static IP, but I can't receive the email on roundcube

I have configured the postfix and dovecot like this article :
http://www.iredmail.org/forum/topic1968 … vecot.html

Anything else I have to enable IPv6 for iRedMail or Roundcube?
Thanks!

4 (edited by Vincent CY 2014-02-27 14:23:37)

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Hi,
Sorry I got some error log from (/var/log/mail.log)

Feb 21 08:40:55 mail postfix/smtpd[15935]: warning: non-SMTP command from unknown[fc00::7ce3:bec7:1e39:4e03]: Subject: AlertMail-137: (INFO) AlertMail Test Message
Feb 21 08:40:55 mail postfix/smtpd[15935]: disconnect from unknown[fc00::7ce3:bec7:1e39:4e03]
Feb 21 08:41:18 mail postfix/smtpd[15935]: connect from unknown[fc00::7ce3:bec7:1e39:4e03]
Feb 21 08:41:18 mail postfix/smtpd[15935]: improper command pipelining after MAIL from unknown[fc00::7ce3:bec7:1e39:4e03]: RCPT TO:
Feb 21 08:41:18 mail postfix/smtpd[15935]: NOQUEUE: reject: RCPT from unknown[fc00::7ce3:bec7:1e39:4e03]: 450 4.7.1 <postmaster@test.com>: Recipient address rejected: Access denied; from=<AlertMail@test.com> to=<postmaster@test.com> proto=SMTP helo=<[192.168.100.49]>
Feb 21 08:41:18 mail postfix/smtpd[15935]: warning: non-SMTP command from unknown[fc00::7ce3:bec7:1e39:4e03]: Subject: AlertMail-138: (INFO) AlertMail Test Message
Feb 21 08:41:18 mail postfix/smtpd[15935]: disconnect from unknown[fc00::7ce3:bec7:1e39:4e03]
Feb 21 08:44:38 mail postfix/anvil[15952]: statistics: max connection rate 3/60s for (smtp:fc00::7ce3:bec7:1e39:4e03) at Feb 21 08:40:08
Feb 21 08:44:38 mail postfix/anvil[15952]: statistics: max connection count 1 for (smtp:fc00::7ce3:bec7:1e39:4e03) at Feb 21 08:39:21
Feb 21 08:44:38 mail postfix/anvil[15952]: statistics: max cache size 1 at Feb 21 08:39:21


*[fc00::7ce3:bec7:1e39:4e03] is my client IP address

5

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Vincent CY wrote:

Feb 21 08:40:55 mail postfix/smtpd[15935]: warning: non-SMTP command from unknown[fc00::7ce3:bec7:1e39:4e03]: Subject: AlertMail-137: (INFO) AlertMail Test Message
Feb 21 08:41:18 mail postfix/smtpd[15935]: improper command pipelining after MAIL from unknown[fc00::7ce3:bec7:1e39:4e03]: RCPT TO:

Looks like your mail client is not a RFC-Compatible mail client. May i know which mail client you used to send email?
Did you try again with Thunderbird/Outlook?

6 (edited by Vincent CY 2014-02-25 11:09:13)

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Hi,
I use my server manager system to send alert mail,
My alert mail configuration:
Email Address = postmaster@test.com
Sender Domain = test.com
SMTP Port = 25
SMTP Server = fc00::13 (if set IPv4 here, will receive the alert mail but IPv6 it's not work with error log)

7

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Vincent CY wrote:

SMTP Server = fc00::13 (if set IPv4 here, will receive the alert mail but IPv6 it's not work with error log)

Looks like bug in your management system, maybe it doesn't support IPv6?

Also, does the server/service work if you send email with Thunderbird/Outlook or other mail client program (with IPv6 address)?

8 (edited by Vincent CY 2014-02-27 14:18:36)

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Hi,
I try to comment all about the "smtp_restriction" in /etc/postfix/main.cf then IPv6 service is working now !!
Thanks for your help.

9

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

Vincent CY wrote:

I try to comment all about the "smtp_restriction" in /etc/postfix/main.cf then IPv6 service is working now !!

Please do not comment out them.

You can try to remove restriction rules in 'smtpd_*_restriction" one by one to check which rule causes this issue, but please do not comment out 'smtpd_*_restriction' settings.

10

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

His problem is the same as everyone else : cluebringer v 2.0.x has no IPv6 support !

Is there an easy way to deactivate the module responsible for this :
Feb 21 08:41:18 mail postfix/smtpd[15935]: NOQUEUE: reject: RCPT from unknown[fc00::7ce3:bec7:1e39:4e03]: 450 4.7.1 <postmaster@test.com>: Recipient address rejected: Access denied; from=<AlertMail@test.com> to=<postmaster@test.com> proto=SMTP helo=<[192.168.100.49]>

11

Re: I can't receive mail with smtp server setting IPv6, somebody help me?

b.cherrier wrote:

Is there an easy way to deactivate the module responsible for this :

You have to turn on debug mode in Cluebringer, then check its log file.