1 (edited by s2500110 2014-03-04 01:42:06)

Topic: upgrade roundcube to 0.9.5

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
======== Required information ====
- iRedMail version: iRedAdmin-Pro-LDAP-1.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: CentOS 5.9
- Related log if you're reporting an issue:
====
I want to upgrade roundcube to 0.9.5, but when I upgrade it, it show  MySQL:  NOT OK(PHP >= 5.3 required)

I search the install requirements by http://trac.roundcube.net/wiki/Howto_Requirements
I know the problem is MySQL database driver requires PHP 5.3 or newer.

My question is :  if I upgrade php to 5.4, does it work at iRedAdmin-Pro-LDAP-1.8.1 and later?
(I search requirements of iRedAdmin-Pro, it seem don't need php , is it ?)

Thanks a lot.
Regards,
Andy

2

Re: upgrade roundcube to 0.9.5

*) The latest Roundcube webmail requires PHP>=5.3. If you upgrade PHP to 5.4, it will work.
*) iRedAdmin-Pro is not written in PHP programming language, so it doesn't need PHP at all.