1 (edited by clovis86 2014-03-04 23:12:17)

Topic: mailbox down since apt-get upgrade

======== Required information ====
- iRedMail version:  0.8.5
- Store mail accounts in which backend :  MYSQL
- Linux/BSD distribution name and version: Debian 7.4
- Related log if you're reporting an issue:
====


Hello Ired support big_smile

Unfortunately, i needed to launch an apt-get upgrade on my mail server, then reboot it .

Since then, I'm not able to receive/send mail.

Here is the /var/log/mail.log error

Mar  4 15:38:29 dedie postfix/scache[6886]: statistics: start interval Mar  4 15:35:09
Mar  4 15:38:29 dedie postfix/scache[6886]: statistics: domain lookup hits=0 miss=1 success=0%
Mar  4 15:38:29 dedie postfix/scache[6886]: statistics: address lookup hits=0 miss=1 success=0%
Mar  4 15:40:09 dedie postfix/qmgr[5762]: B46CDE14EA: from=<www-data@mydomain.fr>, size=536, nrcpt=1 (queue active)
Mar  4 15:40:09 dedie postfix/qmgr[5762]: 494E0E1664: from=<www-data@mydomain.fr>, size=536, nrcpt=1 (queue active)
Mar  4 15:40:09 dedie postfix/qmgr[5762]: ED438DFD35: from=<myname@mydomain.fr>, size=3772373, nrcpt=1 (queue active)
Mar  4 15:40:09 dedie postfix/smtp[7352]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar  4 15:40:09 dedie postfix/smtp[7353]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar  4 15:40:09 dedie postfix/smtp[7352]: B46CDE14EA: to=<www-data@mydomain.fr>, relay=none, delay=8708, delays=8708/0.04/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Mar  4 15:40:09 dedie postfix/smtp[7352]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar  4 15:40:09 dedie postfix/smtp[7353]: 494E0E1664: to=<www-data@mydomain.fr>, relay=none, delay=4208, delays=4208/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Mar  4 15:40:09 dedie postfix/smtp[7352]: ED438DFD35: to=<friend@gmail.com>, relay=none, delay=17529, delays=17529/0.07/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Mar  4 15:43:30 dedie postfix/scache[7356]: statistics: start interval Mar  4 15:40:09
Mar  4 15:43:30 dedie postfix/scache[7356]: statistics: domain lookup hits=0 miss=1 success=0%
Mar  4 15:43:30 dedie postfix/scache[7356]: statistics: address lookup hits=0 miss=1 success=0%
Mar  4 15:45:02 dedie postfix/pickup[5761]: 6C626E1650: uid=33 from=<www-data>
Mar  4 15:45:02 dedie postfix/cleanup[7577]: 6C626E1650: message-id=<20140304144502.6C626E1650@myserver.fr>
Mar  4 15:45:02 dedie postfix/qmgr[5762]: 6C626E1650: from=<www-data@ns387706.ip-myMailserverIP.eu>, size=584, nrcpt=1 (queue active)
Mar  4 15:45:02 dedie postfix/local[7579]: 6C626E1650: to=<www-data@ns387706.ip-176-31-251.eu>, orig_to=<www-data>, relay=local, delay=0.12, delays=0.08/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to mailbox)
Mar  4 15:45:02 dedie postfix/qmgr[5762]: 6C626E1650: removed


Here is the list of packages I updated :

The following packages will be upgraded:
  apache2 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common base-files curl file libapache2-mod-php5
  libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libcurl3 libgnutls26 libmagic1 libpq5 libssl1.0.0 linux-libc-dev
  locales multiarch-support openssl owncloud php-pear php5 php5-cli php5-common php5-curl php5-gd php5-imap php5-intl
  php5-ldap php5-mcrypt php5-mysql php5-pgsql php5-sqlite tzdata wget whois
40 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Here is my iptables print just in case it is needed :

iptables -L
Chain INPUT (policy DROP)
target     prot opt source               destination         
ACCEPT     all  --  anywhere             anywhere             state RELATED,ESTABLISHED
ACCEPT     all  --  anywhere             anywhere           
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:http
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:https
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:smtp
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:submission
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:pop3
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:pop3s
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:imap2
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:imaps
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:snpp
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:25000
ACCEPT     tcp  --  anywhere             anywhere             tcp dpts:40000:42000
ACCEPT     icmp --  anywhere             anywhere             icmp echo-request

Chain FORWARD (policy DROP)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination



Can my apache2/php5 can be too "new" for my 0.8.5 IredMail version ?
Can an update to 0.8.6 can help me get my mailbox working again ?

Everything seems to work perfect except sending and receiving mails .... sad

Will appreciate help here a lot smile


Clovis

2

Re: mailbox down since apt-get upgrade

Hi,

What is the configuration of your server? Is it having minimum 1gb RAM as it is required to run iredmail smoothly.

It seems it is having amavisd/clamd service issues.

try restarting services if it starts without issues, if it throws errors then send respective logs for review.

service amavisd restart for example

You can also try disabling amavisd to check the issue furthermore.

You can do this by using following wiki article:

Let us know by applying some of these above stated solutions and its respective results.

3 (edited by clovis86 2014-03-04 23:43:57)

Re: mailbox down since apt-get upgrade

Hi,

thanks for the quick reply !

well, i got a dedicated server from OVH provider with 4 Gb of ram, workgin flawessly for a year now until this update command ..

try to restart all services you're talking about without any error, and problem is still there  sad

killed them also, with same result

4

Re: mailbox down since apt-get upgrade

Hi Clovis,

Did you try disabling amavisd from article and checked if its running or not?

or simply try disabling following line from your /etc/postfix/main.cf file

content_filter = smtp-amavis:[127.0.0.1]:10024

Restart postfix service and see the results.

5 (edited by clovis86 2014-03-05 00:07:40)

Re: mailbox down since apt-get upgrade

hanks Ketan for your help :

I removed the line from the main.cf and restarted postfix.

here is the mail.log :

Mar  4 17:03:26 dedie postfix/master[14958]: terminating on signal 15
Mar  4 17:03:27 dedie postfix/master[15289]: daemon started -- version 2.9.6, configuration /etc/postfix
Mar  4 17:03:27 dedie postfix/qmgr[15293]: 7FDD2E15C5: from=<www-data@pafo.fr>, size=536, nrcpt=1 (queue active)
Mar  4 17:03:27 dedie postfix/smtp[15295]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar  4 17:03:27 dedie postfix/smtp[15295]: 7FDD2E15C5: to=<www-data@pafo.fr>, relay=none, delay=12805, delays=12805/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

still refused connection

6

Re: mailbox down since apt-get upgrade

It seems postfix is still trying to access amavisd module.

Try

# postconf -e content_filter=''
# /etc/init.d/postfix restart
# postqueue -f

try stopping amavisd service and see the output of your emails.

7

Re: mailbox down since apt-get upgrade

Wow, it's working !

Just received all today's mails big_smile

really appreciate a lot !

So, if I understand well, now i don't have antivirus scanning and spamassassin enabled ?

Is it permanent or will I have to do it on each reboot ?
Maybe, the bette will be for me now to upgrade to latest IredMail and do a full backup, then reinstall my server from scratch ?

any idea welcomed smile

8

Re: mailbox down since apt-get upgrade

Yes currently your server is not scanning spams as it is disabled from postfix.

your amavisd.conf file is having config issues. might be SQL DNS password. verify with your .tips file and modify any changes. re-enable same settings from main.cf and start amavisd serivice.