1

Topic: disable too many errors after RCPT blocking of incoming mail

==== Required information ====
- iRedMail version: 1.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): mysql
- Linux/BSD distribution name and version: debian 6
- Related log if you're reporting an issue: /var/log/mail.log
====

Hello to all, i recently installed a mailcleaner box in front of iredmail, mailcleaner has a feature to validate if the destination address is valid doing a smtp connection to iredmail's smtp port, becasuse of this, there is a lot of  destination address probes coming from the mailcleaner ip, after a while all connection coming from mailcleaner are being blocked by iredmail with this messages in the logs:

Feb 28 15:34:06 mail postfix/smtpd[21119]: too many errors after RCPT from unknown[192.168.150.205]
Feb 28 15:34:06 mail postfix/smtpd[21119]: disconnect from unknown[192.168.150.205]

How can i put in a whitelist mailcleaner so this restriction does not apply to it?
Or is that is not posible i dont care to completely disable such feature, is that posible?
regards

2

Re: disable too many errors after RCPT blocking of incoming mail

I guess your mailcleaner application validates destination address with SMTP command 'VRFY', if so, please try to update below parameter in Postfix config file /etc/postfix/main.cf like below, restart/reload Postfix service and try again:

disable_vrfy_command=no