1

Topic: create_mail_user_OpenLDAP.sh problem

I got the following error when try to add a domain with users.
----------
Add new domain: domain.com.
adding new entry "domainName=domain.com,o=domains,dc=acumensystem,dc=com"
ldapadd: Undefined attribute type (17)
        additional info: enableMailService: attribute type undefined

adding new entry "ou=Users,domainName=domain.com,o=domains,dc=acumensystem,dc=com"
ldapadd: No such object (32)
        matched DN: o=domains,dc=acumensystem,dc=com

adding new entry "ou=Groups,domainName=domain.com,o=domains,dc=acumensystem,dc=com"
ldapadd: No such object (32)
        matched DN: o=domains,dc=acumensystem,dc=com

adding new entry "ou=Aliases,domainName=domain.com,o=domains,dc=acumensystem,dc=com"
ldapadd: No such object (32)
        matched DN: o=domains,dc=acumensystem,dc=com

adding new entry "mail=michael@domain.com,ou=Users,domainName=domain.com,o=domains,dc=acumensystem,dc=com"
ldapadd: No such object (32)
        matched DN: o=domains,dc=acumensystem,dc=com

adding new entry "mail=karen@domain.com,ou=Users,domainName=domain.com,o=domains,dc=acumensystem,dc=com"
ldapadd: No such object (32)
        matched DN: o=domains,dc=acumensystem,dc=com
----------

how to fix it? Thanks.

2

Re: create_mail_user_OpenLDAP.sh problem

Which version of iRedMail do you use? And the script?

3

Re: create_mail_user_OpenLDAP.sh problem

I am using 0.5.0-rc1 with CentOS 5.2.

4

Re: create_mail_user_OpenLDAP.sh problem

        additional info: enableMailService: attribute type undefined

It says LDAP attribute 'enableMailService' is not defined in ldap schema files. This attribute was used in iRedMail-0.3.2 and prevous versions, deprecated since 0.4.0, replaced by 'enabledService'.

Do you use create_mail_user_OpenLDAP.sh shipped in 0.5.0-rc1?
I tested it before, work as expect. Could you please try again?

5

Re: create_mail_user_OpenLDAP.sh problem

The one I use is download from google code, I can sure I only download the 0.5.0-rc1 and install in a fresh install Centos~~
So, what can I do now? re-run the setup script? will it be make all re-install again? Or, do I need to try a new OS install? Also, can I use CentOS 5.3? Thanks!

6

Re: create_mail_user_OpenLDAP.sh problem

iredmail support centos 5.3,  now iredmail not support reinstall. so suggest you fresh install and try it.

I think it is no problem.

7

Re: create_mail_user_OpenLDAP.sh problem

acumen wrote:

The one I use is download from google code, I can sure I only download the 0.5.0-rc1 and install in a fresh install Centos~~
So, what can I do now? re-run the setup script? will it be make all re-install again? Or, do I need to try a new OS install? Also, can I use CentOS 5.3? Thanks!

Open this script, change 'enableMailService' to 'enabledService'.