1

Topic: Error whne after upgradgin to iRedAdmin-Pro-LDAP-2.1

Hi,

I've got an error whne after upgradgin to iRedAdmin-Pro-LDAP-2.1 :
[Mon  ] [error] [client ] Traceback (most recent call last):
[Mon  ] [error] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 242, in process
[Mon  ] [error] [error] [client ]     return self.handle()
[Mon  ] [error] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 233, in handle
[Mon  ] [error] [error] [client ]     return self._delegate(fn, self.fvars, args)
[Mon  ] [error] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 415, in _delegate
[Mon  ] [error] [error] [client ]     return handle_class(cls)
[Mon  ] [error] [error] [client ]   File "/usr/lib/pymodules/python2.7/web/application.py", line 390, in handle_class
[Mon  ] [error] [error] [client ]     return tocall(*args)
[Mon  ] [error] [error] [client ]   File "/usr/share/apache2/iredadmin/controllers/decorators.py", line 11, in proxyfunc
[Mon  ] [error] [error] [client ]     return func(self, *args, **kw)
[Mon  ] [error] [error] [client ]   File "/usr/share/apache2/iredadmin/controllers/ldap/user.py", line 217, in GET
[Mon  ] [error] [error] [client ]     throttleLib = throttle.Throttle()
[Mon  ] [error] [error] [client ] NameError: global name 'throttle' is not defined

is it true that if I change this configuration?
#/usr/share/apache2/iredadmin/settings.py
policyd_enabled = False


running well by disabling it
just to make sure only

#Ubuntu 12.04.LTS
#iRedMail-0.8.6
#iRedAdmin-Pro-LDAP-2.1.1

2

Re: Error whne after upgradgin to iRedAdmin-Pro-LDAP-2.1

Please try below steps:

1: Restart Apache service.
2: Delete all records in SQL table "iredadmin.sessions".
3: Login to iRedAdmin-Pro and try again.

3

Re: Error whne after upgradgin to iRedAdmin-Pro-LDAP-2.1

Thanks, it works

change back  to default
#/usr/share/apache2/iredadmin/settings.py
policyd_enabled = True