1

Topic: MXToolbox saying May Be Open Relay

Using CentOS 6, IredMail 0.8.6
This is what MXToolbox reports when testing:

smtp     mail.northstarhome.com     SMTP Server Disconnected     May be an open relay.      More Info

with the following details:

Transcript: Connecting to 216.83.****

220 mail.northstar***.com ESMTP Postfix [668 ms]
EHLO MXTB-PWS3.mxtoolbox.com
250-mail.northstar***.com
250-PIPELINING
250-SIZE 15728640
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN [639 ms]
MAIL FROM: <supertool@mxtoolbox.com>

SendSMTPCommand: You hung up on us after we connected. Please whitelist us. (connection lost)

MXTB-PWS3v2 2285ms

I have added the domain to the whitelist to no avail.  I also found that any Yahoo address trying to send to this domain was throwing the same error.  Adding Yahoo.com to the whitelist fixed the yahoo problem.  Please advise?  Thanks.

2

Re: MXToolbox saying May Be Open Relay

pjohnson wrote:

SendSMTPCommand: You hung up on us after we connected. Please whitelist us. (connection lost)

Please show us Postfix log related to this smtp session.

3

Re: MXToolbox saying May Be Open Relay

This is what appears in the log after running mxtoolbox health report:

ec 30 17:49:50 mail postfix/smtpd[4601]: lost connection after CONNECT from unknown[186.32.209.112]
Dec 30 17:49:50 mail postfix/smtpd[4601]: disconnect from unknown[186.32.209.112]
Dec 30 17:49:50 mail postfix/smtpd[4601]: connect from unknown[186.32.209.112]
Dec 30 17:49:50 mail postfix/smtpd[4601]: lost connection after CONNECT from unknown[186.32.209.112]
Dec 30 17:49:50 mail postfix/smtpd[4601]: disconnect from unknown[186.32.209.112]
Dec 30 17:52:46 mail postfix/smtpd[4618]: connect from unknown[64.20.227.133]
Dec 30 17:52:47 mail postfix/smtpd[4618]: lost connection after EHLO from unknown[64.20.227.133]
Dec 30 17:52:47 mail postfix/smtpd[4618]: disconnect from unknown[64.20.227.133]
Dec 30 17:52:49 mail postfix/smtpd[4618]: connect from unknown[64.20.227.133]
Dec 30 17:52:50 mail postfix/smtpd[4618]: lost connection after EHLO from unknown[64.20.227.133]
Dec 30 17:52:50 mail postfix/smtpd[4618]: disconnect from unknown[64.20.227.133]

4

Re: MXToolbox saying May Be Open Relay

Postfix log is helpless. Any related log in other log files under /var/log/? e.g. cbpolicyd.log?

5 (edited by pjohnson 2014-01-03 06:23:44)

Re: MXToolbox saying May Be Open Relay

The only thing that looks relevant is in the sieve.log and shows the following:

Jan 02 14:18:50 lda(policyd): Fatal: setgid(2000(vmail) from mail_gid setting) failed with euid=2003(policyd), gid=2003(policyd), egid=2003(policyd): Operation not permitted (This binary should probably be called with process group set to 2000(vmail) instead of 2003(policyd))

Also just realized I'm getting this from my cron response emails in the postmaster account:

/bin/sh: /usr/sbin/policyd-cleanup: No such file or directory

6

Re: MXToolbox saying May Be Open Relay

Do you have package "policyd" or "cluebringer" installed? Is it running and listening on port 10031?

7

Re: MXToolbox saying May Be Open Relay

ZhangHuangbin wrote:

Do you have package "policyd" or "cluebringer" installed? Is it running and listening on port 10031?

I believe so, I just installed the iredmail package as delivered and explained on the installation page.  I can see that cluebringer is running.  It appears that policyd is only invoked occassionaly when trying to send email from yahoo so about 90% of all yahoo email gets rejected immediately without showing a log in policyd at all, but when a yahoo email is successful, a policyd log item shows up.  I have used the standard installation without changing anything.