1

Topic: Problem with mysql dependencies on iRedMail installation

Hello,

I'm trying to install iRedMail 0.8.5 on a CentOS 6.5 using MySQL backend, but I'm getting the following dependencies error messages at the end of the proccess:

Transaction Check Error:
  file /usr/lib64/mysql/libmysqlclient.so.18.0.0 from install of mariadb-libs-5.
5.33a-1.el6.x86_64 conflicts with file from package compat-mysql55-5.5.34-1.el6.
remi.x86_64
  file /usr/libexec/dovecot/managesieve conflicts between attempted installs of
dovecot-1:2.0.21-2.el6.x86_64 and dovecot-managesieve-2:0.2.6-22.el6.x86_64
  file /usr/libexec/dovecot/managesieve-login conflicts between attempted instal
ls of dovecot-1:2.0.21-2.el6.x86_64 and dovecot-managesieve-2:0.2.6-22.el6.x86_6
4
  file /usr/lib64/dovecot/lib90_sieve_plugin.so conflicts between attempted inst
alls of dovecot-pigeonhole-2:0.2.6-22.el6.x86_64 and dovecot-1:2.0.21-2.el6.x86_
64
  file /usr/lib64/dovecot/libdovecot-sieve.so.0.0.0 conflicts between attempted
installs of dovecot-pigeonhole-2:0.2.6-22.el6.x86_64 and dovecot-1:2.0.21-2.el6.
x86_64

2

Re: Problem with mysql dependencies on iRedMail installation

Hmm, package conflicts.

*) MySQL has some files conflict with MariaDB. So please remove MariaDB first if you don't need it.
*) Please remove Dovecot related package first.

Is this a newly installed server os? Why it has MariaDB and Dovecot installed?

3

Re: Problem with mysql dependencies on iRedMail installation

No, it's not a new server. Someone that I don't know has configured the enviroment. I just need to install the email server stack. Strangely, I can't remove mariadb and dovecot packages via yum because it says that the package is not installed!
 
yum remove maria

> updates: mirror.symnds.com
Package(s) mariadb* available, but not installed.
No Packages marked for removal

4

Re: Problem with mysql dependencies on iRedMail installation

You can check what packages were installed with "rpm -qa", then remove the one you want. for example:

# rpm -qa | grep -i 'maria'

5

Re: Problem with mysql dependencies on iRedMail installation

The shell returned nothing to the grep command.

[root@mail iRedMail-0.8.5]# rpm -qa | grep -i 'maria'
[root@mail iRedMail-0.8.5]#

6

Re: Problem with mysql dependencies on iRedMail installation

No MariaDB related packages installed? Then it may be not removed completely, you can remove the conflict file directly like this:

/usr/lib64/mysql/libmysqlclient.so.18.0.0

The same to Dovecot conflict files (again, check installed package first, if not installed, remove conflict files directly).