1

Topic: Python Version Broke iRedmail

Updated packages through Webmin big mistake that was. As python upgraded to version 3 something now iRedMail is broken as it depends on version 2.4+ so now nothing is configured correctly and I keep getting errors complaining that, mod_wsgi is not using the correct version of python. I can't even access /iredadmin login.

Any suggestions or am I going to have to start all over with fresh install?


==== Required information ====
- iRedMail version: iRedMail-0.8.4 
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Ubuntu Linux 12.04.2
- Related log if you're reporting an issue:
====

2

Re: Python Version Broke iRedmail

Is it possible to downgrade to Python 2.x? And bring mod_wsgi back?

3

Re: Python Version Broke iRedmail

ZhangHuangbin wrote:

Is it possible to downgrade to Python 2.x? And bring mod_wsgi back?


I did downgrade to the previous version but I still get the same error it seems like nothing is linking up to the version of python I downgraded to. mod_wsgi shows in the error logs as using 3.x when should be using 2.x not sure how to fix this I have tried removing and installing mod_wsgi but still get the same error

4

Re: Python Version Broke iRedmail

Is /usr/bin/python a symbol link to python3 or python2?