1

Topic: configuration problem.

Setting up Install Process
Package mysql-server-5.1.47-4.el6.x86_64 already installed and latest version
Package mysql-5.1.47-4.el6.x86_64 already installed and latest version
Package httpd-2.2.15-5.el6.x86_64 already installed and latest version
Package 1:mod_ssl-2.2.15-5.el6.x86_64 already installed and latest version
Package php-5.3.2-6.el6.x86_64 already installed and latest version
Package php-common-5.3.2-6.el6.x86_64 already installed and latest version
Package php-gd-5.3.2-6.el6.x86_64 already installed and latest version
Package php-xml-5.3.2-6.el6.x86_64 already installed and latest version
No package php-imap.x86_64 available.
No package php-mbstring.x86_64 available.
Package spamassassin-3.3.1-2.el6.x86_64 already installed and latest version
Package MySQL-python-1.2.3-0.3.c1.1.el6.x86_64 already installed and latest version
Package mod_wsgi-3.2-1.el6.x86_64 already installed and latest version
Package bzip2-1.0.5-6.1.el6.x86_64 already installed and latest version
Package acl-2.2.49-4.el6.x86_64 already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
Package tmpwatch-2.9.16-3.el6.x86_64 already installed and latest version
Package crontabs-1.10-32.1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package altermime.x86_64 0:0.3.10-3.el6 set to be updated
---> Package amavisd-new.noarch 0:2.8.0-4.el6 set to be updated
--> Processing Dependency: perl(Net::Server) >= 0.87 for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: unzoo for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Unix::Syslog) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Razor2::Client::Version) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Words) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Parser) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Head) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Entity) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Decoder::UU) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Decoder::QuotedPrint) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Decoder::NBit) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Decoder::Gzip64) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Decoder::Binary) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Decoder::Base64) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(MIME::Body) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(IO::Stringy) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Convert::UUlib) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Convert::TNEF) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(BerkeleyDB) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Authen::SASL) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: perl(Archive::Zip) for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: p7zip-plugins for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: p7zip for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: nomarch for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: lrzip for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: freeze for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: cabextract for package: amavisd-new-2.8.0-4.el6.noarch
--> Processing Dependency: arj for package: amavisd-new-2.8.0-4.el6.noarch
---> Package awstats.noarch 0:7.0-3.el6 set to be updated
---> Package clamav.x86_64 0:0.97.8-1.el6 set to be updated
---> Package clamav-db.x86_64 0:0.97.8-1.el6 set to be updated
---> Package clamd.x86_64 0:0.97.8-1.el6 set to be updated
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: clamd-0.97.8-1.el6.x86_64
---> Package dos2unix.x86_64 0:3.1-37.el6 set to be updated
---> Package dovecot.x86_64 1:2.0.21-0_136.el6 set to be updated
---> Package dovecot-managesieve.x86_64 2:0.2.6-22.el6 set to be updated
---> Package dovecot-pigeonhole.x86_64 2:0.2.6-22.el6 set to be updated
---> Package fail2ban.noarch 0:0.8.10-1.el6 set to be updated
--> Processing Dependency: python-inotify for package: fail2ban-0.8.10-1.el6.noarch
---> Package logwatch.noarch 0:7.3.6-48.1.el6 set to be updated
--> Processing Dependency: perl(Date::Manip) for package: logwatch-7.3.6-48.1.el6.noarch
---> Package mod_auth_mysql.x86_64 1:3.0.0-11.el6 set to be updated
---> Package perl-LDAP.noarch 1:0.40-1.el6 set to be updated
--> Processing Dependency: perl(XML::SAX::Writer) for package: 1:perl-LDAP-0.40-1.el6.noarch
--> Processing Dependency: perl(XML::SAX::Base) for package: 1:perl-LDAP-0.40-1.el6.noarch
--> Processing Dependency: perl(Convert::ASN1) for package: 1:perl-LDAP-0.40-1.el6.noarch
---> Package perl-Mail-SPF.noarch 0:2.8.0-2.el6 set to be updated
---> Package php-ldap.x86_64 0:5.3.2-6.el6 set to be updated
---> Package php-mysql.x86_64 0:5.3.2-6.el6 set to be updated
---> Package php-pgsql.x86_64 0:5.3.2-6.el6 set to be updated
---> Package policyd.x86_64 0:1.82-6.el6 set to be updated
---> Package postfix.x86_64 3:2.6.6-2.3.el6 set to be updated
---> Package python-jinja2.x86_64 0:2.2.1-1.el6 set to be updated
---> Package python-webpy.noarch 0:0.37-2.el6 set to be updated
--> Processing Dependency: python-cherrypy for package: python-webpy-0.37-2.el6.noarch
--> Running transaction check
---> Package arj.x86_64 0:3.10.22-12.el6 set to be updated
---> Package cabextract.x86_64 0:1.3-3.el6 set to be updated
--> Processing Dependency: libmspack.so.0()(64bit) for package: cabextract-1.3-3.el6.x86_64
---> Package clamd.x86_64 0:0.97.8-1.el6 set to be updated
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: clamd-0.97.8-1.el6.x86_64
---> Package freeze.x86_64 0:2.5.0-11.el6 set to be updated
---> Package lrzip.x86_64 0:0.614-1.el6 set to be updated
---> Package nomarch.x86_64 0:1.4-6.el6 set to be updated
---> Package p7zip.x86_64 0:9.20.1-2.el6 set to be updated
---> Package p7zip-plugins.x86_64 0:9.20.1-2.el6 set to be updated
---> Package perl-Archive-Zip.noarch 0:1.30-2.el6 set to be updated
---> Package perl-Authen-SASL.noarch 0:2.13-2.el6 set to be updated
--> Processing Dependency: perl(GSSAPI) for package: perl-Authen-SASL-2.13-2.el6.noarch
---> Package perl-BerkeleyDB.x86_64 0:0.43-3.el6 set to be updated
---> Package perl-Convert-ASN1.noarch 0:0.22-1.el6 set to be updated
---> Package perl-Convert-TNEF.noarch 0:0.17-10.el6 set to be updated
---> Package perl-Convert-UUlib.x86_64 2:1.4-1.el6 set to be updated
---> Package perl-Date-Manip.noarch 0:5.54-4.el6 set to be updated
---> Package perl-IO-stringy.noarch 0:2.110-10.1.el6 set to be updated
---> Package perl-MIME-tools.noarch 0:5.427-4.el6 set to be updated
--> Processing Dependency: perl(Convert::BinHex) for package: perl-MIME-tools-5.427-4.el6.noarch
---> Package perl-Net-Server.noarch 0:0.97-7.el6 set to be updated
--> Processing Dependency: perl(IO::Multiplex) for package: perl-Net-Server-0.97-7.el6.noarch
---> Package perl-Razor-Agent.x86_64 0:2.85-6.el6 set to be updated
---> Package perl-Unix-Syslog.x86_64 0:1.1-3.el6 set to be updated
---> Package perl-XML-SAX.noarch 0:0.96-7.el6 set to be updated
--> Processing Dependency: perl(XML::LibXML::Common) for package: perl-XML-SAX-0.96-7.el6.noarch
--> Processing Dependency: perl(XML::NamespaceSupport) for package: perl-XML-SAX-0.96-7.el6.noarch
--> Processing Dependency: perl(XML::LibXML) for package: perl-XML-SAX-0.96-7.el6.noarch
---> Package perl-XML-SAX-Writer.noarch 0:0.50-8.el6 set to be updated
--> Processing Dependency: perl(Text::Iconv) for package: perl-XML-SAX-Writer-0.50-8.el6.noarch
--> Processing Dependency: perl(XML::Filter::BufferText) for package: perl-XML-SAX-Writer-0.50-8.el6.noarch
---> Package python-cherrypy.noarch 0:3.2.2-3.el6 set to be updated
---> Package python-inotify.noarch 0:0.9.1-1.el6 set to be updated
---> Package unzoo.x86_64 0:4.4-7.el6 set to be updated
--> Running transaction check
---> Package clamd.x86_64 0:0.97.8-1.el6 set to be updated
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: clamd-0.97.8-1.el6.x86_64
---> Package libmspack.x86_64 0:0.4-0.1.alpha.el6 set to be updated
---> Package perl-Convert-BinHex.noarch 0:1.119-10.1.el6 set to be updated
---> Package perl-GSSAPI.x86_64 0:0.26-5.el6 set to be updated
---> Package perl-IO-Multiplex.noarch 0:1.13-1.el6 set to be updated
---> Package perl-Text-Iconv.x86_64 0:1.7-6.el6 set to be updated
---> Package perl-XML-Filter-BufferText.noarch 0:1.01-8.el6 set to be updated
---> Package perl-XML-LibXML.x86_64 1:1.70-5.el6 set to be updated
---> Package perl-XML-NamespaceSupport.noarch 0:1.10-3.el6 set to be updated
--> Finished Dependency Resolution
Error: Package: clamd-0.97.8-1.el6.x86_64 (epel)
           Requires: libz.so.1(ZLIB_1.2.0.2)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
< ERROR > Installation failed, please check the terminal output.
< ERROR > If you're not sure what the problem is, try to get help in iRedMail
< ERROR > forum: http://www.iredmail.org/forum/


==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
====

2

Re: configuration problem.

*) Does upgrading your server with 'yum update' before installing iRedMail solve this issue?
*) How many yum repositories do you enabled? Please show us output of command 'yum repolist'.

3

Re: configuration problem.

Was there a resolution to this?
I'm experiencing the same problem.

I'm new to iRedMail and am trying to install for the first time.

OS Version
=========
# uname -a
Linux mail.demo.com 2.6.32-202.el6.x86_64 #1 SMP Wed Sep 21 15:27:03 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.2 Beta (Santiago)

iRedMail Version
==============
iRedMail-0.8.5

Yum Repos
=========
# yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
repo id                    repo name                                                                   status
epel                         Extra Packages for Enterprise Linux 6 - x86_64             9,556
iRedMail                  iRedMail                                                                      80
iso                          iso                                                                              3,529
repolist: 13,165

Other Info
=========
- A 'yum update' does not resolve this
- I've tried installing with OpenLDAP, MySQL and PostgreSQL

4

Re: configuration problem.

dcupitt wrote:

I'm experiencing the same problem.

1) Please create a new forum topic for your own question, do not hijack other's thread.
2) Please show us your error message (in a new forum topic).