1

Topic: Problem with outgoing mail, only to one domain.

==== Required information ====
- iRedMail version: latest smile
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Debian Squeeze
- Related log if you're reporting an issue:
====

Hi,

Im having problems with sending emails to our partner. They doesn't receive our emails and we receive no warrning/error messages. Looks like emails are gone somewhere.
here is a log from mail.log:

Jul 30 12:58:15 mail amavis[1241]: (01241-13) Passed CLEAN, MYNETS/MYUSERS LOCAL [10.0.0.12] [10.0.0.12] <xxx@yyy.com> -> <aaa@bbb.pl>, Message-ID: <bda576715f33e10f02599ca19c6aed15@10.0.0.12>, mail_id: uRx+Iv7VbAIB, Hits: -8.807, size: 12298, queued_as: AA1B44F402B, 392 ms
Jul 30 12:58:15 mail postfix/smtp[1421]: 398714F4027: to=<ccc@bbb.pl>, relay=127.0.0.1[127.0.0.1]:10024, delay=17, delays=1/15/0.03/0.4, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=01241-13, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as AA1B44F402B)
Jul 30 12:58:15 mail postfix/smtp[1600]: AA1B44F402B: enabling PIX workarounds: disable_esmtp delay_dotcrlf for relay1.luxmed.pl[91.220.39.10]:25
Jul 30 12:58:16 mail amavis[1241]: (01241-14) Passed CLEAN, MYNETS/MYUSERS LOCAL [10.0.0.12] [10.0.0.12] <xxx@yyy.com> -> <aaa@bbb.pl>, Message-ID: <bda576715f33e10f02599ca19c6aed15@10.0.0.12>, mail_id: 98hsAgtIoUOY, Hits: -8.807, size: 12298, queued_as: 0C0BA4F402C, 329 ms
Jul 30 12:58:16 mail postfix/smtp[1421]: 398714F4027: to=<aaa@bbb.pl>, relay=127.0.0.1[127.0.0.1]:10024, delay=17, delays=1/15/0.02/0.35, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=01241-14, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0C0BA4F402C)
Jul 30 12:58:16 mail postfix/smtp[1604]: 0C0BA4F402C: enabling PIX workarounds: disable_esmtp delay_dotcrlf for relay1.luxmed.pl[91.220.39.10]:25
Jul 30 13:06:18 mail postfix/smtp[2234]: CE18D17A010: enabling PIX workarounds: disable_esmtp delay_dotcrlf for relay1.luxmed.pl[91.220.39.10]:25
Jul 30 13:06:18 mail postfix/smtp[1595]: 2FA0F17A009: enabling PIX workarounds: disable_esmtp delay_dotcrlf for relay1.luxmed.pl[91.220.39.10]:25
Jul 30 13:08:16 mail postfix/smtp[1600]: AA1B44F402B: to=<ccc@bbb.pl>, relay=relay1.luxmed.pl[91.220.39.10]:25, delay=601, delays=0.02/0.03/0.23/600, dsn=4.4.2, status=deferred (conversation with relay1.luxmed.pl[91.220.39.10] timed out while sending end of data -- message may be sent more than once)
Jul 30 13:08:16 mail postfix/smtp[1604]: 0C0BA4F402C: to=<aaa@bbb.pl>, relay=relay1.luxmed.pl[91.220.39.10]:25, delay=600, delays=0.03/0.02/0.11/600, dsn=4.4.2, status=deferred (conversation with relay1.luxmed.pl[91.220.39.10] timed out while sending end of data -- message may be sent more than once)

2

Re: Problem with outgoing mail, only to one domain.

PawelRaczkowski wrote:

Jul 30 13:08:16 mail postfix/smtp[1604]: 0C0BA4F402C: to=<aaa@bbb.pl>, relay=relay1.luxmed.pl[91.220.39.10]:25, delay=600, delays=0.03/0.02/0.11/600, dsn=4.4.2, status=deferred (conversation with relay1.luxmed.pl[91.220.39.10] timed out while sending end of data -- message may be sent more than once)

This email was relayed to "relay1.luxmed.pl", and connection to this server timed out.

3

Re: Problem with outgoing mail, only to one domain.

ZhangHuangbin wrote:
PawelRaczkowski wrote:

Jul 30 13:08:16 mail postfix/smtp[1604]: 0C0BA4F402C: to=<aaa@bbb.pl>, relay=relay1.luxmed.pl[91.220.39.10]:25, delay=600, delays=0.03/0.02/0.11/600, dsn=4.4.2, status=deferred (conversation with relay1.luxmed.pl[91.220.39.10] timed out while sending end of data -- message may be sent more than once)

This email was relayed to "relay1.luxmed.pl", and connection to this server timed out.

I understand, but my connection to this server is very good. And if i'm sending emails from another account from my domain to luxmed.pl all are sent ok. This is only for 1 account. They saied we are on white list and no check for our mails is active.

4

Re: Problem with outgoing mail, only to one domain.

No idea yet. Could you please show us output of command "postconf -n" to help troubleshoot? Do you have any custom settings in Postfix?

5

Re: Problem with outgoing mail, only to one domain.

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
allow_min_user = no
append_dot_mydomain = no
biff = no
bounce_queue_lifetime = 1d
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
delay_warning_time = 0h
disable_vrfy_command = yes
enable_original_recipient = no
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = ipv4
mailbox_command = /usr/lib/dovecot/deliver
mailbox_size_limit = 0
maximal_backoff_time = 4000s
maximal_queue_lifetime = 1d
message_size_limit = 104857600
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhost                      name
mydomain = pl.xxx.com
myhostname = mail.pl.xxx.com
mynetworks = 127.0.0.0/8, aaa.ccc.mmm.122, www.ddd.rrrr.227
mynetworks_style = subnet
myorigin = mail.pl.april.com
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $myde                      stination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domai                      ns $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps                       $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_doma                      ins $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps $smtpd_se                      nder_restrictions
queue_run_delay = 300s
readme_directory = no
recipient_bcc_maps = proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_user.cf,                       proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_domain.cf
recipient_delimiter = +
relay_domains = $mydestination, proxy:mysql:/etc/postfix/mysql/relay_domains.cf
relayhost =
sender_bcc_maps = proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_user.cf, proxy:                      mysql:/etc/postfix/mysql/sender_bcc_maps_domain.cf
smtp_data_init_timeout = 240s
smtp_data_xfer_timeout = 600s
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,permit_sasl_authenticated, check_hel                      o_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_reci                      pient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted                      _recipient, check_policy_service inet:127.0.0.1:7777, permit_mynetworks, permit_                      sasl_authenticated, reject_unauth_destination, reject_non_fqdn_helo_hostname, re                      ject_invalid_helo_hostname, check_policy_service inet:127.0.0.1:10031
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain =
smtpd_sasl_path = ./dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql/sender_login_maps.cf
smtpd_sender_restrictions = permit_mynetworks, permit_sasl_authenticated
smtpd_tls_CAfile = /etc/ssl/certs/ca-bundle.crt
smtpd_tls_cert_file = /etc/ssl/certs/mail.pem
smtpd_tls_key_file = /etc/ssl/private/mail.key
smtpd_tls_loglevel = 0
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = proxy:mysql:/etc/postfix/mysql/transport_maps_user.cf, proxy:my                      sql:/etc/postfix/mysql/transport_maps_domain.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql/virtual_alias_maps.cf, proxy                      :mysql:/etc/postfix/mysql/domain_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/c                      atchall_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_catchall_maps.cf
virtual_gid_maps = static:1001
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_domains                      .cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_maps.cf
virtual_minimum_uid = 1001
virtual_transport = dovecot
virtual_uid_maps = static:1001

No i don't have any custom settings.

6

Re: Problem with outgoing mail, only to one domain.

No idea yet, maybe caused by Cisco router stands front of your mail server.
You can try to increase Postfix parameter "smtp_data_done_timeout" to "800s" (default is 600s) and see whether it occurs again.

7

Re: Problem with outgoing mail, only to one domain.

i do not have Cisco, im using Netasq. I'll try incarace this parameter and we will see.