1

Topic: Problem after migrate

We were using Iredmail version 0.8.1,We migrated our mail server 2 weeks ago. We install a new server and transferred files and etc. Before migrating we install the same version server (0.8.1). After migrating we upgraded to 0.8.4.

We have two groups of user. One of them is normal users and the other is for student.

We use a script  (we updated to iredmail 0.7.2. create_mail_user_openldap.sh) for open mail account for students. After we migrated to new server. Everything works fine for group one. Students also can log in and can send mail successfully. But if someone try to send a mail to student, we have following error;

This is the mail system at host ...............edu.tr.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<123124@......edu.tr>: user unknown

Final-Recipient: rfc822; 123124@......edu.tr
Original-Recipient: rfc822;123124@......edu.tr
Action: failed
Status: 5.1.1
Diagnostic-Code: x-unix; user unknown


Some of mail address of students gives that error. Some of them not. I searched on the forum but i couldnt solve the problem. Do you have an idea about that?

Thank you.


==== Required information ====
- iRedMail version: 0.8.4
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Centos
- Related log if you're reporting an issue:
====

2

Re: Problem after migrate

As you can see in upgrade tutorials, there're several LDAP schema updates, you must apply them, so that you can update your LDAP mail accounts to have required attribute/value pairs:
http://www.iredmail.org/doc.html#upgrade_tutorial

I think you can fix it with scripts here:
https://bitbucket.org/zhb/iredmail/raw/ … ra/update/

The original iRedMail version you used is 0.7.2, you need all scripts applicable to 0.7.2 and later versions.
Just download them, open them and fill with correct LDAP server, bind dn/password, then execute it like below:

# python updateLDAPValues_072_to_073.py

NOTE: You need to execute those scripts one by one, don't jump version numbers.

3

Re: Problem after migrate

It is solved. After I create an account, I execute Ldap update 72 to 73.script. It solved my problem. No need to execute other update scripts.

Thanks.

ZhangHuangbin wrote:

As you can see in upgrade tutorials, there're several LDAP schema updates, you must apply them, so that you can update your LDAP mail accounts to have required attribute/value pairs:
http://www.iredmail.org/doc.html#upgrade_tutorial

I think you can fix it with scripts here:
https://bitbucket.org/zhb/iredmail/raw/ … ra/update/

The original iRedMail version you used is 0.7.2, you need all scripts applicable to 0.7.2 and later versions.
Just download them, open them and fill with correct LDAP server, bind dn/password, then execute it like below:

# python updateLDAPValues_072_to_073.py

NOTE: You need to execute those scripts one by one, don't jump version numbers.