1 (edited by nerdtron09 2013-07-16 17:55:44)

Topic: allow unregistered email

==== Required information ====
- iRedMail version: 0.8.4
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Ubuntu 12.04
- Related log if you're reporting an issue:
====

Let's say i have mail.domain1.com with about 50 email accounts.
And mail.domain2.com with about 30 email accounts.

We have an application here which we would like to send an email using our mail server. However, the email address that the receiver should see is like this: do-not-reply@domain3.com
How do I configure roundcube to relay this email even without creating a seperate user and domain for do-not-reply@domain3.com

2

Re: allow unregistered email

*) First of all, if you don't own domain name '@domain3.com', it's not recommended to do so, you're considered as spammer this way.
*) If you want to do so, please remove 'reject_sender_login_mismatch' in Postfix config file /etc/postfix/main.cf, it's a restriction rule in parameter 'smtpd_sender_restrictions'.
*) Configure your mail client (Outlook, Roundcube webmail, etc) to use 'do-not-reply@domain3.com' as 'From' address.

3

Re: allow unregistered email

Yes zhang, I have tried it and also a lot of incoming spams were received and sent.
Is there a way to just whitelist a sender?
The error is this:

Jul 17 09:50:41 mail postfix/smtpd[32294]: connect from unknown[202.x.x.x]
Jul 17 09:50:41 mail postfix/smtpd[32294]: NOQUEUE: reject: RCPT from unknown[202.x.x.x]: 553 5.7.1 <customercare@7-eleven.com.ph>: Sender address rejected: not owned by user customercare@7-eleven.com.ph; from=<customercare@7-eleven.com.ph> to=<zms_15@yahoo.com> proto=ESMTP helo=<prod-sevenpay.apollo.com.ph>
Jul 17 09:50:41 mail postfix/smtpd[32294]: disconnect from unknown[202.x.x.x]
Jul 17 09:50:48 mail postfix/smtpd[32287]: connect from unknown[202.x.x.x]
Jul 17 09:50:48 mail postfix/smtpd[32287]: NOQUEUE: reject: RCPT from unknown[202.x.x.x]: 553 5.7.1 <customercare@7-eleven.com.ph>: Sender address rejected: not owned by user customercare@7-eleven.com.ph; from=<customercare@7-eleven.com.ph> to=<jonabel_alpanta@yahoo.com> proto=ESMTP helo=<prod-sevenpay.apollo.com.ph>
Jul 17 09:50:48 mail postfix/smtpd[32287]: disconnect from unknown[202.x.x.x]

If the 'reject_sender_login_mismatch' is removed, these messages will pass, but if the it is enabled, that is the error that shows.

4

Re: allow unregistered email

nerdtron09 wrote:

Is there a way to just whitelist a sender?

You can use the iRedAPD plugin "reject_sender_login_mismatch" to achieve this, it's shipped in the latest iRedAPD-1.4.1.
How to use it (you can read it in plugin file):

Reject sender login mismatch (sender in mail header and SASL username).

*) You must remove "sender_login_mismatch" restriction in Postfix parameter
   "smtpd_sender_restrictions" and let this plugin do it for you.

*) Please list all allowed senders in in iRedAPD config file (settings.py),
   parameter ALLOWED_LOGIN_MISMATCH_SENDERS. For example:

    ALLOWED_LOGIN_MISMATCH_SENDERS = ['user1@here.com', 'user2@here.com']

5

Re: allow unregistered email

Thanks zhang, pardon me for asking but where is the settings.py that should be edited?

6

Re: allow unregistered email

It's /opt/iredapd/settings.py, config file of iRedAPD.

7

Re: allow unregistered email

The Plugin "reject_sender_login_mismatch" is not in the plugins directory but I found this in bitbucket.
https://bitbucket.org/zhb/iredapd/src/3 … ismatch.py

I'll put it in the plugins folder and edit the settings.py right?
I'll update you.

8

Re: allow unregistered email

It requires iRedAPD-1.4.0, but it's best to use the latest stable release, iRedAPD-1.4.1.