1

Topic: Outlook 2010 Will not connect to iRedMail

==== Required information ====
- iRedMail version: 0.8.4
- Store mail accounts in which backend MySQL
- Linux/BSD distribution name and version: CentOS 6.4
- Related log if you're reporting an issue:
[root@mail dovecot]# dovecot -n
# 2.0.21: /etc/dovecot/dovecot.conf
# OS: Linux 2.6.32-358.11.1.el6.i686 i686 CentOS release 6.4 (Final)
auth_master_user_separator = *
auth_mechanisms = PLAIN LOGIN
dict {
  acl = mysql:/etc/dovecot/dovecot-share-folder.conf
  expire = db:/var/lib/dovecot/expire/expire.db
  quotadict = mysql:/etc/dovecot/dovecot-used-quota.conf
}
first_valid_uid = 2000
last_valid_uid = 2000
listen = *
log_path = /var/log/dovecot.log
mail_gid = 2000
mail_location = maildir:/%Lh/Maildir/:INDEX=/%Lh/Maildir/
mail_plugins = quota
mail_uid = 2000
managesieve_notify_capability = mailto
managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
namespace {
  inbox = yes
  location =
  prefix =
  separator = /
  type = private
}
namespace {
  list = children
  location = maildir:/%%Lh/Maildir/:INDEX=/%%Lh/Maildir/Shared/%%u
  prefix = Shared/%%u/
  separator = /
  subscriptions = yes
  type = shared
}
passdb {
  args = /etc/dovecot/dovecot-mysql.conf
  driver = sql
}
passdb {
  args = /etc/dovecot/dovecot-master-users-password
  driver = passwd-file
  master = yes
}
plugin {
  acl = vfile
  acl_shared_dict = proxy::acl
  auth_socket_path = /var/run/dovecot/auth-master
  autocreate = INBOX
  autocreate2 = Sent
  autocreate3 = Trash
  autocreate4 = Drafts
  autocreate5 = Junk
  autosubscribe = INBOX
  autosubscribe2 = Sent
  autosubscribe3 = Trash
  autosubscribe4 = Drafts
  autosubscribe5 = Junk
  expire = Trash 7 Trash/* 7 Junk 30
  expire_dict = proxy::expire
  quota = dict:user::proxy::quotadict
  quota_rule = *:storage=1G
  quota_warning = storage=85%% quota-warning 85 %u
  quota_warning2 = storage=90%% quota-warning 90 %u
  quota_warning3 = storage=95%% quota-warning 95 %u
  sieve = /%Lh/sieve/dovecot.sieve
  sieve_dir = /%Lh/sieve
  sieve_global_dir = /var/vmail/sieve
  sieve_global_path = /var/vmail/sieve/dovecot.sieve
}
protocols = pop3 imap sieve
service auth {
  unix_listener /var/spool/postfix/dovecot-auth {
    group = postfix
    mode = 0666
    user = postfix
  }
  unix_listener auth-master {
    group = vmail
    mode = 0666
    user = vmail
  }
  unix_listener auth-userdb {
    group = vmail
    mode = 0660
    user = vmail
  }
}
service dict {
  unix_listener dict {
    group = vmail
    mode = 0660
    user = vmail
  }
}
service imap-login {
  process_limit = 500
  service_count = 1
}
service pop3-login {
  service_count = 1
}
service quota-warning {
  executable = script /usr/local/bin/dovecot-quota-warning.sh
  unix_listener quota-warning {
    group = vmail
    mode = 0660
    user = vmail
  }
}
ssl_cert = </etc/pki/tls/certs/iRedMail_CA.pem
ssl_key = </etc/pki/tls/private/iRedMail.key
userdb {
  args = /etc/dovecot/dovecot-mysql.conf
  driver = sql
}
protocol lda {
  auth_socket_path = /var/run/dovecot/auth-master
  lda_mailbox_autocreate = yes
  log_path = /var/log/sieve.log
  mail_plugins = quota sieve autocreate
  postmaster_address = root
}
protocol imap {
  imap_client_workarounds = tb-extra-mailbox-sep
  mail_plugins = quota imap_quota autocreate
}
protocol pop3 {
  mail_plugins = quota
  pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
  pop3_uidl_format = %08Xu%08Xv
}

====

I can get Thunderbird and cubemail to work just fine, but outlook will not.  I have these two settings in my conf file

disable_plaintext_auth=no
ssl=yes

The server sends and receives email perfectly, I just have to get users to be able to connect to it with Outlook now.

Thanks in advance

2

Re: Outlook 2010 Will not connect to iRedMail

What's the error message in Outlook? Do you have correct IMAP/POP3/SMTP server address and username/password configured in Outlook?

3

Re: Outlook 2010 Will not connect to iRedMail

ZhangHuangbin wrote:

What's the error message in Outlook? Do you have correct IMAP/POP3/SMTP server address and username/password configured in Outlook?


There error message is

"""""Log onto incoming mail server (IMAP): General authentication failed. None of the authentication methods supported by your IMAP server (if any) are supported on this computer.""""""

4

Re: Outlook 2010 Will not connect to iRedMail

What's your IMAP AUTH settings in Outlook? You should use secure connection via port 993, secure type should be TLS or STARTTLS.
Also, make sure you set correct server address, and use full email address as login username.

5

Re: Outlook 2010 Will not connect to iRedMail

ZhangHuangbin wrote:

What's your IMAP AUTH settings in Outlook? You should use secure connection via port 993, secure type should be TLS or STARTTLS.
Also, make sure you set correct server address, and use full email address as login username.

That was it.  Of Course it was something simple.  The port is the standard 143, but I had to turn on TLS.  Outlook now connects and it works how it should.  Thanks for the help.