1

Topic: Error receiving email

==== Required information ====
- iRedMail version: 0.8.4
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Debian Wheezy
- Related log if you're reporting an issue:
Jun 11 18:42:05 mx postfix/smtpd[6232]: connect from mail-wi0-x231.google.com[2a00:1450:400c:c05::231]
Jun 11 18:42:06 mx postfix/smtpd[6232]: NOQUEUE: reject: RCPT from mail-wi0-x231.google.com[2a00:1450:400c:c05::231]: 450 4.7.1 <******@******.***>: Recipient address rejected: Access denied; from=<******@******.***> to=<******@******.***> proto=ESMTP helo=<mail-wi0-x231.google.com>
Jun 11 18:42:06 mx postfix/smtpd[6232]: disconnect from mail-wi0-x231.google.com[2a00:1450:400c:c05::231]
====

Hi, I receive various error in the log like this that I have attached when receving email from trusted and well know sender.
How to fix it?

Thank you

2

Re: Error receiving email

Is the recipient domain (address in "to=<xxx>") hosted on your mail server? Does the recipient exist?

3 (edited by johjoh 2013-06-13 01:00:29)

Re: Error receiving email

Yes it exist, I've spellchecked two times and it's correct.

4

Re: Error receiving email

Could you please show us output of command "postconf -n"?

5

Re: Error receiving email

Of course I can :-)

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
allow_min_user = no
allow_percent_hack = no
append_dot_mydomain = no
biff = no
bounce_queue_lifetime = 4h
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
delay_warning_time = 0h
disable_vrfy_command = yes
dovecot_destination_recipient_limit = 1
enable_original_recipient = no
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_command = /usr/lib/dovecot/deliver
mailbox_size_limit = 0
maximal_backoff_time = 4000s
maximal_queue_lifetime = 4h
message_size_limit = 15728640
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
mydomain = ******.***
myhostname = ***.******.***
mynetworks = 127.0.0.0/8
mynetworks_style = subnet
myorigin = ***.******.***
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $mydestination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domains $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_domains $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps $smtpd_sender_restrictions
queue_run_delay = 300s
readme_directory = no
recipient_bcc_maps = proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_user.cf, proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_domain.cf
recipient_delimiter = +
relay_domains = $mydestination, proxy:mysql:/etc/postfix/mysql/relay_domains.cf
relayhost =
sender_bcc_maps = proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_user.cf, proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_domain.cf
smtp-amavis_destination_recipient_limit = 1
smtp_data_init_timeout = 240s
smtp_data_xfer_timeout = 600s
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_end_of_data_restrictions = check_policy_service inet:127.0.0.1:10031
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_helo_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:127.0.0.1:7777, check_policy_service inet:127.0.0.1:10031, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain =
smtpd_sasl_path = ./dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql/sender_login_maps.cf
smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated
smtpd_tls_CAfile = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_cert_file = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_key_file = /etc/ssl/private/iRedMail.key
smtpd_tls_loglevel = 0
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
swap_bangpath = no
tls_random_source = dev:/dev/urandom
transport_maps = proxy:mysql:/etc/postfix/mysql/transport_maps_user.cf, proxy:mysql:/etc/postfix/mysql/transport_maps_domain.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql/virtual_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/catchall_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_catchall_maps.cf
virtual_gid_maps = static:2000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_maps.cf
virtual_minimum_uid = 2000
virtual_transport = dovecot
virtual_uid_maps = static:2000

6

Re: Error receiving email

Any news?
The problem persist...

7

Re: Error receiving email

Your Postfix config looks fine.

Please turn on debug mode in Postfix to debug this issue. Below are steps:

*) Send n testing email from Gmail. Postfix will log the IP address of this Gmail server.
*) Append this IP address in Postfix config file, /etc/postfix/main.cf, parameter "debug_peer_list =". Then reload (or restart) Postfix service.
*) Send a testing email from Gmail again, hope it will send out your email with the same IP address. Then you should get detailed debug message in Postfix log file. Paste it here so that others can help troubleshoot.

8

Re: Error receiving email

Here's the log:

Jun 24 16:08:36 mx postfix/smtpd[12447]: connect from mail-vb0-x235.google.com[2607:f8b0:400c:c02::235]
Jun 24 16:08:37 mx postfix/smtpd[12447]: NOQUEUE: reject: RCPT from mail-vb0-x235.google.com[2607:f8b0:400c:c02::235]: 450 4.7.1 <******.******@******.***>: Recipient address rejected: Access denied; from=<******.******@gmail.com> to=<******.******@******.***> proto=ESMTP helo=<mail-vb0-x235.google.com>
Jun 24 16:08:37 mx postfix/smtpd[12447]: disconnect from mail-vb0-x235.google.com[2607:f8b0:400c:c02::235]

Now I try to disable IPv6 on Postfix and work only on IPv4, maybe there is something missing in Postfix or IPtables...

9

Re: Error receiving email

Success!!!

If I set in main.cf of Postfix:

inet_protocols = ipv4

I receive from Gmail and other domains that work in IPv6

If I set

inet_protocols = all

Postfix doesn't accept connection.

There's something missing in configuration of Postfix or IPtables?

10

Re: Error receiving email

No idea if we don't have full debug log. sorry about this. sad
If you think it might be a iptables issue, why not completely disable iptables for testing?

11 (edited by johjoh 2013-07-18 09:55:47)

Re: Error receiving email

Investigating it's Policyd
http://comments.gmane.org/gmane.mail.po … licyd/1816

Do you have in plan to realize /etc/default/ip6tables also?
Actually it permit everithing

12

Re: Error receiving email

Hi johjoh,

Does this issue still exist in Policyd-2 (cluebringer)? If so, please report this issue to its official mailing list instead, so that developers can fix it in next release:
http://wiki.policyd.org/#troubleshooting

13 (edited by Jochie 2013-12-08 22:47:22)

Re: Error receiving email

Still there. Disabling ipv6 accepts emails again from Gmail amongst other mailservers. sad

According to : http://www.policyd.org/

(Support for IPv6 is included in r493+, v2.1.x)

Debian 7 version :          VERSION         => "2.0.11a-debian",

Bummer hmm