1

Topic: can not install the old version 0.8.3

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):ldap
- Linux/BSD distribution name and version: centos.6.3
- Related log if you're reporting an issue:

[root@mail iRedMail-0.8.3]# bash iRedMail.sh
< INFO > Checking new version of iRedMail ...

< ERROR > Your iRedMail version (0.8.3) is out of date, please
< ERROR > download the latest version and try again:
< ERROR > http://173.254.22.21/download.html
====

I want to install the same version to backup my mail file, but it seems fail, how to install the old version 0.8.3, my iredmail-0.8.3
works well, i don't want to install the new version, it takes a lot of time to test and upgrade, in fact, i don't want to take a risk with the new version!

2

Re: can not install the old version 0.8.3

*) All users should always use the latest iRedMail release to get the latest features, bug/security fixes. And we may delete addition files required by iRedMail on our server, so old iRedMail releases may not work.

*) If you still want to use old release, append below line in iRedMail-0.8.3/.status, then execute "bash iRedMail.sh" again.

export status_check_new_iredmail="DONE"

3

Re: can not install the old version 0.8.3

Thanks Master Zhang, but it still has some errors when i begin to install with yum, the pkgs/get_all.sh  ip is http://173.254.22.21/yum!!


Error Downloading Packages:
  2:dovecot-pigeonhole-0.2.6-21.el6.x86_64: failure: dovecot-pigeonhole-0.2.6-21.el6.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  perl-Mail-SPF-2.007-1.el6.noarch: failure: perl-Mail-SPF-2.007-1.el6.noarch.rpm from iRedMail: [Errno 256] No more mirrors to try.
  3:postfix-2.6.6-2.3.el6.x86_64: failure: postfix-2.6.6-2.3.el6.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  clamd-0.97.7-1.el6.rf.x86_64: failure: clamd-0.97.7-1.el6.rf.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  clamav-0.97.7-1.el6.rf.x86_64: failure: clamav-0.97.7-1.el6.rf.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  1:perl-Convert-UUlib-1.34-1.el6.x86_64: failure: perl-Convert-UUlib-1.34-1.el6.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  1:dovecot-2.0.18-1_134.el6.x86_64: failure: dovecot-2.0.18-1_134.el6.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  amavisd-new-2.6.6-3.el6.noarch: failure: amavisd-new-2.6.6-3.el6.noarch.rpm from iRedMail: [Errno 256] No more mirrors to try.
  geoip-1.4.6-1.el6.rf.x86_64: failure: geoip-1.4.6-1.el6.rf.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.
  clamav-db-0.97.7-1.el6.rf.x86_64: failure: clamav-db-0.97.7-1.el6.rf.x86_64.rpm from iRedMail: [Errno 256] No more mirrors to try.

< ERROR > Installation failed, please check the terminal output.
< ERROR > If you're not sure what the problem is, try to get help in iRedMail
< ERROR > forum: http://www.iredmail.org/forum/

4

Re: can not install the old version 0.8.3

i change the  pkgs/get_all.sh  ip to 'ping iredmail.com' , finished this errors, thanks!