1

Topic: How do I enable SMTP AUTH?

==== Required information ====
- iRedMail version: latest
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version: cent os 6
- Related log if you're reporting an issue:
====

Hi,

I'm using default install of iRedMail and I would like to use SASL or SMTP AUTH.
Mail is working at least with plain text password in my environment but SASL does not seem to be enabled at default.

I could not find the resource in iRedMail docs.
Where or which config file or what kind of setup should I look into it?

Thank you

2

Re: How do I enable SMTP AUTH?

iRedMail has SMTP AUTH enabled by default.

3

Re: How do I enable SMTP AUTH?

ZhangHuangbin wrote:

iRedMail has SMTP AUTH enabled by default.

Thank you for info.

That means SMTP AUTH may not be working because I have the following error in my maillog and I am not able to configure mailer using SMTPAUTH.

What do I need to check?

-------------------- Postfix Begin ------------------------

       1   *Warning: Pre-queue content-filter connection overload
      28   SASL authentication failed
     152   Miscellaneous warnings

4

Re: How do I enable SMTP AUTH?

different wrote:

1   *Warning: Pre-queue content-filter connection overload

Not sure why it happened. Amavisd is configured as after-queue content-filter by default, not pre-queue. Did you modify it to act as pre-queue filter?

different wrote:

28   SASL authentication failed

It's normal. failed login will cause this error message. e.g. incorrect username or password.

Again, SMTP AUTH is enabled by default in iRedMail.

5

Re: How do I enable SMTP AUTH?

ZhangHuangbin wrote:
different wrote:

1   *Warning: Pre-queue content-filter connection overload

Not sure why it happened. Amavisd is configured as after-queue content-filter by default, not pre-queue. Did you modify it to act as pre-queue filter?

For pre-queue content filter setting, not that I know of... I did edit master.cf file. and main.cf file for smtpd_recipient_restrictions settings.
Should I show you any other config file?

Here is the quote from my other post:

smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:127.0.0.1:7777, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, check_policy_service inet:127.0.0.1:10031