1

Topic: problems with yum update

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):  MySQL
- Linux/BSD distribution name and version: Centos 6.4
- Related log if you're reporting an issue:
====
Hi there, i have an issue with yum update reports as follows:


yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.serverspace.co.uk
* epel: mirrors.coreix.net
* extras: mirror.sov.uk.goscomb.net
* updates: centos.serverspace.co.uk
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.97.7-1.el6 will be updated
--> Processing Dependency: clamav = 0.97.7-1.el6 for package: clamav-devel-0.97.7-1.el6.x86_64
---> Package clamav.x86_64 0:0.97.7-1.el6.rf will be an update
---> Package clamav-db.x86_64 0:0.97.7-1.el6 will be updated
--> Processing Dependency: clamav-db = 0.97.7-1.el6 for package: clamav-0.97.7-1.el6.i686
---> Package clamav-db.x86_64 0:0.97.7-1.el6.rf will be an update
---> Package clamd.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamd.x86_64 0:0.97.7-1.el6.rf will be an update
--> Running transaction check
---> Package clamav.i686 0:0.97.7-1.el6 will be installed
--> Processing Dependency: clamav-db = 0.97.7-1.el6 for package: clamav-0.97.7-1.el6.i686
---> Package clamav.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamav-db.x86_64 0:0.97.7-1.el6 will be updated
--> Processing Dependency: clamav-db = 0.97.7-1.el6 for package: clamav-0.97.7-1.el6.i686
--> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noarch
--> Finished Dependency Resolution
Error: Package: clamav-0.97.7-1.el6.i686 (epel)
           Requires: clamav-db = 0.97.7-1.el6
           Removing: clamav-db-0.97.7-1.el6.x86_64 (@epel)
               clamav-db = 0.97.7-1.el6
           Updated By: clamav-db-0.97.7-1.el6.rf.x86_64 (iRedMail)
               clamav-db = 0.97.7-1.el6.rf
Error: Package: amavisd-new-2.8.0-4.el6.noarch (@epel)
           Requires: /etc/clamd.d
           Removing: clamd-0.97.7-1.el6.x86_64 (@epel)
               Not found
           Updated By: clamd-0.97.7-1.el6.rf.x86_64 (iRedMail)
               Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


What should i do?
Thank you in advance

2

Re: problems with yum update

Please use ClamAV packages provided by iRedMail, not EPEL. You can disable EPEL first, then upgrade packages.

3

Re: problems with yum update

Thank you, i have disabled the epel repo but still no luck the same error:

Determining fastest mirrors
* base: mirror.sov.uk.goscomb.net
* extras: mirror.sov.uk.goscomb.net
* updates: mirror.mhd.uk.as44574.net
base                                                                                                                 | 3.7 kB     00:00     
base/primary_db                                                                                                      | 4.4 MB     00:00     
extras                                                                                                               | 3.5 kB     00:00     
extras/primary_db                                                                                                    |  19 kB     00:00     
iRedMail                                                                                                             |  951 B     00:00     
iRedMail/primary                                                                                                     |  34 kB     00:00     
iRedMail                                                                                                                              74/74
updates                                                                                                              | 3.5 kB     00:00     
updates/primary_db                                                                                                   | 1.5 MB     00:00     
vz-base                                                                                                              |  951 B     00:00     
vz-base/primary                                                                                                      | 1.3 kB     00:00     
vz-base                                                                                                                                 3/3
vz-updates                                                                                                           |  951 B     00:00     
vz-updates/primary                                                                                                   |  157 B     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clamav.x86_64 0:0.97.7-1.el6 will be updated
--> Processing Dependency: clamav = 0.97.7-1.el6 for package: clamav-devel-0.97.7-1.el6.x86_64
---> Package clamav.x86_64 0:0.97.7-1.el6.rf will be an update
---> Package clamav-db.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamav-db.x86_64 0:0.97.7-1.el6.rf will be an update
---> Package clamd.x86_64 0:0.97.7-1.el6 will be updated
---> Package clamd.x86_64 0:0.97.7-1.el6.rf will be an update
--> Processing Dependency: /etc/clamd.d for package: amavisd-new-2.8.0-4.el6.noarch
--> Finished Dependency Resolution
Error: Package: clamav-devel-0.97.7-1.el6.x86_64 (@epel)
           Requires: clamav = 0.97.7-1.el6
           Removing: clamav-0.97.7-1.el6.x86_64 (@epel)
               clamav = 0.97.7-1.el6
           Updated By: clamav-0.97.7-1.el6.rf.x86_64 (iRedMail)
               clamav = 0.97.7-1.el6.rf
Error: Package: amavisd-new-2.8.0-4.el6.noarch (@epel)
           Requires: /etc/clamd.d
           Removing: clamd-0.97.7-1.el6.x86_64 (@epel)
               Not found
           Updated By: clamd-0.97.7-1.el6.rf.x86_64 (iRedMail)
               Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any guess?
Prior to this update everything went well updating

4

Re: problems with yum update

Seams you updates something from epel repo, please post the output of : yum list installed | grep '@epel'

5

Re: problems with yum update

I solved this error message by excluding the packages from epel and rpmforge repositories

you can add the following line just before [epel-debuginfo] and [rpmforge-extras]

 exclude=clamav clamav-db amavisd-new clamd gnustep-* 

this will force yum to update packages from iRedMail repositories only.

6

Re: problems with yum update

With the latest iRedMail release, EPEL is default third-party yum repository, iRedMail will try to install RPMs from EPEL first, if not available, iRedMail yum repo will provide it. So, please always install Amavisd, ClamAV from EPEL.

With EPEL, we can reduce our workload for building RPMs. And for you, EPEL is a big project sponsored by Red Hat, it's more trustable than me.