1

Topic: how can I disable smtp with ssl

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
==== ==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): AD
- Linux/BSD distribution name and version: CentOS 6.3
- Related log if you're reporting an issue:
====

helo,everybody.I will test my iredmail server performance,I dont want use smtp without ssl.how can I disable smtp with ssl?
I try postconf -e smtpd_sasl_auth_enable = no,but it's fail.

2

Re: how can I disable smtp with ssl

nu9i wrote:

helo,everybody.I will test my iredmail server performance,I dont want use smtp without ssl.how can I disable smtp with ssl?
I try postconf -e smtpd_sasl_auth_enable = no,but it's fail.

To turn off SMTP mandatory encryption: edit /etc/postfix/master.cf and towards the bottom of the file you have to comment/remove the line in the submission section:

-o smtpd_tls_security_level=encrypt

Restart postfix.

It should be enough...

3

Re: how can I disable smtp with ssl

Albux wrote:
nu9i wrote:

helo,everybody.I will test my iredmail server performance,I dont want use smtp without ssl.how can I disable smtp with ssl?
I try postconf -e smtpd_sasl_auth_enable = no,but it's fail.

To turn off SMTP mandatory encryption: edit /etc/postfix/master.cf and towards the bottom of the file you have to comment/remove the line in the submission section:

-o smtpd_tls_security_level=encrypt

Restart postfix.

It should be enough...


First,thank you for your answer,but I think I have a mistake.In fact I want to disable "my outgoing server requires authentication".:-(

4 (edited by Albux 2013-04-08 17:53:20)

Re: how can I disable smtp with ssl

nu9i wrote:

First,thank you for your answer,but I think I have a mistake.In fact I want to disable "my outgoing server requires authentication".:-(


How would you like to authenticate to your SMTP server? POP before SMTP ?
No authentication at all would leave your server as an Open Relay, which is really, extremely, unbelievably, BAD! smile

Or maybe the email clients you are sending from are only from a range of IPs?
In this case you should edit the /etc/postfix/main.cf and edit the $mynetworks accordingly to your IP range.

5

Re: how can I disable smtp with ssl

Albux wrote:
nu9i wrote:

First,thank you for your answer,but I think I have a mistake.In fact I want to disable "my outgoing server requires authentication".:-(


How would you like to authenticate to your SMTP server? POP before SMTP ?
No authentication at all would leave your server as an Open Relay, which is really, extremely, unbelievably, BAD! smile

Or maybe the email clients you are sending from are only from a range of IPs?
In this case you should edit the /etc/postfix/main.cf and edit the $mynetworks accordingly to your IP range.

My test server performance tools dont support authentication config...,my iredmail on my internal network,now. So I want to disable iredmail server smtp authentication configure.

6

Re: how can I disable smtp with ssl

nu9i wrote:
Albux wrote:
nu9i wrote:

First,thank you for your answer,but I think I have a mistake.In fact I want to disable "my outgoing server requires authentication".:-(


How would you like to authenticate to your SMTP server? POP before SMTP ?
No authentication at all would leave your server as an Open Relay, which is really, extremely, unbelievably, BAD! smile

Or maybe the email clients you are sending from are only from a range of IPs?
In this case you should edit the /etc/postfix/main.cf and edit the $mynetworks accordingly to your IP range.

My test server performance tools dont support authentication config...,my iredmail on my internal network,now. So I want to disable iredmail server smtp authentication configure.


Simply add the IP range of your test tools in mynetworks in the file /etc/postfix/main.cf. For example let's say that your internal network is on the 192.168.1.x class:

mynetworks = 127.0.0.0/8 192.168.1.0/24

as one of the following rules starts with:  smtpd_sender_restrictions = permit_mynetworks ...
it should be ok smile

Don't forget to restart postfix:
service postfix restart

7

Re: how can I disable smtp with ssl

Albux's advice should fix your issue. (Thanks Albux smile)
It's not a good idea to turn off smtp auth.

8

Re: how can I disable smtp with ssl

Thanks Albux and zhanghuangbin.
Albux's advice very detail.