1

Topic: SMTP not working

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): My SQL
- Linux/BSD distribution name and version: Ubuntu 12.04
- Related log if you're reporting an issue:
====

I can't seem to send mail from my mail client (Mail.app) or through Roundcube.

Here is a part of my mail.log:

Mar 26 13:12:04 server1 postfix/smtpd[1637]: disconnect from localhost[127.0.0.1]
Mar 26 13:12:09 server1 postfix/anvil[1594]: statistics: max connection rate 1/60s for (submission:24.87.135.149) at Mar 26 13:08:41
Mar 26 13:12:09 server1 postfix/anvil[1594]: statistics: max connection count 1 for (submission:24.87.135.149) at Mar 26 13:08:41
Mar 26 13:12:09 server1 postfix/anvil[1594]: statistics: max cache size 1 at Mar 26 13:08:41
Mar 26 13:12:14 server1 postfix/smtpd[1637]: connect from localhost[127.0.0.1]
Mar 26 13:12:14 server1 postfix/smtpd[1637]: warning: connect to 127.0.0.1:10031: Connection refused
Mar 26 13:12:14 server1 postfix/smtpd[1637]: warning: problem talking to server 127.0.0.1:10031: Connection refused
Mar 26 13:12:15 server1 postfix/smtpd[1637]: warning: connect to 127.0.0.1:10031: Connection refused
Mar 26 13:12:15 server1 postfix/smtpd[1637]: warning: problem talking to server 127.0.0.1:10031: Connection refused
Mar 26 13:12:15 server1 postfix/smtpd[1637]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 451 4.3.5 Server configuration problem; from=<postmaster@VIRTUALDOMAIN.com> to=<postmaster@VIRTUALDOMAIN.com> proto=ESMTP helo=<server1.DOMAIN.net>
Mar 26 13:12:15 server1 roundcube: SMTP Error: SMTP error: Failed to add recipient 'postmaster@VIRTUALDOMAIN.com' in /usr/share/apache2/roundcubemail-0.8.2/program/include/main.inc on line 1485 (POST /mail/?_unlock=loading1364289132759&_lang=undefined?_task=mail&_action=send)
Mar 26 13:12:15 server1 postfix/smtpd[1637]: disconnect from localhost[127.0.0.1]
Mar 26 13:15:30 server1 postfix/qmgr[1097]: 3B2CE54238BA: from=<smmsp@server1.DOMAIN.net>, size=708, nrcpt=1 (queue active)
Mar 26 13:15:30 server1 postfix/qmgr[1097]: 784E954238BC: from=<smmsp@server1.DOMAIN.net>, size=708, nrcpt=1 (queue active)
Mar 26 13:15:30 server1 postfix/smtp[1647]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar 26 13:15:30 server1 postfix/smtp[1649]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar 26 13:15:30 server1 postfix/smtp[1647]: 3B2CE54238BA: to=<root@server1.DOMAIN.net>, relay=none, delay=2129, delays=2129/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Mar 26 13:15:30 server1 postfix/smtp[1649]: 784E954238BC: to=<root@server1.DOMAIN.net>, relay=none, delay=929, delays=929/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Mar 26 13:18:41 server1 postfix/smtpd[1657]: connect from S0106b88d1259b6c3.vc.shawcable.net[24.87.135.149]
Mar 26 13:19:01 server1 postfix/smtpd[1657]: disconnect from S0106b88d1259b6c3.vc.shawcable.net[24.87.135.149]
Mar 26 13:20:01 server1 postfix/pickup[1096]: 1F97354238C4: uid=107 from=<smmsp>
Mar 26 13:20:01 server1 postfix/cleanup[1691]: 1F97354238C4: message-id=<20130326092001.1F97354238C4@server1.DOMAIN.net>
Mar 26 13:20:01 server1 postfix/qmgr[1097]: 1F97354238C4: from=<smmsp@server1.DOMAIN.net>, size=708, nrcpt=1 (queue active)
Mar 26 13:20:01 server1 postfix/smtp[1695]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar 26 13:20:01 server1 postfix/smtp[1695]: 1F97354238C4: to=<root@server1.DOMAIN.net>, relay=none, delay=0.04, delays=0.03/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Mar 26 13:22:21 server1 postfix/anvil[1658]: statistics: max connection rate 1/60s for (submission:24.87.135.149) at Mar 26 13:18:41
Mar 26 13:22:21 server1 postfix/anvil[1658]: statistics: max connection count 1 for (submission:24.87.135.149) at Mar 26 13:18:41
Mar 26 13:22:21 server1 postfix/anvil[1658]: statistics: max cache size 1 at Mar 26 13:18:41
Mar 26 13:25:30 server1 postfix/qmgr[1097]: 1F97354238C4: from=<smmsp@server1.DOMAIN.net>, size=708, nrcpt=1 (queue active)
Mar 26 13:25:30 server1 postfix/smtp[1710]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Mar 26 13:25:30 server1 postfix/smtp[1710]: 1F97354238C4: to=<root@server1.DOMAIN.net>, relay=none, delay=329, delays=329/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

2

Re: SMTP not working

Noah wrote:

Mar 26 13:12:14 server1 postfix/smtpd[1637]: warning: connect to 127.0.0.1:10031: Connection refused

Cluebringer is not running. Please try to start it with below command:

# /etc/init.d/postfix-cluebringer restart
Noah wrote:

Mar 26 13:25:30 server1 postfix/smtp[1710]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

Amavisd service is not running. Please try to start it with below command:

# /etc/init.d/amavis restart

3

Re: SMTP not working

I rebooted the machine and did both commands, but no joy. Cannot send mail.

4

Re: SMTP not working

Noah wrote:

I rebooted the machine and did both commands, but no joy. Cannot send mail.

Check log files again, paste related error log here to help troubleshoot.