1 (edited by talal.shobaita 2013-03-11 15:58:04)

Topic: Problem in content filter

Hello ,

I've enabled amavisd on my mail server but after awhile many messages could not be delivered , or received .
I see logs in many messgaes as follow :

3963288524E    64591 Mon Mar 11 08:53:39  lanasser@palnet.com
                   (connect to 127.0.0.1[127.0.0.1]:10026: Connection refused)
                                         labuhijleh@gmail.com

D6B9A880C85    14279 Mon Mar 11 08:53:19  sainarik@palnet.com
                   (connect to 127.0.0.1[127.0.0.1]:10026: Connection refused)
                                         fainarik1@gmail.com

and sometimes at port 10024 connection refused .

my related config files are attached ,

your help is appreciated .

2

Re: Problem in content filter

Is amavisd service running?

3

Re: Problem in content filter

yes ,
it is running with 4 childs
amavisd (pid 705 704 703 702 643) is running...

4

Re: Problem in content filter

Please try restarting it, and it listens on port 10024.

5

Re: Problem in content filter

ZhangHuangbin wrote:

Please try restarting it, and it listens on port 10024.

Hello ,
I did many times , works fine a while but then start losing customer emails , I also checked resources everything is ok .
did you see my config files ? does it contain any wrong configurations ?

regards

6

Re: Problem in content filter

iRedMail doesn't enable port 10026 in Amavisd by default. Did you config Postfix to use it but without enabling it in Amavisd?

7

Re: Problem in content filter

maybe , in this line in master .cf :
-o content_filter=smtp-amavis:[127.0.0.1]:10026

should this be commented out ? how port 10024 is configured in iredmail
thanks

8

Re: Problem in content filter

talal.shobaita wrote:

maybe , in this line in master .cf :
-o content_filter=smtp-amavis:[127.0.0.1]:10026

should this be commented out ?

Please comment out this line if you don't have Amavisd listening on port 10026.

talal.shobaita wrote:

how port 10024 is configured in iredmail

*) iRedMail configures Amavisd to listen on port 10024 and 10025 by default.
*) As defined in Postfix parameter "content_filter=smtp-amavis:[127.0.0.1]:10024", Postfix will inject received emails to Amavisd through port 10024 for spam/virus scanning.
*) Amavisd invokes SpamAssassin for scan scanning, and ClamAV for virus scanning.
*) Amavisd injects scanned email back to Postfix through port 10025. It's defined in Postfix master.cf (search '10025').

Of course you can configure Amavisd to listen on port 10026 (and others) if you want. Search "$interface_policy" and "$policy_bank" in Amavisd config file will show you more details.

Hope it helps.

9

Re: Problem in content filter

Hello ,

Thanks for help , ALSO MY DELAY PROBLEM SOLVED WHEN I CHANGED MASTER.CF
smtp-amavis unix -  -   -   -   8  smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o disable_dns_lookups=yes
    -o max_use=20

127.0.0.1:10025 inet n  -   -   -   8  smtpd

BECAUSE MAX_SERVERS  IN AMAVISD.CONF IS 8 AT MY SERVER .
thanks again