1

Topic: How to create a do-not-reply email address?

==== Required information ====
- iRedMail version: 1.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: CentOS 6.3
- Related log if you're reporting an issue:
====

How would I go about creating a "do-no-reply" email address so that informational emails could be sent out, but iRedMail would not accept or store replies to the email?

Is it as simple as unchecking "Receiving mails for this account on mail server" in Advanced under the account?  By unchecking this setting, are there any other effects that I should be aware of?

Thanks,

Jon

2

Re: How to create a do-not-reply email address?

I tried unchecking "Receiving mails for this account on mail server" and the user was unable to send from RoundCube.

Any ideas?

3

Re: How to create a do-not-reply email address?

Hi,

i have solved this problem by creating a /dev/null alias. Maby there is another simplier solution but this works too.

1) create a real user on the mailserver with the username devnull
2) insert in /etc/postfix/aliases the local alias
devnull:        /dev/null
3) recreate aliases.db with "postmap aliases "
4) create your virtual alias like
address: do-no-reply@domain.com
goto: devnull

Now postfix delivers it to the local account that now is a blackhole.
In the maillog you can control if it works like this example:

Jan 29 06:13:59 mail.domain.com postfix/local[11715]: 5B06241A8A: to=<devnull@mail.domain.com>, relay=local, delay=0.05, delays=0.04/0.01/0/0, dsn=2.0.0, status=sent (delivered to file: /dev/null)

Hope this works. Let see if the oder gurus have a simplier solution smile

Have a nice day!

4

Re: How to create a do-not-reply email address?

Another solution is setting per-user transport to "discard" (without quotes). It's defined in /etc/postfix/master.cf by default, it will drop all emails it received.

5

Re: How to create a do-not-reply email address?

ok, _this_ is simple!
Zhang win

smile
Bye

6

Re: How to create a do-not-reply email address?

It worked!  Thanks Zhang, my hero.

Jon