1

Topic: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
==== ==== Required information ====
- iRedMail version: 0.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): iRedAdmin-Pro-MySQL 1.4
- Linux/BSD distribution name and version: Centos 5.8
- Related log if you're reporting an issue:
====
Hi Zhang

I config Relay/Transport Setting per domain but not working.Server sitll use local ip for sending not relay to ip outside.Pls help me.

Thanks

Post's attachments

iredmail.jpg
iredmail.jpg 70.76 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

2

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

Could you please show us related log in Postfix log file (/var/log/maillog) while you sending email?

3

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

Dear Zhang
Pls help me.
This is log :
[root@store1 ~]# tail -f /var/log/maillog
Jan 23 09:17:52 store1 postfix/smtpd[8747]: connect from abc.com[127.0.0.1]
Jan 23 09:17:52 store1 postfix/smtpd[8747]: 0EAA21DB06BE: client=abc.com[127.0.0.1]
Jan 23 02:17:52 store1 policyd: connection from: 127.0.0.1 port: 50464 slots: 0 of 2044 used
Jan 23 02:17:52 store1 policyd: rcpt=29, throttle=update(a), host=127.0.0.1, from=test@abc.com, to=nmtuan1702@yahoo.com, size=351/15728640,

quota=703/500000000, count=2/300(2), rcpt=2/1000(2), threshold=0%|0%|0%
Jan 23 09:17:52 store1 postfix/cleanup[8753]: 0EAA21DB06BE: message-id=<89c1913e1159946cddeac7d6809756b3@abc.com>
Jan 23 09:17:52 store1 dkim-filter[2983]: 0EAA21DB06BE "DKIM-Signature" header added
Jan 23 09:17:52 store1 postfix/qmgr[7386]: 0EAA21DB06BE: from=<test@abc.com>, size=571, nrcpt=1 (queue active)
Jan 23 09:17:52 store1 postfix/smtpd[8747]: disconnect from abc.com[127.0.0.1]
Jan 23 09:17:52 store1 postfix/smtpd[8759]: connect from abc.com[127.0.0.1]
Jan 23 09:17:52 store1 postfix/smtpd[8759]: 484FA1DB06D4: client=abc.com[127.0.0.1]
Jan 23 09:17:52 store1 postfix/cleanup[8753]: 484FA1DB06D4: message-id=<89c1913e1159946cddeac7d6809756b3@abc.com>
Jan 23 09:17:52 store1 dkim-filter[2983]: 484FA1DB06D4 "DKIM-Signature" header added
Jan 23 09:17:52 store1 postfix/smtpd[8759]: disconnect from abc.com[127.0.0.1]
Jan 23 09:17:52 store1 postfix/qmgr[7386]: 484FA1DB06D4: from=<test@abc.com>, size=1395, nrcpt=1 (queue active)
Jan 23 09:17:52 store1 amavis[3604]: (03604-16) Passed CLEAN, MYNETS LOCAL [127.0.0.1] [127.0.0.1] <test@abc.com> -> <nmtuan1702@yahoo.com>,

Message-ID: <89c1913e1159946cddeac7d6809756b3@abc.com>, mail_id: JzeSWQFl8q5Q, Hits: -, size: 963, queued_as: 484FA1DB06D4, dkim_id=@abc.com, 183

ms
Jan 23 09:17:52 store1 postfix/smtp[8757]: 0EAA21DB06BE: to=<nmtuan1702@yahoo.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.34, delays=0.14/0.01/0/0.19,

dsn=2.0.0, status=sent (250 2.0.0 Ok, id=03604-16, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 484FA1DB06D4)
Jan 23 09:17:52 store1 postfix/qmgr[7386]: 0EAA21DB06BE: removed
Jan 23 09:17:52 store1 postfix/smtp[8761]: 484FA1DB06D4: enabling PIX workarounds: disable_esmtp delay_dotcrlf for mta6.am0.yahoodns.net[66.94.238.147]:25
Jan 23 09:17:55 store1 postfix/smtp[8761]: 484FA1DB06D4: to=<nmtuan1702@yahoo.com>, relay=mta6.am0.yahoodns.net[66.94.238.147]:25, delay=2.9,

delays=0.07/0.01/0.77/2, dsn=2.0.0, status=sent (250 ok dirdel)
Jan 23 09:17:55 store1 postfix/qmgr[7386]: 484FA1DB06D4: removed

4

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

To send out email with a relay host, please set Postfix parameter "relayhost =" instead.
Per-user and per-domain relay are used for received emails.

5

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

Hi Zhang
"relayhost=" default will relay all email so i dont want
I only want relay per domain to another server ip.
example:
Set per-domain relay setting with iRedAdmin-Pro for abc.com, value : smtp:mx.gw.com:25
Set per-domain relay setting with iRedAdmin-Pro for def.com, value : smtp:mx1.gw1.com:25

6

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

Please try searching "postfix sender depend relayhost" with Google.

7

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

==== Required information ====
- iRedAdmin Pro version: 1.8.2
- iRedMail version: 0.8.7
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Linux version 2.6.32-431.20.3.el6.x86_64 (mockbuild@c6b9.bsys.dev.centos.org) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-4) (GCC) ) #1 SMP Thu Jun 19 21:14:45 UTC 2014
- Related log if you're reporting an issue:
====
- tail -f /var/log/maillog

Jul 21 17:00:10 mail1 postfix/smtpd[22869]: connect from esa.fromdomain.com[xx.xx.xx.xx]
Jul 21 17:00:10 mail1 cbpolicyd[22182]: module=AccessControl, action=ok, host=xx.xx.xx.xx, helo=esa.fromdomain.com, from=user@fromdomain.com.com, to=15555551212@fax.ourdomain.com, reason=verdict
Jul 21 17:00:10 mail1 postfix/smtpd[22869]: 6C3A121EFE3: client=esa.fromdomain.com[xx.xx.xx.xx]
Jul 21 17:00:10 mail1 postfix/cleanup[22875]: 6C3A121EFE3: message-id=<00b901cfa526$c2fb67b0$48f23710$@fromdomain.com>
Jul 21 17:00:10 mail1 postfix/qmgr[22812]: 6C3A121EFE3: from=<user@fromdomain.com.com>, size=13751, nrcpt=1 (queue active)
Jul 21 17:00:10 mail1 postfix/smtpd[22869]: disconnect from esa.fromdomain.com[xx.xx.xx.xx]
Jul 21 17:00:14 mail1 postfix/smtpd[22884]: connect from localhost[127.0.0.1]
Jul 21 17:00:14 mail1 postfix/smtpd[22884]: 8B900220C60: client=localhost[127.0.0.1]
Jul 21 17:00:14 mail1 postfix/cleanup[22875]: 8B900220C60: message-id=<00b901cfa526$c2fb67b0$48f23710$@fromdomain.com>
Jul 21 17:00:14 mail1 postfix/smtpd[22884]: disconnect from localhost[127.0.0.1]
Jul 21 17:00:14 mail1 postfix/qmgr[22812]: 8B900220C60: from=<user@fromdomain.com.com>, size=14211, nrcpt=1 (queue active)
Jul 21 17:00:14 mail1 postfix/qmgr[22812]: warning: connect to transport private/smpt: No such file or directory
Jul 21 17:00:14 mail1 amavis[1700]: (01700-04) Passed CLEAN {RelayedInternal}, MYUSERS LOCAL [xx.xx.xx.xx]:45885 [yy.yy.yy.yy] <user@fromdomain.com.com> -> <15555551212@fax.ourdomain.com>, Queue-ID: 6C3A121EFE3, Message-ID: <00b901cfa526$c2fb67b0$48f23710$@fromdomain.com>, mail_id: CmP3YjhRYbZH, Hits: 0.001, size: 13750, queued_as: 8B900220C60, 3995 ms
Jul 21 17:00:14 mail1 postfix/smtp[22880]: 6C3A121EFE3: to=<15555551212@fax.ourdomain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=4.3, delays=0.26/0.02/0.01/4, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 8B900220C60)
Jul 21 17:00:14 mail1 postfix/qmgr[22812]: 6C3A121EFE3: removed
Jul 21 17:00:14 mail1 postfix/error[22885]: 8B900220C60: to=<15555551212@fax.ourdomain.com>, relay=none, delay=0.07, delays=0.01/0.03/0/0.03, dsn=4.3.0, status=deferred (mail transport unavailable)

We are running faxback (NetSatifaxtion) server.  We are using iRedMail Pro as the inbound fax to email distribution which is working fine and outbound (email to fax) as an SMTP Relay.  The DNS records for our fax domain (fax.ourdomain.com) are The A record for fax.ourdomain.com goes to the faxback IP Address and the MX record goes to mail1.ourdomain.com (the iRedmail server).  In order to send email to fax, the user sends an email to telephonenumbertofaxto@fax.ourdomain.com.  It should go through iRedMail SMTP Relay (after clamd etc.) to the faxback server where the email attachment will be faxed to telephonenumbertofaxto.

In iRedAdmin-Pro under Domains and Accounts -> fax.ourdomain.com -> Relay we have smtp:[fax.ourdomain.com]:25 in the "Relay/Transport Setting" and "Relay without verifying local recipients" is checked.

8

Re: Relay/Transport Setting per domain with iRedAdmin-Pro-MySQL not work

What's your issue? What are you trying to solve?

mparmley wrote:

Jul 21 17:00:14 mail1 postfix/qmgr[22812]: warning: connect to transport private/smpt: No such file or directory

"smpt"? It should be 'smtp'.

Also, Please always post your own questions in a new topic, do not hijack other's thread, especially a one-year old thread.