1

Topic: Install seemed fine, but can't send or receive

Hi.  I just installed iRedMail 0.8.3 with MySQL backend on my fresh VPS running Ubuntu 12.04.  The install seemed to go fine.  At least, I can log into both roundcube and create new users with iredadmin.

The problem is that I can't send or receive emails.  If I send an email from roundcube to my gmail, it never gets there.  If I send an email from my gmail to roundcube, it doesn't get there either.  Neither way gives me any kind of Delivery Failure notification, or anything like that.

Here is a snippet from my mail.log

Dec 13 03:19:32 mail postfix/postfix-script[19991]: refreshing the Postfix mail system
Dec 13 03:19:32 mail postfix/master[1765]: reload -- version 2.9.3, configuration /etc/postfix
Dec 13 03:19:32 mail postfix/scache[19971]: statistics: start interval Dec 13 03:18:41
Dec 13 03:19:32 mail postfix/scache[19971]: statistics: domain lookup hits=0 miss=2 success=0%
Dec 13 03:19:32 mail postfix/scache[19971]: statistics: address lookup hits=0 miss=2 success=0%
Dec 13 03:20:20 mail postfix/smtpd[20036]: connect from localhost[127.0.0.1]
Dec 13 03:20:20 mail postfix/smtpd[20036]: 8F29041B19: client=localhost[127.0.0.1], sasl_method=LOGIN
, sasl_username=cpag@backsaba.com
Dec 13 03:20:21 mail postfix/cleanup[20044]: 8F29041B19: message-id=<c7d719b47ca41e928483085ffb54b08e
@backsaba.com>
Dec 13 03:20:21 mail postfix/qmgr[19995]: 8F29041B19: from=<cpag@backsaba.com>, size=555, nrcpt=
1 (queue active)
Dec 13 03:20:21 mail roundcube: User cpag@backsaba.com [99.236.220.75]; Message for chris.pagnut
ti@gmail.com; 250: 2.0.0 Ok: queued as 8F29041B19
Dec 13 03:20:21 mail postfix/smtp[20050]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Dec 13 03:20:21 mail postfix/smtp[20050]: 8F29041B19: to=<chris.pag@gmail.com>, relay=none, dela
y=1.1, delays=1.1/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connec
tion refused)
Dec 13 03:20:21 mail postfix/smtpd[20036]: disconnect from localhost[127.0.0.1]
Dec 13 03:24:32 mail postfix/qmgr[19995]: 848584228B: from=<chris.pag@gmail.com>, size=1958, nrc
pt=1 (queue active)
Dec 13 03:24:32 mail postfix/qmgr[19995]: 3B48B422A7: from=<cpag@backsaba.com>, size=599, nrcpt=
1 (queue active)
Dec 13 03:24:32 mail postfix/smtp[20127]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Dec 13 03:24:32 mail postfix/smtp[20129]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Dec 13 03:24:32 mail postfix/smtp[20127]: 848584228B: to=<cpag@backsaba.com>, relay=none, delay=
1034, delays=1034/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connec
tion refused)
Dec 13 03:24:32 mail postfix/smtp[20129]: 3B48B422A7: to=<chris.pag@gmail.com>, relay=none, dela
y=421, delays=421/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connec
tion refused)
Dec 13 03:26:23 mail postfix/smtpd[20165]: connect from mail-qa0-f43.google.com[209.85.216.43]
Dec 13 03:26:23 mail cbpolicyd[1829]: module=Greylisting, action=pass, host=209.85.216.43, helo=mail-
qa0-f43.google.com, from=chris.pag@gmail.com, to=cpag@backsaba.com, reason=authenticated
Dec 13 03:26:23 mail postfix/smtpd[20165]: 8103D422AC: client=mail-qa0-f43.google.com[209.85.216.43]
Dec 13 03:26:24 mail postfix/cleanup[20172]: 8103D422AC: message-id=<CAF_Uw1fw10aPwfSWZyVshibwzZZovWH
Y35ZDgDmE_8nYXQ=Ntw@mail.gmail.com>
Dec 13 03:26:24 mail postfix/qmgr[19995]: 8103D422AC: from=<chris.pag@gmail.com>, size=1938, nrc
pt=1 (queue active)
Dec 13 03:26:24 mail postfix/smtp[20177]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Dec 13 03:26:24 mail postfix/smtp[20177]: 8103D422AC: to=<cpag@backsaba.com>, relay=none, delay=
1.1, delays=1.1/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connecti
on refused)

And here is my iredapd.log

2012-12-12 16:02:28 INFO Starting iredapd (v1.3.8, mysql). Enabled plugin(s): sql_alias_access_policy
. Listening on 127.0.0.1:7777.
2012-12-12 16:13:48 INFO Starting iredapd (v1.3.8, mysql). Enabled plugin(s): sql_alias_access_policy
. Listening on 127.0.0.1:7777.
2012-12-12 17:13:37 INFO Starting iredapd (v1.3.8, mysql). Enabled plugin(s): sql_alias_access_policy
. Listening on 127.0.0.1:7777.
2012-12-12 18:30:25 INFO [209.85.216.43] chris.pag@gmail.com -> cpag@backsaba.com, DUNNO
2012-12-12 18:37:46 INFO [209.85.216.43] chris.pag@gmail.com -> cpag@backsaba.com, DUNNO
2012-12-13 03:07:18 INFO [209.85.216.43] chris.pag@gmail.com -> cpag@backsaba.com, DUNNO
2012-12-13 03:10:45 INFO [209.85.216.171] chris.pag@gmail.com -> cpag@backsaba.com, DUNNO
2012-12-13 03:17:32 INFO [127.0.0.1] cpag@backsaba.com -> chris.pag@gmail.com, DUNNO
2012-12-13 03:20:20 INFO [127.0.0.1] cpag@backsaba.com -> chris.pag@gmail.com, DUNNO
2012-12-13 03:26:23 INFO [209.85.216.43] chris.pag@gmail.com -> cpag@backsaba.com, DUNNO

The obvious thing that stands out is all the "Connection refused"s in the mail.log.  But I'm not sure what to do about it.  Not finding much with google.

Funny thing is that I had it working on Debian the other day in about 2 minutes.  I switched to Ubuntu today, but it's not working.

Any help would be really great.  Thanks.

==== Required information ====
- iRedMail version:  0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):  MySQL
- Linux/BSD distribution name and version:  Ubuntu 12.04
- Related log if you're reporting an issue:
====

2

Re: Install seemed fine, but can't send or receive

I closed this thread due to your duplicate post below, thanks for your understanding.
http://www.iredmail.org/forum/topic4282 … lamav.html