1

Topic: Disable admin notification of spam?

==== Required information ====
- iRedMail version: 0.7.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: CentOS 5.6
- Related log if you're reporting an issue:
====

This is an easy fix, I assume, but I can't find the answer anywhere as the amavisd.conf looks different in iRedMail than in all the online examples I found.

Basically, I don't want to get an email in the admin inbox every time the server detects a spam message.  I can't for the life of me figure out how to disable this.  I assume it has something to do with this area in amavisd.conf:

    # notify administrator of locally originating malware
    virus_admin_maps => ["root\@$mydomain"],
    spam_admin_maps  => ["root\@$mydomain"],
    warnbadhsender   => 0,
    warnvirussender  => 1,
    warnspamsender   => 1,

How do I disable this?

2

Re: Disable admin notification of spam?

Nobody?

3

Re: Disable admin notification of spam?

answerman wrote:

    spam_admin_maps  => ["root\@$mydomain"],

It will send notification emails to "root@[YOUR_SERVER_HOSTNAME]". If you have alias entry for root user in /etc/postfix/aliases, then mails will be forwarded to the alias address. That's why you receive them.

To fix it, please try to comment out "spam_admin_maps =>", then restart Amavisd service.

4

Re: Disable admin notification of spam?

ZhangHuangbin wrote:
answerman wrote:

    spam_admin_maps  => ["root\@$mydomain"],

It will send notification emails to "root@[YOUR_SERVER_HOSTNAME]". If you have alias entry for root user in /etc/postfix/aliases, then mails will be forwarded to the alias address. That's why you receive them.

To fix it, please try to comment out "spam_admin_maps =>", then restart Amavisd service.

That seems to have worked.  Thank you.