1

Topic: iem SMTP

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):  LDAP
- Linux/BSD distribution name and version: ubuntu
- Related log if you're reporting an issue:
====

I want to use iRedMail as my default SMTP server on iem.

What would be my 'username' and 'passsword'?

2

Re: iem SMTP

Sorry, what's "ism"?
Usually, username of mail account is full email address.

3

Re: iem SMTP

iem

Interspire Email Marketer

4

Re: iem SMTP

Any help would be very much appreciated.

5

Re: iem SMTP

You can create mail accounts with iRedAdmin (httpS://your_server/iredadmin/), then use this mail account in your IEM.
Login username must be full email address.

6

Re: iem SMTP

Thank you for your help. I have tried that, I enter:

SMTP Hostname: demo.iredmail.org
SMTP Username: postmaster@demo.iredmail.org
SMTP Password:   ************
SMTP Port: 587

Then when I try to send a test email I receive the error message below:


A test email has not been successfully sent to the email address info@didyouhear.co.uk: Login failed, please check the username and password and try again.

7

Re: iem SMTP

iredmail_complete_noobi wrote:

SMTP Hostname: demo.iredmail.org

Sorry, did you really use 'demo.iredmail.org' for testing? Please don't do this. Setup your own one instead.

8

Re: iem SMTP

I've set my localhost to demo.iredmail.org.

Is that wrong?

9

Re: iem SMTP

Yap. Don't use registered domains that you don't own. If you're just testing use a local domain name like xpto.test.local. Or buy a domain from Godaddy.

But regarding your question your hostname and your domain are 2 different things so if the SMTP host is demo.xxx.xxx the domain is xxx.xxx. In the SMTP login you have to use user@xxx.xxx not user@demo.xxx.xxx.

10

Re: iem SMTP

I'm even more confused now. I have a domain, that is not the problem. I was just trying to get this working.

Basically I want to send email via my local SMTP server. How do I do that?

My domain is: www.warehouseutility.com which is hosted by freehostia.com I do not want to use their SMTP service.

I currently have my localhost set to demo.iredmail.org as that was the example given.

I need to know what to put in the following fields.

SMTP Hostname:
SMTP Username:
SMTP Port:

Many thanks for your help

11

Re: iem SMTP

iredmail_complete_noobi wrote:

I currently have my localhost set to demo.iredmail.org as that was the example given.

Please do NOT use "demo.iredmail.org" as YOUR server hostname, because it's a valid DNS name which owned by iRedMail project, which means your client connected to our server to send emails, that's obviously wrong.

12

Re: iem SMTP

iredmail_complete_noobi wrote:

I need to know what to put in the following fields.

Presumably:
SMTP Hostname: warehouseutility.com
SMTP Username: youremail@warehouseutility.com
SMTP Port: 25 or 587

13

Re: iem SMTP

I've tried those settings and I get the error

Unable to connect to mail server: Connection refused(111)

14

Re: iem SMTP

Starting Nmap 5.51 ( http://nmap.org ) at 2012-11-29 14:11 CET
Nmap scan report for warehouseutility.com (66.40.52.179)
Host is up (0.17s latency).
Not shown: 997 closed ports
PORT     STATE    SERVICE
80/tcp   open     http
111/tcp  filtered rpcbind
2049/tcp filtered nfs


Either your domain isnt pointing to your mailserver, your iptables are blocking the ports or the mailsever is hosted on a different ip that you haven't mentioned yet.

15

Re: iem SMTP

Did you have iRedMail correctly installed on your server (warehouseutility.com)?

iRedMail will load default iptables rules after installation successfully completed, port 25/587 are open by default.

16

Re: iem SMTP

No I didn't do that as I wanted to test it first (hence the use of  "demo.iredmail.org")

How do I go about changing it?

Thank-you again for all your help.

17

Re: iem SMTP

It's mentioned in iRedMail installation guide:
http://iredmail.org/install_iredmail_on … t_hostname

18

Re: iem SMTP

That's great thank-you. I've done that and I can send mail using Thunderbird with the settings

Server name: warehouseutility.com
Port: 587
User name: mail@warehouseutility.com
Authentication method: Password, transmitted insecurely
Connection security: None

yet I cannot send mail via Interspire Email Marketer with the settings

SMTP hostname: warehouseutility.com
SMTP username: mail@warehouseutility.com