1 (edited by wezon 2012-10-27 06:51:39)

Topic: Installation issues.

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: CentOS 5.8
- Related log if you're reporting an issue:

--> Finished Dependency Resolution
dovecot-managesieve-0.11.13-0_6.el5.i386 from iRedMail-Dovecot-12 has depsolving problems
  --> Missing Dependency: dovecot >= 1.2 is needed by package dovecot-managesieve-0.11.13-0_6.el5.i386 (iRedMail-Dovecot-12)
php53-common-5.3.3-13.el5_8.i386 from installed has depsolving problems
  --> php53-common conflicts with php-common
5:postfix-perl-scripts-2.5.9-5.ired.i386 from iRedMail has depsolving problems
  --> Missing Dependency: postfix = 5:2.5.9-5.ired is needed by package 5:postfix-perl-scripts-2.5.9-5.ired.i386 (iRedMail)
1:dovecot-sieve-0.1.19-9.1.el5.i386 from iRedMail-Dovecot-12 has depsolving problems
  --> Missing Dependency: dovecot >= 1.2 is needed by package 1:dovecot-sieve-0.1.19-9.1.el5.i386 (iRedMail-Dovecot-12)
Error: php53-common conflicts with php-common
Error: Missing Dependency: dovecot >= 1.2 is needed by package 1:dovecot-sieve-0.1.19-9.1.el5.i386 (iRedMail-Dovecot-12)
Error: Missing Dependency: dovecot >= 1.2 is needed by package dovecot-managesieve-0.11.13-0_6.el5.i386 (iRedMail-Dovecot-12)
Error: Missing Dependency: postfix = 5:2.5.9-5.ired is needed by package 5:postfix-perl-scripts-2.5.9-5.ired.i386 (iRedMail)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

====


I'm getting nowhere. Yeah, i'm a little new to linux
Any ideas on how to fix this?

package-cleanup --problems returns with:

Setting up yum
Reading local RPM database
Processing all local requires
No problems found

2

Re: Installation issues.

wezon wrote:

Error: php53-common conflicts with php-common

Please solve this conflict first. iRedMail provides php-5.2 by default.

3

Re: Installation issues.

dovecot-managesieve-0.11.13-0_6.el5.i386 from iRedMail-Dovecot-12 has depsolving problems
  --> Missing Dependency: dovecot >= 1.2 is needed by package dovecot-managesieve-0.11.13-0_6.el5.i386 (iRedMail-Dovecot-12)
5:postfix-perl-scripts-2.5.9-5.ired.i386 from iRedMail has depsolving problems
  --> Missing Dependency: postfix = 5:2.5.9-5.ired is needed by package 5:postfix-perl-scripts-2.5.9-5.ired.i386 (iRedMail)
1:dovecot-sieve-0.1.19-9.1.el5.i386 from iRedMail-Dovecot-12 has depsolving problems
  --> Missing Dependency: dovecot >= 1.2 is needed by package 1:dovecot-sieve-0.1.19-9.1.el5.i386 (iRedMail-Dovecot-12)
Error: Missing Dependency: dovecot >= 1.2 is needed by package 1:dovecot-sieve-0.1.19-9.1.el5.i386 (iRedMail-Dovecot-12)
Error: Missing Dependency: dovecot >= 1.2 is needed by package dovecot-managesieve-0.11.13-0_6.el5.i386 (iRedMail-Dovecot-12)
Error: Missing Dependency: postfix = 5:2.5.9-5.ired is needed by package 5:postfix-perl-scripts-2.5.9-5.ired.i386 (iRedMail)

4

Re: Installation issues.

So. I've had enough of iredmail. I'm sorry.

Can you please help me here?
I now try to install only postfix, but it returns:

Package postfix is obsoleted by postfix-perl-scripts, trying to install 5:postfix-perl-scripts-2.5.9-5.ired.i386 instead
Resolving Dependencies
--> Running transaction check
---> Package postfix-perl-scripts.i386 5:2.5.9-5.ired set to be updated
--> Processing Dependency: postfix = 5:2.5.9-5.ired for package: postfix-perl-scripts
--> Finished Dependency Resolution
5:postfix-perl-scripts-2.5.9-5.ired.i386 from iRedMail has depsolving problems
  --> Missing Dependency: postfix = 5:2.5.9-5.ired is needed by package 5:postfix-perl-scripts-2.5.9-5.ired.i386 (iRedMail)
Error: Missing Dependency: postfix = 5:2.5.9-5.ired is needed by package 5:postfix-perl-scripts-2.5.9-5.ired.i386 (iRedMail)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

5

Re: Installation issues.

Could you please remove package "postfix-perl-scripts" first?

6 (edited by wezon 2012-11-17 05:06:11)

Re: Installation issues.

It's not installed. That's the thing

edit:
yum remove postfix-perl-scripts

Loaded plugins: fastestmirror, priorities, security
Setting up Remove Process
No Match for argument: postfix-perl-scripts
Loading mirror speeds from cached hostfile
* base: mirror01.th.ifl.net
* extras: mirror01.th.ifl.net
* updates: mirror01.th.ifl.net
36 packages excluded due to repository priority protections
Package(s) postfix-perl-scripts available, but not installed.
No Packages marked for removal

7

Re: Installation issues.

I want to completely remove iredmail.

It now even creates problems for me with just updating the system.

Is it not possible to remove without removing httpd and mysql?

8

Re: Installation issues.

wezon wrote:

I want to completely remove iredmail.

It now even creates problems for me with just updating the system.

Is it not possible to remove without removing httpd and mysql?

You can remove related packages manually. e.g. Postfix, dovecot, etc.