1

Topic: Problem with "transport_maps lookup failure"

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
==== ==== Required information ====
- iRedMail version: 0.8.2
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): mysql
- Linux/BSD distribution name and version: debian 6.0.6
- Related log if you're reporting an issue: mail.log
====

Hello all,
I got some troubles with an installation that stopped properly working.
If I try to send an email I got this error:
Nov  6 20:02:05 srv1 postfix/smtpd[6834]: NOQUEUE: reject: RCPT from tbjjbihbhcfh.turbo-smtp.net[199.187.172.57]: 550 5.1.1 <***HIDDEN***>: Recipient address rejected: User unknown in virtual mailbox table; from=<***HIDDEN***> to=<***HIDDEN***> proto=SMTP helo=<tbjjbihbhcfh.turbo-smtp.net>

and I've found on mail.log this too:

Nov  6 19:58:48 srv1 postfix/error[6943]: C2BE239BAF8: to=<6@srv1.libera-soft.it>, relay=none, delay=2358396, delays=2358396/0/0/0.05, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 19:58:48 srv1 postfix/error[6917]: AE88B39BAF6: to=<Lagan?@srv1.libera-soft.it>, relay=none, delay=613078, delays=613078/0/0/0.14, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 19:58:48 srv1 postfix/error[6946]: CDE6439BAF9: to=<guidadaniele@virgilio.it>, relay=none, delay=3221, delays=3221/0/0/0.02, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 19:58:48 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 19:58:48 srv1 postfix/cleanup[6968]: DBCEA39BAFB: message-id=<20121106183104.6872D1371A3D@srv1.libera-soft.it>
Nov  6 19:58:48 srv1 postfix/error[6954]: B801639BAF7: to=<Pamela@srv1.libera-soft.it>, relay=none, delay=699505, delays=699504/0.01/0/0.12, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 19:58:48 srv1 postfix/error[6943]: C2BE239BAF8: to=<Al?@srv1.libera-soft.it>, relay=none, delay=2358396, delays=2358396/0/0/0.11, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 19:58:48 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 19:58:48 srv1 postfix/cleanup[6965]: EAA6939BAFC: message-id=<20121106183110.B7A021371AD4@srv1.libera-soft.it>
Nov  6 19:58:49 srv1 postfix/error[6943]: C2BE239BAF8: to=<Antonella@srv1.libera-soft.it>, relay=none, delay=2358396, delays=2358396/0/0/0.24, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 19:58:49 srv1 postfix/pickup[3538]: 15E2439BAFD: uid=105 from=<***HIDDEN***> orig_id=3895B1371D53
Nov  6 19:58:49 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 19:58:49 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 19:58:49 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 19:58:49 srv1 postfix/cleanup[6968]: 15E2439BAFD: message-id=<20121106183125.20A091371BC7@srv1.libera-soft.it>
Nov  6 19:58:49 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 19:58:49 srv1 postfix/trivial-rewrite[6823]: warning: transport_maps lookup failure
Nov  6 20:05:21 srv1 postfix/error[7167]: 97B6E39BAF4: to=<Patern?@srv1.libera-soft.it>, relay=none, delay=2359204, delays=2359196/8.4/0/0.19, dsn=4.3.0, status=deferred (address resolver failure)
Nov  6 20:05:21 srv1 postfix/error[7116]: 9F1C31371DC7: to=<Serena@srv1.libera-soft.it>, relay=none, delay=961516, delays=961508/8.4/0/0.19, dsn=4.3.0, status=deferred (address resolver failure)

Before of that I had this error:

postfix/proxymap23175: warning: mysql query failed: Illegal mix of collations (ascii_general_ci,IMPLICIT) and (latin1_swedish_ci,COERCIBLE) for operation '='
but after changing all tables/columns to utf-8_general_ci this warning gone.

What could be the problem?
mysql server is up
this is my postconf -n

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
allow_min_user = no
append_dot_mydomain = no
biff = no
bounce_queue_lifetime = 1d
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
delay_warning_time = 0h
disable_vrfy_command = yes
enable_original_recipient = no
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = ipv4
mailbox_command = /usr/lib/dovecot/deliver
mailbox_size_limit = 0
maximal_backoff_time = 4000s
maximal_queue_lifetime = 3d
message_size_limit = 15728640
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
mydomain = libera-soft.it
myhostname = srv1.libera-soft.it
mynetworks = 127.0.0.0/8
mynetworks_style = subnet
myorigin = srv1.libera-soft.it
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $mydestination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domains $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_domains $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps $smtpd_sender_restrictions
queue_run_delay = 180s
readme_directory = no
recipient_bcc_maps = proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_user.cf, proxy:mysql:/etc/postfix/mysql/recipient_bcc_maps_domain.cf
recipient_delimiter = +
relay_domains = $mydestination, proxy:mysql:/etc/postfix/mysql/relay_domains.cf
relayhost =
sender_bcc_maps = proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_user.cf, proxy:mysql:/etc/postfix/mysql/sender_bcc_maps_domain.cf
smtp_data_init_timeout = 240s
smtp_data_xfer_timeout = 600s
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_enforce_tls = no
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,permit_sasl_authenticated, check_helo_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:127.0.0.1:7777, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_policy_service inet:127.0.0.1:10031
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain =
smtpd_sasl_path = ./dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql/sender_login_maps.cf
smtpd_sender_restrictions = permit_mynetworks, permit_sasl_authenticated
smtpd_tls_CAfile = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_cert_file = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_key_file = /etc/ssl/private/iRedMail.key
smtpd_tls_loglevel = 0
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = proxy:mysql:/etc/postfix/mysql/transport_maps_user.cf, proxy:mysql:/etc/postfix/mysql/transport_maps_domain.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql/virtual_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/catchall_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_catchall_maps.cf
virtual_gid_maps = static:1000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql/virtual_mailbox_maps.cf
virtual_minimum_uid = 1000
virtual_transport = dovecot
virtual_uid_maps = static:1000

2

Re: Problem with "transport_maps lookup failure"

You have below settings in your Postfix:

transport_maps = proxy:mysql:/etc/postfix/mysql/transport_maps_user.cf, proxy:mysql:/etc/postfix/mysql/transport_maps_domain.cf

Do below command return any result?

# postmap -q "user@your_domain" mysql:/etc/postfix/mysql/transport_maps_user.cf
# postmap -q "your_domain" mysql:/etc/postfix/mysql/transport_maps_domain.cf

3

Re: Problem with "transport_maps lookup failure"

ZhangHuangbin wrote:
# postmap -q "user@your_domain" mysql:/etc/postfix/mysql/transport_maps_user.cf
# postmap -q "your_domain" mysql:/etc/postfix/mysql/transport_maps_domain.cf

they doesn't report nothing.
I've increased mysql connections and added google dns server to the dns servers list, and now all seems working properly. mail.log doen't shows more warnings or errors.
Anyway this seems strange to me, becouse If this was a mysql problem, then I should had troubles with other services like the web.