1 (edited by britesc 2012-11-06 19:01:31)

Topic: [SOLVED] Newbie Install Error 0.8.3

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
==== ==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version: Ubuntu 12.10
- Related log if you're reporting an issue: ?
====
Just run the install and it has exited with the following messages
...
Processing triggers for ureadahead ...
Errors were encountered while processing:
postfix
altermime
logwatch
postfix-mysql
postfix-pcre
E: Sub-process /usr/bin/dpkg returned an error code (1)
<ERROR> Installation failed, please check the terminal output

I originally tried a postfix courier-imap install but removed all postfix and courier-imap I could find so that the machine was clean...
MySQL already installed for ZoneMinder as is PHP5 and Apache2.

Please could someone advise me on what steps I need to take to complete the installation?
Thanks and kind regards,

jB cool

2

Re: [SOLVED] Newbie Install Error 0.8.3

As mentioned in iRedMail installation guide, iRedMail is designed to be deployed on a FRESH os. i suggest you trying with a fresh, minimal os again.

3

Re: [SOLVED] Newbie Install Error 0.8.3

ZhangHuangbin wrote:

As mentioned in iRedMail installation guide, iRedMail is designed to be deployed on a FRESH os. i suggest you trying with a fresh, minimal os again.

Thanks, but that is impossible so I fixed it.

1. Create a /etc/init.d/postfix with 4 blank lines
2. aptitude purge postfix
3. aptitude clean

voila it now installs...

I think this action will help others to overcome hangover problems therefore a fresh install is not necessary anymore.

Kind regards

jB

4

Re: [SOLVED] Newbie Install Error 0.8.3

Thanks for your sharing. smile