1

Topic: hostname resolution after install

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend : LDAP
- Linux/BSD distribution name and version: CentOS 6.3
- Related log if you're reporting an issue: iREdMail.tips
====

I just setup iRedMail using this tutorial, http://iredmail.org/install_iredmail_on_rhel.html
Here's my issue.. under Preparations it says to setup a FQDN so i did (internalmail.example.com) and I confirmed it with hostname -f and it's good after reboot....
Next when installing iRedMail.sh it comes time to setup the "First Virtual Domain Name" it tells me I cannot use the same hostname as the server so I put in wmail.example.com ... the install continues and completes and after I reboot I cannot ping the hostname of either from another computer. In fact it shows up in iRedMail.tips that the webmail interface will be available at https://internalmail.example.com/mail/ and it is not, I tried https://wmail.example.com/mail/ with no luch as well. I can access them if i put the ip in rather than the hostnames. I am a little confused to why this is the case and am reluctant to try and integrate with AD environment(http://www.iredmail.org/wiki/index.php?title=Integration/Active.Directory.iRedMail) until I can confirm this is not by error. How can i send mail to a hostname that wont resolve?

Thanks for any help
slkph

2

Re: hostname resolution after install

Hi there;

I think you have a firewall problem; please restart the iptables service. Also remember to uncomment the ldap rule in /etc/sysconfig/iptables before you restart the service.

Bye

slkph wrote:

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend : LDAP
- Linux/BSD distribution name and version: CentOS 6.3
- Related log if you're reporting an issue: iREdMail.tips
====

I just setup iRedMail using this tutorial, http://iredmail.org/install_iredmail_on_rhel.html
Here's my issue.. under Preparations it says to setup a FQDN so i did (internalmail.example.com) and I confirmed it with hostname -f and it's good after reboot....
Next when installing iRedMail.sh it comes time to setup the "First Virtual Domain Name" it tells me I cannot use the same hostname as the server so I put in wmail.example.com ... the install continues and completes and after I reboot I cannot ping the hostname of either from another computer. In fact it shows up in iRedMail.tips that the webmail interface will be available at https://internalmail.example.com/mail/ and it is not, I tried https://wmail.example.com/mail/ with no luch as well. I can access them if i put the ip in rather than the hostnames. I am a little confused to why this is the case and am reluctant to try and integrate with AD environment(http://www.iredmail.org/wiki/index.php?title=Integration/Active.Directory.iRedMail) until I can confirm this is not by error. How can i send mail to a hostname that wont resolve?

Thanks for any help
slkph

3

Re: hostname resolution after install

Do you have these two hostames pointed to this server IP address?