1 (edited by Hoper 2012-11-05 18:39:46)

Topic: ERROR install iRedMail 0.8.3

==== ==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Linux post-ired-s1 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
- Related log if you're reporting an issue:
====
After run

sudo bash iRedMail.sh
...
< Question > Continue? [y|N]y
< INFO > Installing package(s): postfix-ldap slapd ldap-utils libnet-ldap-perl mysql-server mysql-client apache2 apache2-mpm-prefork apache2.2-common libapache2-mod-php5 php5-cli php5-imap php5-gd php5-mcrypt php5-mysql php5-ldap php5-pgsql libapache2-mod-auth-mysql libapache2-mod-auth-pgsql php-net-ldap2 postfix postfix-pcre postfix-cluebringer postfix-cluebringer-webui postfix-cluebringer-mysql dovecot-imapd dovecot-pop3d dovecot-managesieved dovecot-sieve dovecot-ldap dovecot-mysql amavisd-new libcrypt-openssl-rsa-perl libmail-dkim-perl clamav-freshclam clamav-daemon spamassassin altermime arj zoo nomarch cpio lzop cabextract p7zip rpm unrar-free ripole libmail-spf-perl phpmyadmin phpldapadmin python-ldap python-mysqldb libapache2-mod-wsgi python-jinja2 python-netifaces python-webpy awstats fail2ban bzip2 acl patch cron tofrodos logwatch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
bzip2 is already the newest version.
cpio is already the newest version.
patch is already the newest version.
cron is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ldap-utils : Depends: libldap-2.4-2 (= 2.4.28-1.1ubuntu4.1) but 2.4.28-1.1ubuntu4.2 is to be installed
 slapd : Depends: libldap-2.4-2 (= 2.4.28-1.1ubuntu4.1) but 2.4.28-1.1ubuntu4.2 is to be installed
E: Unable to correct problems, you have held broken packages.
< ERROR > Installation failed, please check the terminal output.

OS is clear.
Did: "apt-get update && apt-get upgrade"
Depends: libldap-2.4-2 (= 2.4.28-1.1ubuntu4.1) but I have 2.4.28-1.1ubuntu4.2.
What is this mean? sad

Stop for upgrade libldap-2.4-2 and iRedMail install OK. But it's not is good!

2

Re: ERROR install iRedMail 0.8.3

Please upgrade libldap to the latest version first.

3

Re: ERROR install iRedMail 0.8.3

Hm... I reinstalled a system, update pakeges and all OK.
strangely but it worked.