1 (edited by snarfies 2012-10-11 02:02:30)

Topic: Markasjunk2 configuration issues in Debian

==== Required information ====
- iRedMail version: 0.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Debian Squeeze
- Related log if you're reporting an issue:
====

Trying to follow http://www.iredmail.org/wiki/index.php? … yes.In.SQL , but I'm running into a problem at this step:

# /etc/init.d/amavisd stop
# amavisd -c /etc/amavisd/amavisd.conf debug 2>&1 | grep -i 'bayes'

There is no amavisd.conf in Debian, there is a conf.d folder with a dozen different .conf files in it.  So far I've had no luck getting any output whatsoever from the command above.  Advice?

2

Re: Markasjunk2 configuration issues in Debian

Does below command work for you?

# amavisd debug 2>&1 | grep -i 'bayes'

3

Re: Markasjunk2 configuration issues in Debian

ZhangHuangbin wrote:

Does below command work for you?

# amavisd debug 2>&1 | grep -i 'bayes'

No.  It does nothing at all.

4

Re: Markasjunk2 configuration issues in Debian

Sorry, what do you mean "it does nothing"? Any output message?

5

Re: Markasjunk2 configuration issues in Debian

ZhangHuangbin wrote:

Sorry, what do you mean "it does nothing"? Any output message?

I mean, there is no output message.  Here's a copypasta from my terminal:

root@server:/home/erik# amavisd debug 2>&1 | grep -i 'bayes'
root@server:/home/erik#

6

Re: Markasjunk2 configuration issues in Debian

No output means Bayes is not enabled.
Did you modify /etc/mail/spamassassin/local.cf to add Bayes related settings by following the tutorial?

7

Re: Markasjunk2 configuration issues in Debian

Cut and paste from my local.cf:

use_bayes          1
bayes_auto_learn   1
bayes_auto_expire  1

Actually, I didn't set it that way - iredmail 0.8.1 installed it that way by default.

I had disabled the other parts though, since it wasn't working for me, so I restored the following lines:

bayes_store_module Mail::SpamAssassin::BayesStore::MySQL
bayes_sql_dsn      DBI:mysql:database:127.0.0.1:3306
bayes_sql_username *****
bayes_sql_password *****
bayes_sql_override_username vmail

Now, when I run amavisd debug 2>&1 | grep -i 'bayes' I get a ">" prompt, but nothing else.

8

Re: Markasjunk2 configuration issues in Debian

snarfies wrote:

Now, when I run amavisd debug 2>&1 | grep -i 'bayes' I get a ">" prompt, but nothing else.

Looks like missing pared quotes.
Try this:

# amavisd debug 2>&1 | grep -i bayes

9

Re: Markasjunk2 configuration issues in Debian

ZhangHuangbin wrote:
snarfies wrote:

Now, when I run amavisd debug 2>&1 | grep -i 'bayes' I get a ">" prompt, but nothing else.

Looks like missing pared quotes.
Try this:

# amavisd debug 2>&1 | grep -i bayes

Still no luck, and now I can't even replicate the ">" prompt.

Stopping amavisd: amavisd-new.
root@server:/etc/amavis/conf.d# amavisd debug 2>&1 | grep -i 'bayes'
root@server:/etc/amavis/conf.d# amavisd debug 2>&1 | grep -i bayes
root@server:/etc/amavis/conf.d#

10

Re: Markasjunk2 configuration issues in Debian

No idea yet. Did you find any error message in output log of "amavisd debug"?