1

Topic: Cannot Install iRedMail on CentOS (Rackspace)

==== Required information ====
- iRedMail version: 0.7.4
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version: CentOS / Rackspace
- Related log if you're reporting an issue:
====

Hello,

We are trying to install iRedMail on our CentOS Server following this manual:
http://www.rackspace.com/knowledge_cent … stallation

However everything was fine until the last configure step where we get the blue installation script where we did all the answers (correct ones) and after that it was asking us if we want to configure. That's where we get the following errors:
----------------
root@www [/tmp/iRedMail-0.7.4]# sudo bash iRedMail.sh
< INFO > Check configuration file: /tmp/iRedMail-0.7.4/config... [FOUND]
< Question > Use it for mail server setting? [y|N]y
< INFO > Use config file: /tmp/iRedMail-0.7.4/config for mail server setting.
< INFO > Import installation process status from file: /tmp/iRedMail-0.7.4/.iRedMail.installation.status.
< INFO > Installing package(s): httpd.x86_64 mod_ssl.x86_64 php.x86_64 php-common.x86_64 php-gd.x86_64 php-xml.x86_64 php-mysql.x86_64 php-ldap.x86_64 php-imap.x86_64 libmcrypt.x86_64 php-mcrypt.x86_64 php-mhash.x86_64 php-mbstring.x86_64 postfix.x86_64 awstats.noarch mysql-server.x86_64 mysql.x86_64 mod_auth_mysql.x86_64 policyd.x86_64 dovecot.x86_64 dovecot-sieve.x86_64 dovecot-managesieve.x86_64 clamd.x86_64 clamav.x86_64 clamav-db.x86_64 spamassassin.x86_64 altermime.x86_64 perl-LDAP.noarch amavisd-new.x86_64 perl-IO-Compress.noarch perl-Mail-SPF.noarch perl-Mail-SPF-Query.noarch python-ldap.x86_64 python-jinja2.x86_64 python-webpy.noarch MySQL-python.x86_64 mod_wsgi.x86_64 python-ldap.x86_64 fail2ban bzip2.x86_64 acl.x86_64 patch.x86_64 tmpwatch.x86_64 crontabs.noarch dos2unix.x86_64 vixie-cron.x86_64
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* atomic: www5.atomicorp.com
* base: dallas.tx.mirror.xygenhosting.com
* centosplus: centos-mirror.jchost.net
* epel: fedora-epel.mirror.lstn.net
* extras: dallas.tx.mirror.xygenhosting.com
* updates: mirrors.loosefoot.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package httpd.x86_64 available.
No package php.x86_64 available.
No package php-common.x86_64 available.
No package php-gd.x86_64 available.
No package php-xml.x86_64 available.
No package php-mysql.x86_64 available.
No package php-ldap.x86_64 available.
No package php-imap.x86_64 available.
Package libmcrypt-2.5.8-4.el5.centos.x86_64 already installed and latest version
No package php-mcrypt.x86_64 available.
No package php-mhash.x86_64 available.
No package php-mbstring.x86_64 available.
No package mysql-server.x86_64 available.
  * Maybe you meant: MySQL-server
No package mysql.x86_64 available.
No package dovecot-sieve.x86_64 available.
No package dovecot-managesieve.x86_64 available.
No package spamassassin.x86_64 available.
No package perl-LDAP.noarch available.
No package perl-IO-Compress.noarch available.
No package perl-Mail-SPF.noarch available.
No package perl-Mail-SPF-Query.noarch available.
Package bzip2-1.0.3-6.el5_5.x86_64 already installed and latest version
Package acl-2.2.39-8.el5.x86_64 already installed and latest version
Package patch-2.5.4-31.el5.x86_64 already installed and latest version
Package crontabs-1.10-8.noarch already installed and latest version
Package 4:vixie-cron-4.1-81.el5.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package MySQL-python.x86_64 0:1.2.3-0.1.c1.el5 set to be updated
---> Package altermime.x86_64 0:0.3.10-1.ired set to be updated
---> Package amavisd-new.x86_64 0:2.6.4-3.ired set to be updated
--> Processing Dependency: arc >= 5.21e for package: amavisd-new
--> Processing Dependency: perl-HTML-Parser >= 3.24 for package: amavisd-new
--> Processing Dependency: perl(Archive::Zip) >= 1.14 for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.87 for package: amavisd-new
--> Processing Dependency: perl(Mail::DKIM) >= 0.31 for package: amavisd-new
--> Processing Dependency: perl(MIME::Tools) >= 5.420 for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.93 for package: amavisd-new
--> Processing Dependency: zoo >= 2.10 for package: amavisd-new
--> Processing Dependency: nomarch >= 1.2 for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) >= 1.35 for package: amavisd-new
--> Processing Dependency: unrar >= 2.71 for package: amavisd-new
--> Processing Dependency: perl(Unix::Syslog) for package: amavisd-new
--> Processing Dependency: perl(Digest::HMAC) for package: amavisd-new
--> Processing Dependency: perl(Convert::UUlib) for package: amavisd-new
--> Processing Dependency: ripole for package: amavisd-new
--> Processing Dependency: perl-MailTools for package: amavisd-new
--> Processing Dependency: perl(Archive::Tar) for package: amavisd-new
--> Processing Dependency: perl(Convert::TNEF) for package: amavisd-new
--> Processing Dependency: perl(Mail::SpamAssassin) for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) for package: amavisd-new
--> Processing Dependency: ncompress for package: amavisd-new
--> Processing Dependency: perl(IO::Stringy) for package: amavisd-new
--> Processing Dependency: cabextract for package: amavisd-new
--> Processing Dependency: perl(Digest::SHA1) for package: amavisd-new
--> Processing Dependency: lzop for package: amavisd-new
--> Processing Dependency: perl(BerkeleyDB) for package: amavisd-new
--> Processing Dependency: perl(MIME::Words) for package: amavisd-new
--> Processing Dependency: unarj for package: amavisd-new
--> Processing Dependency: perl(MIME::Parser) for package: amavisd-new
--> Processing Dependency: lha for package: amavisd-new
--> Processing Dependency: freeze for package: amavisd-new
--> Processing Dependency: perl(Net::DNS) for package: amavisd-new
--> Processing Dependency: perl(MIME::Entity) for package: amavisd-new
---> Package awstats.noarch 0:6.95-3.el5 set to be updated
--> Processing Dependency: perl(HTML::Entities) for package: awstats
--> Processing Dependency: perl(LWP::UserAgent) for package: awstats
--> Processing Dependency: perl(URI::Escape) for package: awstats
---> Package clamav.x86_64 0:0.97.6-9.el5.art set to be updated
---> Package clamav-db.x86_64 0:0.97.6-9.el5.art set to be updated
---> Package clamd.x86_64 0:0.97.6-9.el5.art set to be updated
---> Package dos2unix.x86_64 0:3.1-27.2.el5 set to be updated
---> Package fail2ban.noarch 0:0.8.4-29.el5 set to be updated
--> Processing Dependency: shorewall for package: fail2ban
--> Processing Dependency: python-inotify for package: fail2ban
--> Processing Dependency: gamin-python for package: fail2ban
---> Package mod_auth_mysql.x86_64 1:3.0.0-3.2.el5_3 set to be updated
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_auth_mysql
---> Package mod_wsgi.x86_64 0:3.2-2.el5 set to be updated
---> Package policyd.x86_64 0:1.82-4.rhms set to be updated
---> Package postfix.x86_64 5:2.5.9-5.ired set to be updated
--> Processing Dependency: cyrus-sasl >= 2.1.10 for package: postfix
---> Package python-jinja2.x86_64 0:2.2.1-1.el5 set to be updated
--> Processing Dependency: python-babel >= 0.8 for package: python-jinja2
---> Package python-ldap.x86_64 2:2.3.13-2.ired set to be updated
---> Package python-webpy.noarch 0:0.35-1 set to be updated
---> Package tmpwatch.x86_64 0:2.9.7-1.1.el5.5 set to be updated
--> Running transaction check
---> Package amavisd-new.x86_64 0:2.6.4-3.ired set to be updated
--> Processing Dependency: perl-HTML-Parser >= 3.24 for package: amavisd-new
--> Processing Dependency: perl(Archive::Zip) >= 1.14 for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.87 for package: amavisd-new
--> Processing Dependency: perl(Mail::DKIM) >= 0.31 for package: amavisd-new
--> Processing Dependency: perl(MIME::Tools) >= 5.420 for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.93 for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) >= 1.35 for package: amavisd-new
--> Processing Dependency: perl(Unix::Syslog) for package: amavisd-new
--> Processing Dependency: perl(Digest::HMAC) for package: amavisd-new
--> Processing Dependency: perl(Convert::UUlib) for package: amavisd-new
--> Processing Dependency: perl-MailTools for package: amavisd-new
--> Processing Dependency: perl(Archive::Tar) for package: amavisd-new
--> Processing Dependency: perl(Convert::TNEF) for package: amavisd-new
--> Processing Dependency: perl(Mail::SpamAssassin) for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) for package: amavisd-new
--> Processing Dependency: perl(IO::Stringy) for package: amavisd-new
--> Processing Dependency: perl(Digest::SHA1) for package: amavisd-new
--> Processing Dependency: perl(BerkeleyDB) for package: amavisd-new
--> Processing Dependency: perl(MIME::Words) for package: amavisd-new
--> Processing Dependency: perl(MIME::Parser) for package: amavisd-new
--> Processing Dependency: perl(Net::DNS) for package: amavisd-new
--> Processing Dependency: perl(MIME::Entity) for package: amavisd-new
---> Package arc.x86_64 0:5.21o-7.el5 set to be updated
---> Package arj.x86_64 0:3.10.22-6.el5 set to be updated
---> Package awstats.noarch 0:6.95-3.el5 set to be updated
--> Processing Dependency: perl(HTML::Entities) for package: awstats
--> Processing Dependency: perl(LWP::UserAgent) for package: awstats
--> Processing Dependency: perl(URI::Escape) for package: awstats
---> Package cabextract.x86_64 0:1.3-1.el5 set to be updated
--> Processing Dependency: libmspack.so.0()(64bit) for package: cabextract
---> Package cyrus-sasl.x86_64 0:2.1.22-7.el5_8.1 set to be updated
---> Package freeze.x86_64 0:2.5.0-9.el5 set to be updated
---> Package gamin-python.x86_64 0:0.1.7-10.el5 set to be updated
atomic/filelists_db                                                                                             | 1.2 MB     00:00
base/filelists                                                                                                  | 3.5 MB     00:00
centosplus/filelists_db                                                                                         | 1.1 MB     00:00
contrib/filelists_db                                                                                            |  567 B     00:00
epel/filelists_db                                                                                               | 5.5 MB     00:00
extras/filelists_db                                                                                             | 232 kB     00:00
iRedMail/filelists                                                                                              |  47 kB     00:00
iRedMail-Dovecot-12/filelists                                                                                   | 6.2 kB     00:00
updates/filelists_db                                                                                            | 3.4 MB     00:00
---> Package lha.x86_64 0:1.14i-19.2.2.el5.rf set to be updated
---> Package lzop.x86_64 0:1.03-2.el5 set to be updated
--> Processing Dependency: liblzo2.so.2()(64bit) for package: lzop
---> Package mod_auth_mysql.x86_64 1:3.0.0-3.2.el5_3 set to be updated
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_auth_mysql
---> Package ncompress.x86_64 0:4.2.4-47 set to be updated
---> Package nomarch.x86_64 0:1.4-2.el5 set to be updated
---> Package python-babel.noarch 0:0.9.5-3.el5.art set to be updated
---> Package python-inotify.noarch 0:0.9.1-1.el5 set to be updated
--> Processing Dependency: python-ctypes for package: python-inotify
---> Package ripole.x86_64 0:0.2.0-1.2.el5.rf set to be updated
---> Package shorewall.noarch 0:4.0.15-1.el5 set to be updated
--> Processing Dependency: shorewall-perl = 4.0.15-1.el5 for package: shorewall
--> Processing Dependency: shorewall-shell = 4.0.15-1.el5 for package: shorewall
--> Processing Dependency: shorewall-common = 4.0.15-1.el5 for package: shorewall
---> Package unrar.x86_64 0:3.8.2-1.el5.rf set to be updated
---> Package zoo.x86_64 0:2.10-2.2.el5.rf set to be updated
--> Running transaction check
---> Package amavisd-new.x86_64 0:2.6.4-3.ired set to be updated
--> Processing Dependency: perl-HTML-Parser >= 3.24 for package: amavisd-new
--> Processing Dependency: perl(Archive::Zip) >= 1.14 for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.87 for package: amavisd-new
--> Processing Dependency: perl(Mail::DKIM) >= 0.31 for package: amavisd-new
--> Processing Dependency: perl(MIME::Tools) >= 5.420 for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.93 for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) >= 1.35 for package: amavisd-new
--> Processing Dependency: perl(Unix::Syslog) for package: amavisd-new
--> Processing Dependency: perl(Digest::HMAC) for package: amavisd-new
--> Processing Dependency: perl(Convert::UUlib) for package: amavisd-new
--> Processing Dependency: perl-MailTools for package: amavisd-new
--> Processing Dependency: perl(Archive::Tar) for package: amavisd-new
--> Processing Dependency: perl(Convert::TNEF) for package: amavisd-new
--> Processing Dependency: perl(Mail::SpamAssassin) for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) for package: amavisd-new
--> Processing Dependency: perl(IO::Stringy) for package: amavisd-new
--> Processing Dependency: perl(Digest::SHA1) for package: amavisd-new
--> Processing Dependency: perl(BerkeleyDB) for package: amavisd-new
--> Processing Dependency: perl(MIME::Words) for package: amavisd-new
--> Processing Dependency: perl(MIME::Parser) for package: amavisd-new
--> Processing Dependency: perl(Net::DNS) for package: amavisd-new
--> Processing Dependency: perl(MIME::Entity) for package: amavisd-new
---> Package awstats.noarch 0:6.95-3.el5 set to be updated
--> Processing Dependency: perl(HTML::Entities) for package: awstats
--> Processing Dependency: perl(LWP::UserAgent) for package: awstats
--> Processing Dependency: perl(URI::Escape) for package: awstats
---> Package libmspack.x86_64 0:0.2-0.1.20100723alpha.el5 set to be updated
---> Package lzo.x86_64 0:2.02-2.el5.1 set to be updated
---> Package mod_auth_mysql.x86_64 1:3.0.0-3.2.el5_3 set to be updated
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_auth_mysql
---> Package python-ctypes.x86_64 0:1.0.2-3.el5 set to be updated
---> Package shorewall-common.noarch 0:4.0.15-1.el5 set to be updated
---> Package shorewall-perl.noarch 0:4.0.15-1.el5 set to be updated
---> Package shorewall-shell.noarch 0:4.0.15-1.el5 set to be updated
--> Finished Dependency Resolution
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Net::Server) >= 0.87 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Mail::SpamAssassin) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
awstats-6.95-3.el5.noarch from epel has depsolving problems
  --> Missing Dependency: perl(URI::Escape) is needed by package awstats-6.95-3.el5.noarch (epel)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Digest::HMAC) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Compress::Zlib) >= 1.35 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Archive::Zip) >= 1.14 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Mail::DKIM) >= 0.31 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
awstats-6.95-3.el5.noarch from epel has depsolving problems
  --> Missing Dependency: perl(HTML::Entities) is needed by package awstats-6.95-3.el5.noarch (epel)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Convert::UUlib) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Convert::TNEF) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Compress::Zlib) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(MIME::Parser) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Net::DNS) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
awstats-6.95-3.el5.noarch from epel has depsolving problems
  --> Missing Dependency: perl(LWP::UserAgent) is needed by package awstats-6.95-3.el5.noarch (epel)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl-MailTools is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Unix::Syslog) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(IO::Stringy) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Archive::Tar) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl-HTML-Parser >= 3.24 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(MIME::Entity) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(MIME::Words) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(MIME::Tools) >= 5.420 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Net::Server) >= 0.93 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
1:mod_auth_mysql-3.0.0-3.2.el5_3.x86_64 from base has depsolving problems
  --> Missing Dependency: httpd-mmn = 20051115 is needed by package 1:mod_auth_mysql-3.0.0-3.2.el5_3.x86_64 (base)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(BerkeleyDB) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
amavisd-new-2.6.4-3.ired.x86_64 from iRedMail has depsolving problems
  --> Missing Dependency: perl(Digest::SHA1) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Digest::SHA1) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package 1:mod_auth_mysql-3.0.0-3.2.el5_3.x86_64 (base)
Error: Missing Dependency: perl(Net::Server) >= 0.87 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl-MailTools is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Mail::SpamAssassin) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Archive::Zip) >= 1.14 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(IO::Stringy) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Net::Server) >= 0.93 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(MIME::Words) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(MIME::Parser) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(HTML::Entities) is needed by package awstats-6.95-3.el5.noarch (epel)
Error: Missing Dependency: perl(Unix::Syslog) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Compress::Zlib) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Compress::Zlib) >= 1.35 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl-HTML-Parser >= 3.24 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Net::DNS) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(MIME::Tools) >= 5.420 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Convert::TNEF) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Mail::DKIM) >= 0.31 is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Convert::UUlib) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(Digest::HMAC) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(MIME::Entity) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(LWP::UserAgent) is needed by package awstats-6.95-3.el5.noarch (epel)
Error: Missing Dependency: perl(Archive::Tar) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
Error: Missing Dependency: perl(URI::Escape) is needed by package awstats-6.95-3.el5.noarch (epel)
Error: Missing Dependency: perl(BerkeleyDB) is needed by package amavisd-new-2.6.4-3.ired.x86_64 (iRedMail)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
< ERROR > Installation failed, please check the terminal output.
< ERROR > If you're not sure what the problem is, try to get help in iRedMail
< ERROR > forum: http://www.iredmail.org/forum/
root@www [/tmp/iRedMail-0.7.4]#
----------------

Can you please tell us what the problem is and why we cannot install this mail server.

Thanks in advance,
Martin

2

Re: Cannot Install iRedMail on CentOS (Rackspace)

1. Disable all nonstandard repository (atomic, etc ...)
2. Replace nonstandard packages with standard packages from official centos repository.
3. Install iRedMail in a newest version.

Pavel

3

Re: Cannot Install iRedMail on CentOS (Rackspace)

As mentioned in iRedMail installation guide (http://www.iredmail.org/install_iredmai … able_repos):

For CentOS or Scientific Linux, please enable CentOS/Scientific official yum repositories, and DISABLE all third-party yum repositories to avoid package conflict.