1

Topic: fresh install, cannot send email but can receive

==== Required information ====
- iRedMail version: 0.8.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Centos 6.3
- Related log if you're reporting an issue:
====

I know this seems vague, but after my fresh install i cant SEND email from outside the domain. I can receive email from all sources. I am almost sure my DNS settings are correct, and I set up my MX records and SPF record correctly. I can post logs if needed. Does anyone have some pro-tips?? I am not a linux expert by any means, but i know my way around.

thanks in advance!

-Nate

2

Re: fresh install, cannot send email but can receive

Sorry, what do you mean "cant SEND email from outside the domain"? Any related log?

3

Re: fresh install, cannot send email but can receive

ZhangHuangbin wrote:

Sorry, what do you mean "cant SEND email from outside the domain"? Any related log?

Hi ZhangHuangbin,

Thank you for replying!
I can send from within my iRedMail domain, here is my delima..

I can send/receive @mydomain to @mydomain.
I can receive from @gmail, @yahoo, @etc...
I can't send to @gmail, @yahoo.

I can post a log, but i do not know which you would need.

4

Re: fresh install, cannot send email but can receive

Check related log in /var/log/maillog, /var/log/dovecot.log.

5

Re: fresh install, cannot send email but can receive

ZhangHuangbin wrote:

Check related log in /var/log/maillog, /var/log/dovecot.log.

maillog:
Oct  7 04:17:10 mail postfix/qmgr[2348]: EF499200C3B: from=<nate@digitalnuage.com>, size=1026, nrcpt=1 (queue active)
Oct  7 04:17:41 mail postfix/smtp[22963]: connect to gmail-smtp-in.l.google.com[173.194.77.27]:25: Connection timed out
Oct  7 04:18:11 mail postfix/smtp[22963]: connect to alt1.gmail-smtp-in.l.google.com[74.125.134.27]:25: Connection timed out
Oct  7 04:18:41 mail postfix/smtp[22963]: connect to alt2.gmail-smtp-in.l.google.com[173.194.68.26]:25: Connection timed out
Oct  7 04:19:11 mail postfix/smtp[22963]: connect to alt3.gmail-smtp-in.l.google.com[173.194.73.26]:25: Connection timed out
Oct  7 04:19:41 mail postfix/smtp[22963]: connect to alt4.gmail-smtp-in.l.google.com[173.194.78.26]:25: Connection timed out
Oct  7 04:19:41 mail postfix/smtp[22963]: EF499200C3B: to=<nate.baker1988@gmail.com>, relay=none, delay=40594, delays=40444/0.07/150/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[173.194.78.26]:25: Connection timed out)
Oct  7 04:43:13 mail amavis[23479]: starting.  /usr/sbin/amavisd at mail.digitalnuage.com amavisd-new-2.6.6 (20110518), Unicode aware, LANG="en_US.UTF-8"

dovecot:
Oct 07 03:20:06 imap-login: Info: Login: user=<nate@digitalnuage.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=21835, secured
Oct 07 03:20:06 imap(nate@digitalnuage.com): Info: Disconnected: Logged out bytes=312/1681
Oct 07 03:21:06 imap-login: Info: Login: user=<nate@digitalnuage.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=21853, secured
Oct 07 03:21:06 imap(nate@digitalnuage.com): Info: Disconnected: Logged out bytes=312/1681
Oct 07 03:22:06 imap-login: Info: Login: user=<nate@digitalnuage.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=21871, secured
Oct 07 03:22:06 imap(nate@digitalnuage.com): Info: Disconnected: Logged out bytes=312/1681

6

Re: fresh install, cannot send email but can receive

Oct  7 04:17:41 mail postfix/smtp[22963]: connect to gmail-smtp-in.l.google.com[173.194.77.27]:25: Connection timed out

Looks like network connection issue, your mail server cannot connect to gmail servers.

7 (edited by squeezyboxx 2012-10-09 02:02:46)

Re: fresh install, cannot send email but can receive

ZhangHuangbin wrote:

Oct  7 04:17:41 mail postfix/smtp[22963]: connect to gmail-smtp-in.l.google.com[173.194.77.27]:25: Connection timed out

Looks like network connection issue, your mail server cannot connect to gmail servers.

could this possibly be a MX record issue, DNS, or misconfigured port settings?

thank you for all your help ZhangHuangbin!

edit:

now that i think about it, my public IP has never changed, but i do not know if it is actually deemed "Static" by the ISP. Could that have an impact?

8

Re: fresh install, cannot send email but can receive

i think i have finally found the problem.... my ISP (AT&T Uverse) is blocking outgoing port 25. Which is why my email is timing out against outside domains.

9

Re: fresh install, cannot send email but can receive

squeezyboxx wrote:

i think i have finally found the problem.... my ISP (AT&T Uverse) is blocking outgoing port 25. Which is why my email is timing out against outside domains.

I contacted my ISP, and was able to unblock port 25. Email is now working properly, sending/receiving.