1

Topic: how to conf for shared_folder ?

hello
i use iredmail0.8.1 ubuntu12.0.4lts mysql backend
i want to use shared_folder between my 2 accounts.

mysql> select * from share_folder ;
+-----------------+----------------+-------+
| from_user       | to_user        | dummy |
+-----------------+----------------+-------+
| first@test.org | second@test.org | Y     |
+-----------------+----------------+-------+

i added "acl = vfile" in dovecot.conf.


Which values do i have to configure anything else ?

2

Re: how to conf for shared_folder ?

Reference: http://www.iredmail.org/wiki/index.php? … MAP.Folder

3

Re: how to conf for shared_folder ?

i read the link.
protocol lda {
    mail_plugins = ... acl
}

protocol imap {
    mail_plugins = ... acl imap_acl
}
those settings were set . I had added them in dovecot.conf.

Also i had added;
# mysql -uroot -p
mysql> USE vmail;
mysql> SELECT * FROM share_folder;
+-----------------+--------------------+-------+
| from_user       | to_user            | dummy |
+-----------------+--------------------+-------+
| from@domain.ltd | testing@domain.ltd | 1     |
+-----------------+--------------------+-------+

but when i add a shared file called vfile into my main account via imap, i can't see second account it.
what can the problem?

4

Re: how to conf for shared_folder ?

bulend wrote:

but when i add a shared file called vfile into my main account via imap, i can't see second account it.

"Share folder" is used to share IMAP folders, not share files directly.
Please read section "Test share folder" here:
http://www.iredmail.org/wiki/index.php? … red_folder

5

Re: how to conf for shared_folder ?

i followed the link i get an error via the telnet section;

# telnet 127.0.0.1 143
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE STARTTLS AUTH=PLAIN AUTH=LOGIN] Dovecot ready.
login from@test.org 111
login BAD First parameter in line is IMAP's command tag, not the command name. Add that before the command, like: a login user pass

6

Re: how to conf for shared_folder ?

bulend wrote:

login from@test.org 111

You forgot the dot before imap command. It should be ". login from@test.org 111".

7

Re: how to conf for shared_folder ?

Thank you.