1

Topic: Problem installing on debian lenny

Hello,

I've a problem installing on debian lenny,
The problem is cause by postfix-policyd package, here is the console message.

Setting up postfix-policyd (1.82-2) ...
dbconfig-common: writing config to /etc/dbconfig-common/postfix-policyd.conf
*** WARNING: ucf was run from a maintainer script that uses debconf, but
             the script did not pass --debconf-ok to ucf. The maintainer
             script should be fixed to not stop debconf before calling ucf,
             and pass it this parameter. For now, ucf will revert to using
             old-style, non-debconf prompting. Ugh!

             Please inform the package maintainer about this problem.

Thanks

2

Re: Problem installing on debian lenny

It's SAFE to ignore this WARNING message, and policyd works as excepted. smile

3

Re: Problem installing on debian lenny

Ok, but the installer do not complete the installation

Just after the message given in post #1 I've the following

Starting Postfix greylisting policy daemon: invoke-rc.d: initscript postfix-policyd, action "start" failed.
dpkg: error processing postfix-policyd (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
postfix-policyd
E: Sub-process /usr/bin/dpkg returned an error code (1)
< ERROR > Installation failed, please check the terminal output.

Thanks

4

Re: Problem installing on debian lenny

It really works for me here, even with the same output message.
I don't know why it doesn't work for you.

5

Re: Problem installing on debian lenny

whether you run

#cd iRedMail-0.5.0-rc1/pkgs/
#bash get_all.sh 

download the software.