1 (edited by okoetter 2012-05-14 17:23:44)

Topic: Override default settings of spamassassin

==== Provide required information to help troubleshoot and get quick answer ====
- iRedMail version: 0.7.4
- Linux/BSD distribution name and version: Debian Squeeze
- Any related log? Log is helpful for troubleshooting.
====

Hi,

how do I override a default setting of spamassassin? I want to set the default score of SPF_FAIL to 0.
Putting "SPF_FAIL 0" into /etc/spamassassin/local.cf does not help.

Regards,
Oliver

2

Re: Override default settings of spamassassin

You will find SPF score defined by iRedMail in /etc/mail/spamassassin/local.cf. For example:

score SPF_PASS -10.000
score SPF_FAIL 5.00

3

Re: Override default settings of spamassassin

ZhangHuangbin wrote:

You will find SPF score defined by iRedMail in /etc/mail/spamassassin/local.cf. For example:

score SPF_PASS -10.000
score SPF_FAIL 5.00

Thanks for your answer. /etc/mail/spamassassin is a symbolic link to /etc/spamassassin:

root@www:~# ls -l /etc/mail/spamassassin
lrwxrwxrwx 1 root root 15 17. Apr 09:17 /etc/mail/spamassassin -> ../spamassassin

So I accidentally edited the right file.
I put these into local.cf:

score SPF_PASS 0
score SPF_FAIL 0

Nevertheless I get mails whose headers show this:

X-Spam-Status: No, score=-2.822 required=5 tests=[BAYES_00=-1.9,
    DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1,
    FUZZY_CREDIT=1.678, RCVD_IN_DNSWL_NONE=-0.0001, SPF_FAIL=5,
    USER_IN_DEF_DKIM_WL=-7.5] autolearn=no

(Please see the  SPF_FAIL=5)

Any idea what I am doing wrong?
Do I have to restart amavis after editing local.cf? I just restarted it, let's see...

Regards,
Oliver

4

Re: Override default settings of spamassassin

It seems that restarting amavisd helped, I see the new values now. Thanks.