1

Topic: SMTP recv. error from internet. Sender address rejected: not logged in

==== Provide required information to help troubleshoot and get quick answer ====
- iRedMail version: iRedMail-Pro-MySQL 1.3.1
- Linux/BSD distribution name and version: Debian Squeeze
- Any related log? Log is helpful for troubleshooting.
====

Hello!
I have following scenario:

A customer has all its mailboxes hosted on our mailserver.
A client has to use the SMTP server in the company where he works, no direct SMTP connection to our mailserver is possible.
Now if the customer tries to send an email message from mb1@example.com to mb2@example.com or and other destination address which is hosted on the server, following error message is generated:

mail postfix/smtpd[5422]: NOQUEUE: reject: RCPT from mail.reallybigcompany.com[1.2.3.4]: 553 5.7.1 <mb1@example.com>: Sender address rejected: not logged in; from=<mb1@example.com> to=<mb2@example.com> proto=ESMTP helo=<ns.reallybigcompany.com>

I added the host mail.reallybigcompany.com to the whitelist - no success.
Is there a way to enable the client to send messages to our server passing by mail.reallybigcompany.com ?
I would like to avoid disabling this check globally.

Best regards,

Bernhard

2

Re: SMTP recv. error from internet. Sender address rejected: not logged in

broth wrote:

Sender address rejected: not logged in

Why not ask your client to enable SMTP auth for sending out email? They it works everywhere.

3

Re: SMTP recv. error from internet. Sender address rejected: not logged in

ZhangHuangbin wrote:
broth wrote:

Sender address rejected: not logged in

Why not ask your client to enable SMTP auth for sending out email? They it works everywhere.

Hello Zhang and thak you for your reply.

The sender is not using the mailserver directly but sending the mails via a smarthost:

Client -> Company SMTP-Server -> Internet -> iRedMail Server

If SMTP Auth is enabled, only the first server will check the authentication, then sending the email vis standard SMTP to the destionation server. This won't help IMHO

4

Re: SMTP recv. error from internet. Sender address rejected: not logged in

Try adding the IP address of "Company SMTP-Server" in your postfix setting: mynetworks.