1

Topic: Migrated from Qmail-Toaster to iRedMail successfully!

==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version:
- iRedMail version and backend (LDAP/MySQL):
- Any related log? Log is helpful for troubleshooting.
====
Hi!

Migrated the 3 domains I take care of from Qmail-Toaster to iRedmail successfully.
Took me a day or so.
All in all things went very smoothly.

I mainly had to add the external outbound SMTP provider to "$mynetworks" in /etc/postfix/main.cf to allow users from the same domain to send emails to each others (as all use that provider). Found the info by search on the forum. Easy one.

I also turned off GREYLISTING as it was blocking most of the emails we get. Maybe, if I can find some time fine tuning it, I will turn it back on as it really brings down spam a lot.

Some config to amavis also to add my virtual email domains (I wish iRedAdmin would have done that for me, maybe it is a feature of the standard version, I use the free one at the moment).

The toughest moment was to migrate the mailbox content from the old system to the new system.
Since the old system crashed in flame (actually the RAID system hosting the Virtual Machine, so disks were unrecoverable),
I had to use backups from email clients (Thunderbird, Apple Mail, Outlook).
A little painful, but I doubt there was an easy way anyway.

Now if I could find a way to use the local smtp to send emails, that would be neat. I use an external SMTP provider because my own IP address is not static, so most SMTP in the world reject my server.

Keep up the good work!

2

Re: Migrated from Qmail-Toaster to iRedMail successfully!

Thanks for your sharing. smile

bzh_nihon wrote:

Some config to amavis also to add my virtual email domains

May i know what config?

bzh_nihon wrote:

Now if I could find a way to use the local smtp to send emails, that would be neat. I use an external SMTP provider because my own IP address is not static, so most SMTP in the world reject my server.

I guess what you need is Postfix setting 'relayhost =' in main.cf.
Reference: http://www.postfix.org/postconf.5.html#relayhost