1

Topic: All mail from the internet is being rejected

==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version:
- iRedMail version and backend (LDAP/MySQL):
- Any related log? Log is helpful for troubleshooting.
====

Hello, I installed iRedmail on a new freshly installed OpenSuse 12.1 server and I am able to send email via an outbound relay, but all email from the internet is being. Below is a copy of the message that I am seeing in my mail log. Wondering if could get some assistance or guidance with this issue? I am using the default settings in my postfix main.cf for smtpd_recipient_restrictions =

mail postfix/smtpd[7079]: NOQUEUE: reject: RCPT from nm17-vm0.bullet.mail.ne1.yahoo.com[98.138.91.58]: 554 5.7.1 <nm17-vm0.bullet.mail.ne1.yahoo.com[98.138.91.58]>: Client host rejected: Access denied; from=<ronmitch4@yahoo.com> to=<ron.mitchell@articulate2day.com> proto=SMTP helo=<nm17-vm0.bullet.mail.ne1.yahoo.com>

2

Re: All mail from the internet is being rejected

- Can you send email from Gmail/Hotmail and other ISP to your mail server? What's the error message in Postfix log file?
- Did you change other Postfix settings? Please show us the output of command 'postconf -n' here to help troubleshoot.

3

Re: All mail from the internet is being rejected

Thank you for your response, and yes I am able to send emails from this mail server too the internet, and too specifically to my gmail, and yahoo mail accounts. But because this server is sitting behind a dynamic dns address and the IP address space is with in my providers PBL list, I am doing this via an external relay service.  Here is the output of my mail log for email coming from the internet regardless if it is coming from my, yahoo, gmail, work, or personal Comcast account, I always get a Client host rejected:Access denied!

NOQUEUE: reject: RCPT from nm18.bullet.mail.ac4.yahoo.com[98.139.52.215]: 554 5.7.1 <nm18.bullet.mail.ac4.yahoo.com[98.139.52.215]>: Client host rejected: Access denied; from=<username@yahoo.com> to=<internal.mailuser@example.com> proto=SMTP helo=<nm18.bullet.mail.ac4.yahoo.com>

Output of my postconf -n

postconf -n
alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
allow_min_user = no
biff = no
bounce_queue_lifetime = 1d
broken_sasl_auth_clients = yes
canonical_maps =
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/lib/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
defer_transports =
delay_warning_time = 0h
disable_dns_lookups = no
disable_mime_output_conversion = no
disable_vrfy_command = yes
enable_original_recipient = no
home_mailbox = Maildir/
html_directory = /usr/share/doc/packages/postfix-doc/html
inet_interfaces = all
inet_protocols = ipv4
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command = /usr/lib/dovecot/deliver
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
maximal_backoff_time = 4000s
maximal_queue_lifetime = 1d
message_size_limit = 15728640
message_strip_characters = \0
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
mydomain = example.com
myhostname = mail.example.com
mynetworks = 127.0.0.0/8
mynetworks_style = subnet
myorigin = mail.example.com
newaliases_path = /usr/bin/newaliases
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $mydestination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domains $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_domains $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps $smtpd_sender_restrictions
queue_directory = /var/spool/postfix
queue_run_delay = 300s
readme_directory = /usr/share/doc/packages/postfix-doc/README_FILES
recipient_bcc_maps = proxy:ldap:/etc/postfix/ldap/recipient_bcc_maps_domain.cf, proxy:ldap:/etc/postfix/ldap/recipient_bcc_maps_user.cf
recipient_delimiter = +
relay_clientcerts =
relay_domains = $mydestination, proxy:ldap:/etc/postfix/ldap/relay_domains.cf
relayhost = [outbound.mailhop.org]:2525
relocated_maps =
sample_directory = /usr/share/doc/packages/postfix-doc/samples
sender_bcc_maps = proxy:ldap:/etc/postfix/ldap/sender_bcc_maps_domain.cf, proxy:ldap:/etc/postfix/ldap/sender_bcc_maps_user.cf
sender_canonical_maps =
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_data_init_timeout = 240s
smtp_data_xfer_timeout = 600s
smtp_enforce_tls = no
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_CAfile =
smtp_tls_CApath =
smtp_tls_cert_file =
smtp_tls_key_file =
smtp_tls_session_cache_database =
smtp_use_tls = no
smtpd_client_restrictions =
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_enforce_tls = no
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,permit_sasl_authenticated, check_helo_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:127.0.0.1:7777, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_policy_service inet:127.0.0.1:10031
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain =
smtpd_sasl_path = ./dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:ldap:/etc/postfix/ldap/sender_login_maps.cf
smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated
smtpd_tls_CAfile = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_CApath =
smtpd_tls_ask_ccert = no
smtpd_tls_cert_file = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_key_file = /etc/ssl/private/iRedMail.key
smtpd_tls_loglevel = 0
smtpd_tls_received_header = no
smtpd_tls_security_level = may
smtpd_use_tls = no
strict_8bitmime = no
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = proxy:ldap:/etc/postfix/ldap/transport_maps_user.cf, proxy:ldap:/etc/postfix/ldap/transport_maps_domain.cf
unknown_local_recipient_reject_code = 550
virtual_alias_domains =
virtual_alias_maps = proxy:ldap:/etc/postfix/ldap/virtual_alias_maps.cf, proxy:ldap:/etc/postfix/ldap/virtual_group_maps.cf, proxy:ldap:/etc/postfix/ldap/sender_login_maps.cf, proxy:ldap:/etc/postfix/ldap/catchall_maps.cf
virtual_gid_maps = static:1000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:ldap:/etc/postfix/ldap/virtual_mailbox_domains.cf
virtual_mailbox_maps = proxy:ldap:/etc/postfix/ldap/virtual_mailbox_maps.cf
virtual_minimum_uid = 1001
virtual_transport = dovecot
virtual_uid_maps = static:1001

4

Re: All mail from the internet is being rejected

I can see where a lot of users has had this issue, but besides editing the smtpd_recipient_restrictions field, which I did an attempt to fix my problem; I still don't know how others are resolving this problem! Can anyone share any insight there experience with this issue and what was done to resolve it?

5

Re: All mail from the internet is being rejected

Is Dovecot service running? if not, please start it and try again.

6

Re: All mail from the internet is being rejected

As far s I know it is but, I will restart it.

7

Re: All mail from the internet is being rejected

I restarted doevcot and postfix and I can still send email outside of my domain just fine, but I still cant receive email outside of my domain, and for all email from the internet my mail log is still giving me the same error message!

Mar  6 06:14:25 mail postfix/smtpd[5950]: NOQUEUE: reject: RCPT from nm23-vm0.bullet.mail.bf1.yahoo.com[98.139.212.191]: 554 5.7.1 <nm23-vm0.bullet.mail.bf1.yahoo.com[98.139.212.191]>: Client host rejected: Access denied; from=<myemail@yahoo.com> to=<user.name@mydomain2day.com> proto=SMTP helo=<nm23-vm0.bullet.mail.bf1.yahoo.com>
Mar  6 06:14:25 mail postfix/smtpd[5950]: disconnect from nm23-vm0.bullet.mail.bf1.yahoo.com[98.139.212.191]

8

Re: All mail from the internet is being rejected

Still no idea at all, sorry.

- Did you change any settings/config files? Please clearly explain what you changed.
- Is user "user.name@mydomain2day.com" a virtual mail account stored in LDAP or a Unix system account?
- Does this issue happen again if you comment out "relayhost =" in Postfix main.cf?

9

Re: All mail from the internet is being rejected

Zhang,

I did not make any changes this is a new freshly installed OpensSuse 12.1 OS, and with just the default iRedMail configurations except with me having to use a relay host of my dynamic dns provider to send email. I have an MX record for my domain and LDAP was never configured on the server it self. If I comment out " relayhost" in my main.cf then that line will be ignored and I would not be able to send mail, if I am understanding you correctly in terms of commenting out relayhost.

10

Re: All mail from the internet is being rejected

I did as you asked and I put a #comment in front of relayhost =, and I still got the same results. In reviewing my Wireshark capture I can see where the email actually connects, it just appears that nothing happen once the mail hits my server! Very unusual. For gigles I'm going to show you the ouput of my master.cf file.


# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#amavis    unix  -       -       n       -       4       smtp
#  -o smtp_data_done_timeout=1200
#  -o smtp_send_xforward_command=yes
#  -o disable_dns_lookups=yes
#  -o max_use=20
#smtp      inet  n       -       n       -       1       postscreen
#smtpd     pass  -       -       n       -       -       smtpd
#dnsblog   unix  -       -       n       -       0       dnsblog
#tlsproxy  unix  -       -       n       -       0       tlsproxy
#submission inet n       -       n       -       -       smtpd
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o milter_macro_daemon_name=ORIGINATING
#smtps     inet  n       -       n       -       -       smtpd -o smtpd_tls_wrappermode=yes
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o milter_macro_daemon_name=ORIGINATING
#628       inet  n       -       n       -       -       qmqpd
#pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       n       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       n       -       -       smtp
        -o smtp_fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
retry     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
#localhost:10025 inet   n       -       n       -       -       smtpd
#  -o content_filter=
#  -o smtpd_delay_reject=no
#  -o smtpd_client_restrictions=permit_mynetworks,reject
#  -o smtpd_helo_restrictions=
#  -o smtpd_sender_restrictions=
#  -o smtpd_recipient_restrictions=permit_mynetworks,reject
#  -o smtpd_data_restrictions=reject_unauth_pipelining
#  -o smtpd_end_of_data_restrictions=
#  -o smtpd_restriction_classes=
#  -o mynetworks=127.0.0.0/8
#  -o smtpd_error_sleep_time=0
#  -o smtpd_soft_error_limit=1001
#  -o smtpd_hard_error_limit=1000
#  -o smtpd_client_connection_count_limit=0
#  -o smtpd_client_connection_rate_limit=0
#  -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks,no_address_mappings
#  -o local_header_rewrite_clients=
#  -o local_recipient_maps=
#  -o relay_recipient_maps=
scache    unix  -       -       n       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
#maildrop  unix  -       n       n       -       -       pipe
#  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
#
# ====================================================================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
#   lmtp    cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
#
# Specify in main.cf one or more of the following:
#  mailbox_transport = lmtp:inet:localhost
#  virtual_transport = lmtp:inet:localhost
#
# ====================================================================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus     unix  -       n       n       -       -       pipe
#  user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ====================================================================
#
# Old example of delivery via Cyrus.
#
#old-cyrus unix  -       n       n       -       -       pipe
#  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ====================================================================
#
# See the Postfix UUCP_README file for configuration details.
#
#uucp      unix  -       n       n       -       -       pipe
#  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# ====================================================================
#
# Other external delivery methods.
#
#ifmail    unix  -       n       n       -       -       pipe
#  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
#
#bsmtp     unix  -       n       n       -       -       pipe
#  flags=Fq. user=bsmtp argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
#
#scalemail-backend unix -       n       n       -       2       pipe
#  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store
#  ${nexthop} ${user} ${extension}
#
#mailman   unix  -       n       n       -       -       pipe
#  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
#  ${nexthop} ${user}
#
#procmail  unix  -       n       n       -       -       pipe
#  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
#
# Bypass checks for internally generated mail.
pickup    fifo  n       -       n       60      1       pickup
  -o content_filter=
submission inet n       -       n       -       -       smtpd
  -o smtpd_enforce_tls=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_mynetworks,permit_sasl_authenticated,reject
#  -o content_filter=smtp-amavis:[127.0.0.1]:10026

# Use dovecot deliver program as LDA.
dovecot unix    -       n       n       -       -      pipe
    flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${domain}
smtp-amavis unix -  -   -   -   2  smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o disable_dns_lookups=yes
    -o max_use=20

127.0.0.1:10025 inet n  -   -   -   -  smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_delay_reject=no
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks_style=host
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o smtpd_error_sleep_time=0
    -o smtpd_soft_error_limit=1001
    -o smtpd_hard_error_limit=1000
    -o smtpd_client_connection_count_limit=0
    -o smtpd_client_connection_rate_limit=0
    -o receive_override_options=no_header_body_checks,no_unknown_recipient_checks,no_address_mappings

11

Re: All mail from the internet is being rejected

I am still not able to receive email from the internet, I have tried a lot of different things but I am still getting the same error in the mail log when trying to send email to my domain from yahoo, gmail or my comcast email account below is my mail log.

Mar  6 21:03:30 mail postfix/smtpd[14987]: NOQUEUE: reject: RCPT from qmta06.westchester.pa.mail.comcast.net[76.96.62.56]: 554 5.7.1 <qmta06.westchester.pa.mail.comcast.net[76.96.62.56]>: Client host rejected: Access denied; from=<myprovideremial@comcast.net> to=<user.name@mydomain.com> proto=ESMTP helo=<qmta06.westchester.pa.mail.comcast.net>

Mar  6 21:03:47 mail postfix/smtpd[14996]: connect from mail-gx0-f171.google.com[209.85.161.171]
Mar  6 21:03:48 mail postfix/smtpd[14996]: NOQUEUE: reject: RCPT from mail-gx0-f171.google.com[209.85.161.171]: 554 5.7.1 <mail-gx0-f171.google.com[209.85.161.171]>: Client host rejected: Access denied; from=<mygmail@gmail.com> to=<ron.mitchell@articulate2day.com> proto=ESMTP helo=<mail-gx0-f171.google.com>
Mar  6 21:03:48 mail postfix/smtpd[14996]: disconnect from mail-gx0-f171.google.com[209.85.161.171]

12

Re: All mail from the internet is being rejected

Could you please turn on debug mode in Postfix and paste related log to help troubleshoot?

To enable debug mode in Postfix, please append '-v' in transport 'smtp' in file /etc/postfix/master.cf. For example:

smtp      inet  n       -       -       -       -       smtpd -v

Restarting Postfix service, monitor its log file, resend an testing email from Gmail, and paste related Postfix log here.

13

Re: All mail from the internet is being rejected

Well I did as you asked and added the  "-v" at the end of that line but when I ran the debug I did not see any detailed information in my mail log, so I added again but this time without the space between the "smtpd -v" and did "smtpd-v" , but it made on difference in the output. below are the results.

Mar  7 05:26:19 mail postfix/master[20139]: daemon started -- version 2.8.7, configuration /etc/postfix
Mar  7 05:26:48 mail postfix/smtpd[20194]: connect from nm5.bullet.mail.bf1.yahoo.com[98.139.212.164]
Mar  7 05:26:49 mail postfix/smtpd[20194]: NOQUEUE: reject: RCPT from nm5.bullet.mail.bf1.yahoo.com[98.139.212.164]: 554 5.7.1 <nm5.bullet.mail.bf1.yahoo.com[98.139.212.164]>: Client host rejected: Access denied; from=<myyahoomail@yahoo.com> to=<user.name@mydomain2day.com> proto=SMTP helo=<nm5.bullet.mail.bf1.yahoo.com>
Mar  7 05:26:49 mail postfix/smtpd[20194]: disconnect from nm5.bullet.mail.bf1.yahoo.com[98.139.212.164]
Mar  7 05:28:27 mail postfix/postfix-script[20220]: stopping the Postfix mail system
Mar  7 05:28:27 mail postfix/master[20139]: terminating on signal 15

Mar  7 05:28:27 mail postfix/postfix-script[20310]: warning: /var/spool/postfix/etc/hosts and /etc/hosts differ
Mar  7 05:28:27 mail postfix/postfix-script[20315]: starting the Postfix mail system
Mar  7 05:28:27 mail postfix/master[20316]: daemon started -- version 2.8.7, configuration /etc/postfix
Mar  7 05:29:00 mail postfix/smtpd[20393]: connect from nm7-vm0.bullet.mail.bf1.yahoo.com[98.139.213.151]
Mar  7 05:29:00 mail postfix/smtpd[20393]: NOQUEUE: reject: RCPT from nm7-vm0.bullet.mail.bf1.yahoo.com[98.139.213.151]: 554 5.7.1 <nm7-vm0.bullet.mail.bf1.yahoo.com[98.139.213.151]>: Client host rejected: Access denied; from=<myyahoomail@yahoo.com> to=<user.name@mydomain2day.com> proto=SMTP helo=<nm7-vm0.bullet.mail.bf1.yahoo.com>
Mar  7 05:29:01 mail postfix/smtpd[20393]: disconnect from nm7-vm0.bullet.mail.bf1.yahoo.com[98.139.213.151]

14

Re: All mail from the internet is being rejected

The warning message below does not make any sense because when I look at the details of these two files they are identical, but yet at times the message still occurs.

Mar  7 05:28:27 mail postfix/postfix-script[20310]: warning: /var/spool/postfix/etc/hosts and /etc/hosts differ

15

Re: All mail from the internet is being rejected

Please copy /etc/hosts to /var/spool/postfix/etc/hosts.

16

Re: All mail from the internet is being rejected

Zhang,

I actually did that and restarted postfix earlier after I got that message but unfortunately it still did not resolve my issue, and I am still getting the same error for incoming email from my domain. But when I do a postfix check I know longer get that error.

/usr/sbin/postfix check


Mar  7 10:16:36 mail postfix/smtpd[25950]: connect from mail-gy0-f171.google.com[209.85.160.171]
Mar  7 10:16:37 mail postfix/smtpd[25950]: NOQUEUE: reject: RCPT from mail-gy0-f171.google.com[209.85.160.171]: 554 5.7.1 <mail-gy0-f171.google.com[209.85.160.171]>: Client host rejected: Access denied; from=<mygmail@gmail.com> to=<user.name@mydomain2day.com> proto=ESMTP helo=<mail-gy0-f171.google.com>
Mar  7 10:16:37 mail postfix/smtpd[25950]: disconnect from mail-gy0-f171.google.com[209.85.160.171]

17

Re: All mail from the internet is being rejected

Well is it safe to assume that this could be some type of bug? Because according to wireshark and my Cisco router ACL log, I can see that mail is coming into my server on submission port 587, and I can even see the EHLO and response in wireshark and depending on the server connecting I can see the TLS encrypted negotiation. But for some reason the mail from the outside internet is immediately being rejected by the email server! In looking at the process of mail delivery you would think that it would have to be something to do with the Spam Filters or AV, but I have removed that from the equation and I still got the same error message.

Client host rejected: Access denied from the internet@gmail.com, to user.name@mydomain2day.com

18

Re: All mail from the internet is being rejected

You know I hate to ask this question but I have been putting a lot of energy into trying to find a resolution for this issue, and since this is a new server with nothing really nothing on it but this application; you think maybe I should remove iRedMail, and tr try to go through the install process again? The environment that this will be in is for a small home based business behind a dynamic DNS address, with about four email users to start. I'm just running out of ideas of what could be causing this problem!

19

Re: All mail from the internet is being rejected

ronmitch4 wrote:

Because according to wireshark and my Cisco router ACL log, I can see that mail is coming into my server on submission port 587

Incoming emails should goes to port 25, not 587. Did you direct all incoming mails to port 587?

20

Re: All mail from the internet is being rejected

Yes, and in wireshark I can see the connection and commication on that port

21

Re: All mail from the internet is being rejected

Unfortunately, my ISP is blocking port 25 that is why I have it configured for port 587, and I can see the email hit the server on that port.

22

Re: All mail from the internet is being rejected

Zhang,

After reading some other Postfix information, I am wondering if my issue is the way I had to configure my postfix server? My environment is going to be really small in which I don't plan on hosting emil for any more domains, but in the installation process it appeared that the only option I had to was too create virtual domains. Once I completed the install I created the virtual domain for the for the accounts that I plan on using primarily which is the same domain my email server is in, but yet in my postfix main.cf, I don't have nothing configured for virtual_mailbox_domains=; could this be my problem?

I mean the primary domain that the server is in is also my virtual domain and I don't plan on creating any more domains!

23

Re: All mail from the internet is being rejected

ronmitch4 wrote:

Unfortunately, my ISP is blocking port 25 that is why I have it configured for port 587, and I can see the email hit the server on that port.

I'm afraid this block behavior will make your server cannot receive emails, because all communications between mail servers are going through port 25.

24

Re: All mail from the internet is being rejected

Well I am able to send email via a relay host just fine, and like I said I can see the email SMTP protocol via port 587 and the Ehlo per failed email.

25

Re: All mail from the internet is being rejected

I guess this is just one of those questions or issues that's just not going to be answered!