1

Topic: Add new domain - lost ability to login/connect.

==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version:
- iRedMail version and backend (LDAP/MySQL):
- Any related log? Log is helpful for troubleshooting.
====
Centos5.5
iredAdmin - Pro ver 6.0 LDAP

The system has been running well until I tried to add a new domain.  In iredAdmin I added the domain, put it immediately lost the ability to connect and login.

From the logs:
From the message log - many repeated  like:
mail2 postfix/cleanup[2457]: warning: 5C550350004: virtual_alias_maps map lookup problem for postmaster@mail.alliancenetworksolutions.ca

The maillog indicate the ldap has an issue
Jan 20 20:32:17 mail2 postfix/master[1223]: warning: process /usr/libexec/postfix/trivial-rewrite pid 2657 exit status 1
Jan 20 20:32:17 mail2 postfix/master[1223]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling
Jan 20 20:32:26 mail2 postfix/proxymap[2472]: warning: dict_ldap_connect: Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=mail,dc=alliancenetworksolutions,dc=ca: -5 (Timed out)
Jan 20 20:32:36 mail2 postfix/proxymap[2483]: warning: dict_ldap_connect: Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=mail,dc=alliancenetworksolutions,dc=ca: -5 (Timed out)
Jan 20 20:32:36 mail2 postfix/trivial-rewrite[2658]: fatal: proxy:ldap:/etc/postfix/ldap/virtual_mailbox_domains.cf(0,lock|fold_fix): table lookup problem
Jan 20 20:32:37 mail2 postfix/smtpd[2509]: warning: problem talking to service rewrite: Connection reset by peer
Jan 20 20:32:37 mail2 postfix/cleanup[2513]: warning: problem talking to service rewrite: Connection reset by peer
Jan 20 20:32:37 mail2 postfix/master[1223]: warning: process /usr/libexec/postfix/trivial-rewrite pid 2658 exit status 1
Jan 20 20:33:27 mail2 postfix/proxymap[2483]: warning: dict_ldap_connect: Unable to bind to server ldap://127.0.0.1:389 as cn=vmail,dc=mail,dc=alliancenetworksolutions,dc=ca: -5 (Timed out)

Any easy way to restore ldap or other hints on how to move foward?

Thanks

2

Re: Add new domain - lost ability to login/connect.

mheward wrote:

Unable to bind to server ldap://127.0.0.1:389 as ... (Timed out)

There must be something wrong with your OpenLDAP server, was it running?