1

Topic: Sending messages - IMAP Error

IMAP Error: Could not save message in Sent in /usr/share/apache2/roundcubemail-0.5.4/program/steps/mail/sendmail.inc on line 669 (POST /webmail/?_unlock=loading1320772731873?_task=mail&_action=send

Is that a misconfiguration? I'm not instaling the system on the real server. I have a test server here, and not a long ago it was moved to another datacenter. Is it possible to test the system internaly?

iRedMail 0.7.3.

Thanks.
--
Guilherme Rocha

2

Re: Sending messages - IMAP Error

Is there any related log in Postfix and Dovecot log files?

3

Re: Sending messages - IMAP Error

I've changed on the logs the real user and domain to user@domain.

Postfix log:
warning: BB2A0514045: virtual_alias_maps map lookup problem for "user@domain"

complete Dovecot log from the moment of loging to logout:
Nov 08 16:04:15 auth(default): Info: client in: AUTH    1       PLAIN   service=imap    secured lip=::1 rip=::1 lport=143       rport=46435     resp=d3d3QHNlZHVjLTA3OTEuY2lkYWRhb3BnLnNwLmdvdi5icgB3d3dAc2VkdWMtMDc5MS5jaWRhZGFvcGcuc3AuZ292LmJyAGNwaWRUZXN0ZVJvb3Q=
Nov 08 16:04:15 auth-worker(default): Info: sql(user@domain,::1): query: SELECT password FROM mailbox WHERE username='www@seduc-0791.cidadaopg.sp.gov.br' AND active='1'
Nov 08 16:04:15 auth(default): Info: client out: OK     1       user=user@domain
Nov 08 16:04:15 auth(default): Info: master in: REQUEST 59      9340    1
Nov 08 16:04:15 auth-worker(default): Info: sql(user@domain,::1): SELECT CONCAT(mailbox.storagebasedirectory, '/', mailbox.storagenode, '/', mailbox.maildir) AS home, CONCAT('*:bytes=', mailbox.quota*1048576) AS quota_rule FROM mailbox,domain WHERE mailbox.username='user@domain' AND mailbox.domain='user@domain' AND mailbox.enableimapsecured=1 AND mailbox.domain=domain.domain AND domain.backupmx=0 AND domain.active=1 AND mailbox.active=1
Nov 08 16:04:15 auth(default): Info: master out: USER   59      user@domain      home=/var/vmail/vmail1/domain/user       quota_rule=*:bytes=104857600
Nov 08 16:04:15 IMAP(user@domain): Info: Loading modules from directory: /usr/lib/dovecot/modules/imap
Nov 08 16:04:15 IMAP(user@domain): Info: Module loaded: /usr/lib/dovecot/modules/imap/lib10_quota_plugin.so
Nov 08 16:04:15 IMAP(user@domain): Info: Module loaded: /usr/lib/dovecot/modules/imap/lib11_imap_quota_plugin.so
Nov 08 16:04:15 IMAP(user@domain): Info: Module loaded: /usr/lib/dovecot/modules/imap/lib20_autocreate_plugin.so
Nov 08 16:04:15 IMAP(user@domain): Info: Effective uid=1823, gid=1823, home=/var/vmail/vmail1/domain/user
Nov 08 16:04:15 IMAP(user@domain): Info: Quota root: name=user backend=dict args=:proxy::quotadict
Nov 08 16:04:15 IMAP(user@domain): Info: Quota rule: root=user mailbox=* bytes=104857600 messages=0
Nov 08 16:04:15 IMAP(user@domain): Info: Quota warning: bytes=89128960 (85%) messages=0 command=/usr/local/bin/dovecot-quota-warning.sh 85
Nov 08 16:04:15 IMAP(user@domain): Info: Quota warning: bytes=94371840 (90%) messages=0 command=/usr/local/bin/dovecot-quota-warning.sh 90
Nov 08 16:04:15 IMAP(user@domain): Info: Quota warning: bytes=99614720 (95%) messages=0 command=/usr/local/bin/dovecot-quota-warning.sh 95
Nov 08 16:04:15 IMAP(user@domain): Info: dict quota: user=user@domain, uri=proxy::quotadict, noenforcing=0
Nov 08 16:04:15 IMAP(user@domain): Info: Namespace: type=private, prefix=, sep=/, inbox=yes, hidden=no, list=yes, subscriptions=yes
Nov 08 16:04:15 IMAP(user@domain): Info: maildir: data=//var/vmail/vmail1/domain/user/Maildir/:INDEX=//var/vmail/vmail1/domain/user/Maildir/
Nov 08 16:04:15 IMAP(user@domain): Info: maildir++: root=//var/vmail/vmail1/domain/user/Maildir, index=, control=, inbox=//var/vmail/vmail1/domain/user/Maildir
Nov 08 16:04:15 IMAP(user@domain): Info: Namespace: type=shared, prefix=Shared/%u/, sep=/, inbox=no, hidden=no, list=children, subscriptions=yes
Nov 08 16:04:15 IMAP(user@domain): Info: shared: root=, index=, control=, inbox=
Nov 08 16:04:15 IMAP(user@domain): Info: Namespace : Using permissions from //var/vmail/vmail1/user@domain/user/Maildir: mode=0700 gid=-1
Nov 08 16:04:15 imap-login: Info: Login: user=<user@domain>, method=PLAIN, rip=::1, lip=::1, secured
Nov 08 16:04:15 IMAP(user@domain): Info: Disconnected: Logged out bytes=50/410
Nov 08 16:04:15 auth(default): Info: new auth connection: pid=9352

4

Re: Sending messages - IMAP Error

GuilhermeRocha wrote:

Postfix log:
warning: BB2A0514045: virtual_alias_maps map lookup problem for "user@domain"

Looks like there's something wrong in config files which configured in Postfix setting "virtual_alias_maps".
Please verify them first, for example:

# postconf virtual_alias_maps
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql/virtual_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_maps.cf, proxy:mysql:/etc/postfix/mysql/catchall_maps.cf, proxy:mysql:/etc/postfix/mysql/domain_alias_catchall_maps.cf

# cd /etc/postfix/mysql/
# postmap -q "user@domain" mysql:./virtual_alias_maps.cf
# postmap -q "user@domain" mysql:./domain_alias_maps.cf
# postmap -q "user@domain" mysql:./catchall_maps.cf
# postmap -q "user@domain" mysql:./domain_alias_catchall_maps.cf

5

Re: Sending messages - IMAP Error

I think the problem is in the postfix itself. I'm gonna try to reinstall it and ost the outcome.

6

Re: Sending messages - IMAP Error

I have reinstall the postfix, reconfigured it, and the message is still the same, but now it shows me this error on mail.log:
warning: connect to mysql server localhost: Access denied for user 'root'@'localhost' (using password: YES)
the error message keeps popping up...
I did tail the mail.log and constantly it shows atempts of map lookups for three user of my O.S., not from iredmail database, so as the test message i sent drom one of my test mailbox. Is there any related report, or known issue? Or this is some problem of my network?

7

Re: Sending messages - IMAP Error

IRedMail won't use MySQL root user at all, did you change Postfix config files manually?

8 (edited by GuilhermeRocha 2011-11-11 20:02:30)

Re: Sending messages - IMAP Error

yes... to be sure it can connect to the mysql with no restrictions... with the vmail user the error message is the same... obviously showing the vmail user on the log... The odd thing is that i can connect manualy to da data base with both useres.